python 2.6.1: add softft fix from libffi, this hopefully makes python-ctypes work...
authorKoen Kooi <koen@openembedded.org>
Mon, 9 Feb 2009 16:07:59 +0000 (17:07 +0100)
committerKoen Kooi <koen@openembedded.org>
Mon, 9 Feb 2009 16:07:59 +0000 (17:07 +0100)
packages/python/python_2.6.1.bb

index 8c3f354..ae9f8ee 100644 (file)
@@ -1,7 +1,7 @@
 require python.inc
 DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl tk zlib"
 DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-PR = "ml2"
+PR = "ml3"
 
 SRC_URI = "\
   http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
@@ -27,6 +27,11 @@ S = "${WORKDIR}/Python-${PV}"
 
 inherit autotools
 
+# The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources
+#Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :(
+TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
+TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
+
 #
 # copy config.h and an appropriate Makefile for distutils.sysconfig
 # which laters uses the information out of these to compile extensions