Add new plugin : AddStreamURL.
authorChang.H.S <jhs@dev3>
Fri, 29 Jun 2012 09:27:25 +0000 (18:27 +0900)
committerChang.H.S <jhs@dev3>
Fri, 29 Jun 2012 09:42:15 +0000 (18:42 +0900)
update dvbapp PR.

recipes/e2openplugins/enigma2-plugin-extensions-addstreamurl.bb [new file with mode: 0644]
recipes/e2openplugins/enigma2-plugin-extensions-remotestreamconvert.bb
recipes/e2openplugins/files/addstreamurl_uifix.patch [new file with mode: 0644]
recipes/enigma2/enigma2.bb
recipes/tasks/task-vuplus-enigma2.bb

diff --git a/recipes/e2openplugins/enigma2-plugin-extensions-addstreamurl.bb b/recipes/e2openplugins/enigma2-plugin-extensions-addstreamurl.bb
new file mode 100644 (file)
index 0000000..637955e
--- /dev/null
@@ -0,0 +1,20 @@
+MODULE = "AddStreamUrl"
+DESCRIPTION = "Add a stream url to your channellist"
+
+PR="r0"
+
+require openplugins.inc
+
+require assume-gplv2.inc
+
+SRC_URI += "file://addstreamurl_uifix.patch;patch=1;pnum=1"
+
+PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
+
+do_install() {
+        install -d ${D}${PLUGINPATH}
+        cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
+}
+
+FILES_${PN} = "${PLUGINPATH}"
+PACKAGES = ${PN}
index 1befd3a..c1b95e1 100755 (executable)
@@ -5,6 +5,16 @@ RDEPENDS_${PN} = "python-shell"
 
 PR="r0"
 
-require openplugins-distutils.inc
+require openplugins.inc
 
 require assume-gplv2.inc
+
+PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
+
+do_install() {
+        install -d ${D}${PLUGINPATH}
+        cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
+}
+
+FILES_${PN} = "${PLUGINPATH}"
+PACKAGES = ${PN}
diff --git a/recipes/e2openplugins/files/addstreamurl_uifix.patch b/recipes/e2openplugins/files/addstreamurl_uifix.patch
new file mode 100644 (file)
index 0000000..0109514
--- /dev/null
@@ -0,0 +1,38 @@
+diff --git a/plugin/plugin.py b/plugin/plugin.py
+index 7b03094..ab473f5 100755
+--- a/plugin/plugin.py
++++ b/plugin/plugin.py
+@@ -11,8 +11,8 @@ from enigma import eDVBDB
+ class LiveStreamingLinksHeader(Screen):
+       skin = """
+-      <screen position="c-150,c-100" size="300,200" title="">
+-              <widget name="menu" position="10,10" size="e-20,e-10" scrollbarMode="showOnDemand" />
++      <screen position="center,center" size="300,200" title="">
++              <widget name="menu" position="10,10" size="280,190" scrollbarMode="showOnDemand" />
+       </screen>"""
+       def __init__(self, session):
+@@ -47,15 +47,14 @@ class LiveStreamingLinksHeader(Screen):
+ class LiveStreamingLinks(Screen):
+       DIR_ENIGMA2 = '/etc/enigma2/'
+-
+       skin = """
+-      <screen position="c-300,c-210" size="600,420" title="">
+-              <widget name="menu" position="10,5" size="e-20,e-90" scrollbarMode="showOnDemand" />
+-              <widget source="statusbar" render="Label" position="c-300,e-80" zPosition="10" size="e-10,40" halign="center" valign="center" font="Regular;22" transparent="1" shadowColor="black" shadowOffset="-1,-1" />
+-              <ePixmap pixmap="skin_default/buttons/red.png" position="c-150,e-45" size="140,40" alphatest="on" />
+-              <ePixmap pixmap="skin_default/buttons/green.png" position="c-0,e-45" size="140,40" alphatest="on" />
+-              <widget source="key_red" render="Label" position="c-150,e-45" zPosition="1" size="140,40" font="Regular;20" halign="center" valign="center" backgroundColor="#9f1313" transparent="1" />
+-              <widget source="key_green" render="Label" position="c-0,e-45" zPosition="1" size="140,40" font="Regular;20" halign="center" valign="center" backgroundColor="#1f771f" transparent="1" />
++      <screen position="center,center" size="500,380" title="">
++              <widget name="menu" position="10,5" size="480,280" scrollbarMode="showOnDemand" />
++              <widget source="statusbar" render="Label" position="10,290" zPosition="10" size="480,40" halign="center" valign="center" font="Regular;22" foregroundColor="#000000" transparent="1" />
++              <ePixmap pixmap="skin_default/buttons/red.png" position="80,330" size="140,40" alphatest="on" />
++              <ePixmap pixmap="skin_default/buttons/green.png" position="280,330" size="140,40" alphatest="on" />
++              <widget source="key_red" render="Label" position="80,330" zPosition="1" size="140,40" font="Regular;20" halign="center" valign="center" backgroundColor="#9f1313" foregroundColor="#ffffff" transparent="1" />
++              <widget source="key_green" render="Label" position="280,330" zPosition="1" size="140,40" font="Regular;20" halign="center" valign="center" backgroundColor="#1f771f" foregroundColor="#ffffff" transparent="1" />
+       </screen>"""
+       def __init__(self, session):
index e3ebfe8..764e1be 100644 (file)
@@ -73,7 +73,7 @@ RDEPENDS_enigma2-plugin-extensions-dlnabrowser = "djmount fuse-utils libfuse2 li
 RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna libexif12 libavformat52 libavutil50 libavcodec52 libgsm1 libmp3lame0 libschroedinger-1.0-0 libtheora0 liboil"
 
 PN = "enigma2"
-PR = "r35"
+PR = "r36"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
index e4822dd..0dcde73 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Vuplus: E2 Task for the Vuplus Distribution"
 SECTION = "vuplus/base"
 LICENSE = "MIT"
-PR = "r20"
+PR = "r21"
 
 inherit task
 
@@ -37,6 +37,7 @@ RDEPENDS_task-vuplus-enigma2 = "\
   enigma2-plugin-extensions-dlnabrowser \
   enigma2-plugin-extensions-remotestreamconvert \
   enigma2-plugin-systemplugins-zappingmodeselection \
+  enigma2-plugin-extensions-addstreamurl \
 "
 
 RRECOMMENDS_task-vuplus-enigma2 = "\