perl-native: respect STAGING_BINDIR over prefix
authorPhil Blundell <philb@gnu.org>
Sun, 19 Oct 2008 08:37:53 +0000 (09:37 +0100)
committerPhil Blundell <philb@gnu.org>
Sun, 19 Oct 2008 08:37:53 +0000 (09:37 +0100)
packages/perl/perl-native_5.8.8.bb

index 0381777..3e215c5 100644 (file)
@@ -55,8 +55,10 @@ do_configure () {
         -Ud_csh \
         -Uusesfio \
         -Uusenm -des
-    sed 's!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
-         s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new
+    sed "s!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
+         s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!;
+        s!^installbin=.*!installbin=\'${STAGING_BINDIR}\'!;
+        s!^installsitebin=.*!installsitebin=\'${STAGING_BINDIR}\'!" < config.sh > config.sh.new
     mv config.sh.new config.sh
 }
 do_stage_append() {