[deep-standby manager] add plugin.
authorkos <kos@dev3>
Tue, 13 Nov 2012 09:37:26 +0000 (18:37 +0900)
committerkos <kos@dev3>
Tue, 13 Nov 2012 09:37:26 +0000 (18:37 +0900)
recipes/enigma2/enigma2-plugin-systemplugins-adsm.bb [new file with mode: 0644]
recipes/enigma2/enigma2-plugins.bb
recipes/tasks/task-vuplus-enigma2.bb

diff --git a/recipes/enigma2/enigma2-plugin-systemplugins-adsm.bb b/recipes/enigma2/enigma2-plugin-systemplugins-adsm.bb
new file mode 100644 (file)
index 0000000..32035c9
--- /dev/null
@@ -0,0 +1,37 @@
+DESCRIPTION = "Automatically Deep Standby Manager Plugins"
+SECTION  = "base"
+PRIORITY = "optional"
+LICENSE  = "proprietary"
+
+DEPENDS  = "enigma2"
+
+PR = "r0"
+PV = "20121113.3"
+
+SRC_URI = "http://code.vuplus.com/download/build.fc3abf29fb03f797e78f907928125638/embedded/adsm/vuplus_enigma2_adsm_${PV}.tar.gz"
+
+PLUGINPATH = "/usr/lib/enigma2/python/Plugins/SystemPlugins/ADSM"
+
+S = "${WORKDIR}/adsm"
+
+do_compile() {
+}
+
+do_install() {
+        install -d  ${D}/${PLUGINPATH}
+        install -m 0644 ${S}/__init__.py ${D}/${PLUGINPATH}
+        install -m 0644 ${S}/plugin.py ${D}/${PLUGINPATH}
+        install -m 0644 ${S}/helper.py ${D}/${PLUGINPATH}
+        install -m 0644 ${S}/singleton.py ${D}/${PLUGINPATH}
+        install -m 0644 ${S}/keymap.xml ${D}/${PLUGINPATH}
+}
+
+PACKAGE_ARCH := "${MACHINE_ARCH}"
+FILES_${PN} = "${PLUGINPATH}"
+PACKAGES = "${PN}"
+
+PROVIDES="${PACKAGES}"
+
+SRC_URI[md5sum] = "cee7c2960b3d652036dd804b99dc2c25"
+SRC_URI[sha256sum] = "d6a997d687126d217a2e64b58d7ebab31ffb3a49910d9295c11801a9fdfd0241"
+
index 0698168..7aa7cf7 100755 (executable)
@@ -43,6 +43,7 @@ S = "${WORKDIR}/git"
 DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen python-daap"
 DEPENDS += "enigma2"
 DEPENDS += "enigma2-plugin-extensions-openwebif"
+DEPENDS += "enigma2-plugin-systemplugins-adsm"
 
 
 def modify_po():
index 3bf8504..e1cd158 100644 (file)
@@ -81,6 +81,7 @@ RDEPENDS_task-vuplus-enigma2_append_vusolo2 = "\
   enigma2-plugin-extensions-hbbtv \
   enigma2-plugin-systemplugins-firmwareupgrade \
   enigma2-plugin-systemplugins-manualfancontrol \
+  enigma2-plugin-systemplugins-adsm \
 "
 
 RDEPENDS_task-vuplus-enigma2_append_vuuno = "\