util-linux-ng: put mountall in its own package, have it RRPLACE busybox-mountall...
authorKoen Kooi <koen@openembedded.org>
Tue, 2 Jun 2009 09:43:14 +0000 (11:43 +0200)
committerKoen Kooi <koen@Powerbook-3.local>
Fri, 5 Jun 2009 15:48:03 +0000 (17:48 +0200)
recipes/util-linux-ng/util-linux-ng.inc
recipes/util-linux-ng/util-linux-ng_2.15.bb

index 9c70b9e..39100b0 100644 (file)
@@ -28,8 +28,12 @@ FILES_util-linux-ng-mount = "/bin/mount.${PN} ${sysconfdir}/default/mountall"
 FILES_util-linux-ng-umount = "/bin/umount.${PN}"
 FILES_util-linux-ng-readprofile = "/usr/sbin/readprofile.${PN}"
 
+PACKAGES =+ "${PN}-mountall"
+FILES_${PN}-mountall = "${sysconfdir}/default/mountall"
+RREPLACES_${PN}-mountall = "busybox-mountall"
+
 RRECOMMENDS_${PN} = "util-linux-ng-fdisk util-linux-ng-cfdisk util-linux-ng-sfdisk util-linux-ng-mount util-linux-ng-readprofile "
-RDEPENDS_${PN} = "util-linux-ng-umount util-linux-ng-swaponoff util-linux-ng-losetup"
+RDEPENDS_${PN} = "${PN}-mountall util-linux-ng-umount util-linux-ng-swaponoff util-linux-ng-losetup"
 
 EXTRA_OECONF = "--disable-use-tty-group --disable-makeinstall-chown \
 --enable-kill --enable-last --enable-mesg --enable-raw --enable-login-utils \
index 773db28..c52fc75 100644 (file)
@@ -1,6 +1,6 @@
 require util-linux-ng.inc
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI += "file://fix-make-c.patch;patch=1 \
             file://optional-uuid.patch;patch=1 \