linux-omap-pm: add patch to register all OPPs, tweak defconfig
authorKoen Kooi <koen@openembedded.org>
Wed, 18 Feb 2009 12:59:23 +0000 (13:59 +0100)
committerKoen Kooi <koen@openembedded.org>
Wed, 18 Feb 2009 12:59:23 +0000 (13:59 +0100)
packages/linux/linux-omap-pm/beagleboard/defconfig
packages/linux/linux-omap-pm/register-all-OPPs.diff [new file with mode: 0644]
packages/linux/linux-omap-pm_git.bb

index 5189863..3688186 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Automatically generated make config: don't edit
 # Linux kernel version: 2.6.28-omap1
-# Tue Feb 17 22:52:35 2009
+# Wed Feb 18 13:57:41 2009
 #
 CONFIG_ARM=y
 CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -1489,7 +1489,7 @@ CONFIG_USB_DEVICEFS=y
 CONFIG_USB_DEVICE_CLASS=y
 # CONFIG_USB_DYNAMIC_MINORS is not set
 CONFIG_USB_SUSPEND=y
-# CONFIG_USB_OTG is not set
+CONFIG_USB_OTG=y
 # CONFIG_USB_OTG_WHITELIST is not set
 # CONFIG_USB_OTG_BLACKLIST_HUB is not set
 CONFIG_USB_MON=y
@@ -1500,9 +1500,11 @@ CONFIG_USB_MON=y
 # USB Host Controller Drivers
 #
 # CONFIG_USB_C67X00_HCD is not set
-# CONFIG_USB_EHCI_HCD is not set
-# CONFIG_OMAP_EHCI_PHY_MODE is not set
+CONFIG_USB_EHCI_HCD=y
+CONFIG_OMAP_EHCI_PHY_MODE=y
 # CONFIG_OMAP_EHCI_TLL_MODE is not set
+# CONFIG_USB_EHCI_ROOT_HUB_TT is not set
+# CONFIG_USB_EHCI_TT_NEWSCHED is not set
 # CONFIG_USB_ISP116X_HCD is not set
 # CONFIG_USB_OHCI_HCD is not set
 # CONFIG_USB_SL811_HCD is not set
@@ -1515,9 +1517,10 @@ CONFIG_USB_MUSB_SOC=y
 # OMAP 343x high speed USB support
 #
 # CONFIG_USB_MUSB_HOST is not set
-CONFIG_USB_MUSB_PERIPHERAL=y
-# CONFIG_USB_MUSB_OTG is not set
+# CONFIG_USB_MUSB_PERIPHERAL is not set
+CONFIG_USB_MUSB_OTG=y
 CONFIG_USB_GADGET_MUSB_HDRC=y
+CONFIG_USB_MUSB_HDRC_HCD=y
 # CONFIG_MUSB_PIO_ONLY is not set
 CONFIG_USB_INVENTRA_DMA=y
 # CONFIG_USB_TI_CPPI_DMA is not set
@@ -1638,6 +1641,7 @@ CONFIG_USB_LED=m
 # CONFIG_USB_IDMOUSE is not set
 # CONFIG_USB_FTDI_ELAN is not set
 # CONFIG_USB_APPLEDISPLAY is not set
+# CONFIG_USB_SISUSBVGA is not set
 # CONFIG_USB_LD is not set
 # CONFIG_USB_TRANCEVIBRATOR is not set
 # CONFIG_USB_IOWARRIOR is not set
diff --git a/packages/linux/linux-omap-pm/register-all-OPPs.diff b/packages/linux/linux-omap-pm/register-all-OPPs.diff
new file mode 100644 (file)
index 0000000..95e6b9b
--- /dev/null
@@ -0,0 +1,12 @@
+--- /tmp/clock34xx.c   2009-02-18 13:51:18.000000000 +0100
++++ git/arch/arm/mach-omap2/clock34xx.c        2009-02-18 13:51:51.000000000 +0100
+@@ -698,8 +698,7 @@
+       if (!mpu_opps)
+               return;
+-      /* Avoid registering the 120% Overdrive with CPUFreq */
+-      prcm = mpu_opps + MAX_VDD1_OPP - 1;
++      prcm = mpu_opps + MAX_VDD1_OPP;
+       for (; prcm->rate; prcm--) {
+               freq_table[i].index = i;
+               freq_table[i].frequency = prcm->rate / 1000;
index 6481b0c..ddaff33 100644 (file)
@@ -10,7 +10,7 @@ DEFAULT_PREFERENCE = "-1"
 SRCREV = "65d02c2c7fe676369b7162459feec60268c7f4ba"
 
 PV = "2.6.28-pm1+gitr${SRCREV}"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;protocol=git;branch=pm \
           file://defconfig"
@@ -45,6 +45,7 @@ SRC_URI_append = " \
            file://0001-ASoC-Add-support-for-OMAP3-EVM.patch;patch=1 \
            file://0001-This-merges-Steve-Kipisz-USB-EHCI-support.-He-star.patch;patch=1 \
            file://dss2.diff;patch=1 \
+           file://register-all-OPPs.diff;patch=1 \
 "