evtest_1.23.bb: New recipe
authorKhem Raj <raj.khem@gmail.com>
Mon, 16 Feb 2009 07:45:52 +0000 (23:45 -0800)
committerKhem Raj <raj.khem@gmail.com>
Mon, 16 Feb 2009 07:45:52 +0000 (23:45 -0800)
conf/checksums.ini
packages/evtest/evtest_1.23.bb [new file with mode: 0644]

index 5b8e2ed..e867c6e 100644 (file)
@@ -5102,6 +5102,10 @@ sha256=c424e6dd5cc0d998a311f5c49835de9803da4dbcb74ca7fbda29c1b953bf6d6b
 md5=ad0e463ab1fe596fc52c03403a9b9f1e
 sha256=d8803313e2a0b3fa3fe20fe613ac3ec85ec6848d5d446dd02e9cc5be8194f65c
 
+[http://beagleboard.googlecode.com/files/evtest.c]
+md5=da26fda6df8835a7cb95182e1fabe912
+sha256=ba2bdf6887eb0ef606402d51a2f4e68510d68dec5afd9f4d30d787950dece770
+
 [http://enlightenment.freedesktop.org/files/ewl-0.0.4.007.tar.gz]
 md5=29bc8aec80b53480c2ea53aea1796e15
 sha256=0a0dba00517013082b8e094b4b7753162cf5fb71a170eb54cbc2eaa35717d5f6
@@ -22050,14 +22054,14 @@ sha256=6fb80935fe208538131ce2c4178221bab1078a1656306bce8909c19887e2e5a1
 md5=05fada181e12bfa94b52f0b10395b28c
 sha256=a4f15c73e2b67c888cbedfaa8093661dff6cb859357c197c60f3026baddb939e
 
-[http://downloads.sourceforge.net/wireshark/wireshark-1.0.5.tar.bz2]
-md5=4c6a93e00123d8bb7af48a009519aca4
-sha256=4f923e24d674ac62ded3da402a4de6d402886d80e3d7cac91cf026921f32fcf7
-
 [http://heanet.dl.sourceforge.net/wireshark/wireshark-0.99.4.tar.bz2]
 md5=05fada181e12bfa94b52f0b10395b28c
 sha256=a4f15c73e2b67c888cbedfaa8093661dff6cb859357c197c60f3026baddb939e
 
+[http://downloads.sourceforge.net/wireshark/wireshark-1.0.5.tar.bz2]
+md5=4c6a93e00123d8bb7af48a009519aca4
+sha256=4f923e24d674ac62ded3da402a4de6d402886d80e3d7cac91cf026921f32fcf7
+
 [ftp://ftp.elmeg.de/artem/ClientCards/11b/linux/wl_lkm_718_release.tar.gz]
 md5=049c6c3d410e9f46884627b57485d3e7
 sha256=a28c7ea94d57a5354b7de06cf5f6416d80a40596911c129d4b6a4087dc916831
diff --git a/packages/evtest/evtest_1.23.bb b/packages/evtest/evtest_1.23.bb
new file mode 100644 (file)
index 0000000..4c5d195
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright (C) 2009 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Event device test program"
+AUTHOR = "Vojtech Pavlik <vojtech@suse.cz>"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+PR = "r0"
+
+SRC_URI = "http://beagleboard.googlecode.com/files/evtest.c"
+S = "${WORKDIR}"
+
+do_compile() {
+    ${CC} evtest.c -o evtest -I${STAGING_INCDIR} -L${STAGING_LIBDIR}
+}
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 evtest ${D}${bindir}
+}