recipes/opkg/files/configure : fix the case where this is no splash installed.
authorGraeme Gregory <dp@xora.org.uk>
Wed, 29 Apr 2009 13:25:14 +0000 (14:25 +0100)
committerGraeme Gregory <dp@xora.org.uk>
Wed, 29 Apr 2009 13:32:37 +0000 (14:32 +0100)
recipes/opkg/opkg*.bb : bump PR for affected recipes

recipes/opkg/files/configure
recipes/opkg/opkg-nogpg-nocurl_svn.bb
recipes/opkg/opkg-nogpg_svn.bb
recipes/opkg/opkg_svn.bb

index 318ccb1..d5dd74d 100644 (file)
@@ -7,16 +7,18 @@ status_pulse || true
 fi
 
 # run configure in bg
-opkg-cl configure &
-PID=$!
-
-if [ -f /etc/default/splashfuncs ]; then
+if [  -f /etc/default/splashfuncs ]; then
+  opkg-cl configure &
+  PID=$!
+  
   # while configure still running loop
   while test -d /proc/$PID; do
   # tick to splash so it doesn't time out
     status_tick || true
     sleep 1
   done
+else
+  opkg-cl configure
 fi
 
 # delete myself
index 60da447..c390174 100644 (file)
@@ -11,7 +11,7 @@ SRC_URI += " \
            file://opkg_wget_nogpg_03_fix_tmpdirs.patch;patch=1 \
            file://opkg_wget_nogpg_04_default_tmpdir.patch;patch=1 \
           "
-PR = "r6"
+PR = "r7"
 
 SRCREV = "${SRCREV_pn-opkg}"
 
index c0a4d4a..b6bb4b3 100644 (file)
@@ -3,7 +3,7 @@ require opkg_svn.bb
 DEPENDS = "curl"
 PROVIDES += "opkg"
 
-PR = "r12"
+PR = "r13"
 
 SRCREV = "${SRCREV_pn-opkg}"
 
index 749fa1e..d286377 100644 (file)
@@ -1,6 +1,6 @@
 require opkg.inc
 
-PR = "r12"
+PR = "r13"
 
 PACKAGES =+ "libopkg-dev libopkg"