e2fsprogs: use Koen's trick to get GNU_HASH section in binaries
authorMarcin Juszkiewicz <hrw@openembedded.org>
Wed, 18 Feb 2009 10:33:12 +0000 (11:33 +0100)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Wed, 18 Feb 2009 10:33:12 +0000 (11:33 +0100)
This makes insane.bbclass happy.

packages/e2fsprogs/e2fsprogs_1.38.bb

index 4957ba7..5687556 100644 (file)
@@ -1,11 +1,13 @@
 require e2fsprogs.inc
 
-PR = "r18"
+PR = "r19"
 
 SRC_URI += "file://no-hardlinks.patch;patch=1 \
            file://mkinstalldirs.patch;patch=1 \
           "
 
+TARGET_CC_ARCH += "${LDFLAGS}"
+
 do_compile_prepend () {
        find ./ -print|xargs chmod u=rwX
        ( cd util; ${BUILD_CC} subst.c -o subst )