bash: unified, bumped PR
authorMarcin Juszkiewicz <hrw@openembedded.org>
Tue, 20 Feb 2007 08:30:44 +0000 (08:30 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Tue, 20 Feb 2007 08:30:44 +0000 (08:30 +0000)
packages/bash/bash.inc [new file with mode: 0644]
packages/bash/bash_3.0.bb
packages/bash/bash_3.2.bb

diff --git a/packages/bash/bash.inc b/packages/bash/bash.inc
new file mode 100644 (file)
index 0000000..80aedfa
--- /dev/null
@@ -0,0 +1,26 @@
+DESCRIPTION = "An sh-compatible command language interpreter."
+HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+DEPENDS = "ncurses"
+SECTION = "base/shell"
+LICENSE = "GPL"
+
+inherit autotools gettext
+
+PARALLEL_MAKE = ""
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+EXTRA_OECONF = "--with-ncurses"
+export CC_FOR_BUILD = "${BUILD_CC}"
+
+do_configure () {
+       gnu-configize
+       oe_runconf
+}
+
+pkg_postinst () {
+       touch ${sysconfdir}/shells
+       grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
+       grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
+}
index 2a8e0ee..b4fb26a 100644 (file)
@@ -1,31 +1,6 @@
-DESCRIPTION = "An sh-compatible command language interpreter."
-HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-DEPENDS = "ncurses"
-SECTION = "base/shell"
-LICENSE = "GPL"
-PR = "r7"
+require bash.inc
+PR = "r8"
 
 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
         file://bash-3.0-fixes.patch;patch=1 \
        file://signames-mipsel.diff;patch=1"
-
-inherit autotools gettext
-
-PARALLEL_MAKE = ""
-
-bindir = "/bin"
-sbindir = "/sbin"
-
-EXTRA_OECONF = "--with-ncurses"
-export CC_FOR_BUILD = "${BUILD_CC}"
-
-do_configure () {
-       gnu-configize
-       oe_runconf
-}
-
-pkg_postinst () {
-       touch ${sysconfdir}/shells
-       grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
-       grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
-}
index fd59b84..8e0293e 100644 (file)
@@ -1,29 +1,5 @@
-DESCRIPTION = "An sh-compatible command language interpreter."
-HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-DEPENDS = "ncurses"
-SECTION = "base/shell"
-LICENSE = "GPL"
+require bash.inc
+PR = "r1"
 
 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
            file://001-005.patch;patch=1"
-
-inherit autotools gettext
-
-PARALLEL_MAKE = ""
-
-bindir = "/bin"
-sbindir = "/sbin"
-
-EXTRA_OECONF = "--with-ncurses"
-export CC_FOR_BUILD = "${BUILD_CC}"
-
-do_configure () {
-       gnu-configize
-       oe_runconf
-}
-
-pkg_postinst () {
-       touch ${sysconfdir}/shells
-       grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
-       grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
-}