vpnc: add 0.5.1, unify
authorJunqian Gordon Xu <xjqian@gmail.com>
Sun, 16 Mar 2008 07:49:40 +0000 (07:49 +0000)
committerJunqian Gordon Xu <xjqian@gmail.com>
Sun, 16 Mar 2008 07:49:40 +0000 (07:49 +0000)
* 0.5.1: patch makeman.pl which calls crosscompiled vpnc binary
* verified vpnc-script.patch (0.3.3) has been fixed upstream in 0.5.1

packages/vpnc/files/makeman.patch [new file with mode: 0644]
packages/vpnc/files/vpnc0.5.1--long-help [new file with mode: 0644]
packages/vpnc/vpnc.inc [new file with mode: 0644]
packages/vpnc/vpnc_0.3.2.bb
packages/vpnc/vpnc_0.3.3.bb
packages/vpnc/vpnc_0.5.1.bb [new file with mode: 0644]

diff --git a/packages/vpnc/files/makeman.patch b/packages/vpnc/files/makeman.patch
new file mode 100644 (file)
index 0000000..13a40ed
--- /dev/null
@@ -0,0 +1,11 @@
+--- vpnc-0.5.1/makeman.pl.old  2008-03-16 02:17:59.000000000 -0500
++++ vpnc-0.5.1/makeman.pl      2008-03-16 02:29:34.000000000 -0500
+@@ -29,7 +29,7 @@ my $vpnc = './vpnc';
+ # indenting lists (those originally starting with an asterisk). I hope
+ # this pays off when converting the manpage to HTML or such.
+-open my $LONGHELP, '-|', "$vpnc --long-help";
++open my $LONGHELP, '-|', "cat ../vpnc0.5.1--long-help";
+ my $vpnc_options    = '';
+ my $relative_indent = 0;
+ my $indent_needed   = 0;
diff --git a/packages/vpnc/files/vpnc0.5.1--long-help b/packages/vpnc/files/vpnc0.5.1--long-help
new file mode 100644 (file)
index 0000000..4afa2b7
--- /dev/null
@@ -0,0 +1,173 @@
+Usage: vpnc [--version] [--print-config] [--help] [--long-help] [options] [config files]
+
+Options:
+  --gateway <ip/hostname>
+      IP/name of your IPSec gateway
+  conf-variable: IPSec gateway <ip/hostname>
+
+  --id <ASCII string>
+      your group name
+  conf-variable: IPSec ID <ASCII string>
+
+  (configfile only option) 
+      your group password (cleartext)
+  conf-variable: IPSec secret <ASCII string>
+
+  (configfile only option) 
+      your group password (obfuscated)
+  conf-variable: IPSec obfuscated secret <hex string>
+
+  --username <ASCII string>
+      your username
+  conf-variable: Xauth username <ASCII string>
+
+  (configfile only option) 
+      your password (cleartext)
+  conf-variable: Xauth password <ASCII string>
+
+  (configfile only option) 
+      your password (obfuscated)
+  conf-variable: Xauth obfuscated password <hex string>
+
+  --domain <ASCII string>
+      (NT-) Domain name for authentication
+  conf-variable: Domain <ASCII string>
+
+  --xauth-inter 
+      enable interactive extended authentication (for challenge response auth)
+  conf-variable: Xauth interactive
+
+  --vendor <cisco/netscreen>
+      vendor of your IPSec gateway
+    Default: cisco
+  conf-variable: Vendor <cisco/netscreen>
+
+  --natt-mode <natt/none/force-natt/cisco-udp>
+      Which NAT-Traversal Method to use:
+       * natt -- NAT-T as defined in RFC3947
+       * none -- disable use of any NAT-T method
+       * force-natt -- always use NAT-T encapsulation even
+                       without presence of a NAT device
+                       (useful if the OS captures all ESP traffic)
+       * cisco-udp -- Cisco proprietary UDP encapsulation, commonly over Port 10000
+      Note: cisco-tcp encapsulation is not yet supported
+    Default: natt
+  conf-variable: NAT Traversal Mode <natt/none/force-natt/cisco-udp>
+
+  --script <command>
+      command is executed using system() to configure the interface,
+      routing and so on. Device name, IP, etc. are passed using enviroment
+      variables, see README. This script is executed right after ISAKMP is
+      done, but before tunneling is enabled. It is called when vpnc
+      terminates, too
+    Default: /etc/vpnc/vpnc-script
+  conf-variable: Script <command>
+
+  --dh <dh1/dh2/dh5>
+      name of the IKE DH Group
+    Default: dh2
+  conf-variable: IKE DH Group <dh1/dh2/dh5>
+
+  --pfs <nopfs/dh1/dh2/dh5/server>
+      Diffie-Hellman group to use for PFS
+    Default: server
+  conf-variable: Perfect Forward Secrecy <nopfs/dh1/dh2/dh5/server>
+
+  --enable-1des 
+      enables weak single DES encryption
+  conf-variable: Enable Single DES
+
+  --enable-no-encryption 
+      enables using no encryption for data traffic (key exchanged must be encrypted)
+  conf-variable: Enable no encryption
+
+  --application-version <ASCII string>
+      Application Version to report. Note: Default string is generated at runtime.
+    Default: Cisco Systems VPN Client 0.5.1:Linux
+  conf-variable: Application version <ASCII string>
+
+  --ifname <ASCII string>
+      visible name of the TUN/TAP interface
+  conf-variable: Interface name <ASCII string>
+
+  --ifmode <tun/tap>
+      mode of TUN/TAP interface:
+       * tun: virtual point to point interface (default)
+       * tap: virtual ethernet interface
+    Default: tun
+  conf-variable: Interface mode <tun/tap>
+
+  --debug <0/1/2/3/99>
+      Show verbose debug messages
+       *  0: Do not print debug information.
+       *  1: Print minimal debug information.
+       *  2: Show statemachine and packet/payload type information.
+       *  3: Dump everything exluding authentication data.
+       * 99: Dump everything including authentication data (e.g. passwords).
+  conf-variable: Debug <0/1/2/3/99>
+
+  --no-detach 
+      Don't detach from the console after login
+  conf-variable: No Detach
+
+  --pid-file <filename>
+      store the pid of background process in <filename>
+    Default: /var/run/vpnc/pid
+  conf-variable: Pidfile <filename>
+
+  --local-addr <ip/hostname>
+      local IP to use for ISAKMP / ESP / ... (0.0.0.0 == automatically assign)
+    Default: 0.0.0.0
+  conf-variable: Local Addr <ip/hostname>
+
+  --local-port <0-65535>
+      local ISAKMP port number to use (0 == use random port)
+    Default: 500
+  conf-variable: Local Port <0-65535>
+
+  --udp-port <0-65535>
+      Local UDP port number to use (0 == use random port).
+      This is only relevant if cisco-udp nat-traversal is used.
+      This is the _local_ port, the remote udp port is discovered automatically.
+      It is especially not the cisco-tcp port.
+    Default: 10000
+  conf-variable: Cisco UDP Encapsulation Port <0-65535>
+
+  --dpd-idle <0,10-86400>
+      Send DPD packet after not receiving anything for <idle> seconds.
+      Use 0 to disable DPD completely (both ways).
+    Default: 300
+  conf-variable: DPD idle timeout (our side) <0,10-86400>
+
+  --non-inter 
+      Don't ask anything, exit on missing options
+  conf-variable: Noninteractive
+
+  --auth-mode <psk/cert/hybrid>
+      Authentication mode:
+       * psk:    pre-shared key (default)
+       * cert:   server + client certificate (not implemented yet)
+       * hybrid: server certificate + xauth (if built with openssl support)
+    Default: psk
+  conf-variable: IKE Authmode <psk/cert/hybrid>
+
+  --ca-file <filename>
+      filename and path to the CA-PEM-File
+  conf-variable: CA-File <filename>
+
+  --ca-dir <directory>
+      path of the trusted CA-Directory
+    Default: /etc/ssl/certs
+  conf-variable: CA-Dir <directory>
+
+  --dns-update 
+      DEPRECATED extension, see README.Debian for details
+    Default: Yes
+  conf-variable: DNSUpdate
+
+  --target-networks 
+      DEPRECATED extension, see README.Debian for details
+    Default: 
+  conf-variable: Target Networks
+
+Report bugs to vpnc@unix-ag.uni-kl.de
diff --git a/packages/vpnc/vpnc.inc b/packages/vpnc/vpnc.inc
new file mode 100644 (file)
index 0000000..4ca82eb
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "A client for the Cisco3000 VPN Concentrator"
+HOMEPAGE = "http://www.unix-ag.uni-kl.de/~massar/vpnc/"
+AUTHOR = "Maurice Massar vpnc@unix-ag.uni-kl.de"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libgcrypt"
+RDEPENDS = "kernel-module-tun"
+
+CFLAGS_append = ' -DVERSION=\\"${PV}\\"'
+LDFLAGS_append = " -lgcrypt -lgpg-error"
+
+do_install () {
+       oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr' install
+       rm -f ${D}${sysconfdir}/vpnc/vpnc.conf #This file is useless
+       install ${WORKDIR}/default.conf ${D}${sysconfdir}/vpnc/default.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/vpnc/default.conf"
index d542408..1a3f7fc 100644 (file)
@@ -1,15 +1,5 @@
-DESCRIPTION = "A client for the Cisco3000 VPN Concentrator"
-SECTION = "console/network"
-PRIORITY = "optional"
-LICENSE = "GPL"
-DEPENDS = "libgcrypt"
+require vpnc.inc
 
-SRC_URI = "http://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-${PV}.tar.gz"
-
-CFLAGS_append = ' -DVERSION=\\"${PV}\\"'
-LDFLAGS_append = " -lgcrypt -lgpg-error"
+PR = "r1"
 
-do_install () {
-        install -d ${D}${sbindir}
-       install -m 0755 vpnc ${D}${sbindir}
-}
+SRC_URI = "http://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-${PV}.tar.gz"
index 8aee0fa..3c83976 100644 (file)
@@ -1,23 +1,7 @@
-DESCRIPTION = "A client for the Cisco3000 VPN Concentrator"
-SECTION = "console/network"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.unix-ag.uni-kl.de/~massar/vpnc/"
-LICENSE = "GPL"
-DEPENDS = "libgcrypt"
-RDEPENDS = "kernel-module-tun"
-PR = "r1"
+require vpnc.inc
+
+PR = "r2"
 
 SRC_URI = "http://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-${PV}.tar.gz \
            file://vpnc-script.patch;patch=1 \
            file://default.conf"
-
-CFLAGS_append = ' -DVERSION=\\"${PV}\\"'
-LDFLAGS_append = " -lgcrypt -lgpg-error"
-
-do_install () {
-       oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr' install
-       rm -f ${D}${sysconfdir}/vpnc/vpnc.conf #This file is useless
-       install ${WORKDIR}/default.conf ${D}${sysconfdir}/vpnc/default.conf
-}
-
-CONFFILES_${PN} = "${sysconfdir}/vpnc/default.conf"
diff --git a/packages/vpnc/vpnc_0.5.1.bb b/packages/vpnc/vpnc_0.5.1.bb
new file mode 100644 (file)
index 0000000..3591984
--- /dev/null
@@ -0,0 +1,8 @@
+require vpnc.inc
+
+PR = "r0"
+
+SRC_URI = "http://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-${PV}.tar.gz \
+           file://makeman.patch;patch=1 \
+           file://vpnc${PV}--long-help \
+           file://default.conf"