libcap2-2.16: fix initial build using patch from gentoo
authorAndreas Oberritter <obi@opendreambox.org>
Tue, 21 Jul 2009 12:02:48 +0000 (14:02 +0200)
committerAndreas Oberritter <obi@opendreambox.org>
Tue, 21 Jul 2009 12:02:48 +0000 (14:02 +0200)
recipes/libcap/libcap2-2.16/0001-build-system-fixes.patch [new file with mode: 0644]
recipes/libcap/libcap2-2.16/make.patch [deleted file]
recipes/libcap/libcap2_2.16.bb

diff --git a/recipes/libcap/libcap2-2.16/0001-build-system-fixes.patch b/recipes/libcap/libcap2-2.16/0001-build-system-fixes.patch
new file mode 100644 (file)
index 0000000..9f5d4fb
--- /dev/null
@@ -0,0 +1,154 @@
+From 7ee197885e113878aedab58bdda80302e42aff4c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 16 Nov 2008 09:10:31 -0500
+Subject: [PATCH] build system fixes
+
+This touches up the homebrewed build system to work much better "out of the
+box" for people.  Specifically:
+       - allow toolchain vars to be set via environment
+               - CC / BUILD_CC / AR / RANLIB
+               - CFLAGS / CPPFLAGS / LDFLAGS
+       - split CPPFLAGS out of CFLAGS
+       - break -fPIC out of global CFLAGS and only use where needed
+       - use LDLIBS for libraries, not LDFLAGS
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Make.Rules       |   28 ++++++++++++++--------------
+ libcap/Makefile  |   11 ++++++-----
+ pam_cap/Makefile |    6 +++---
+ progs/Makefile   |    2 +-
+ 4 files changed, 24 insertions(+), 23 deletions(-)
+
+diff --git a/Make.Rules b/Make.Rules
+index 6e63a5b..32cb5ea 100644
+--- a/Make.Rules
++++ b/Make.Rules
+@@ -42,27 +42,27 @@ MINOR=16
+ # Compilation specifics
+-KERNEL_HEADERS := $(topdir)/libcap/include
+-IPATH += -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
+-
+-CC := gcc
+-CFLAGS := -O2
+-BUILD_CC := $(CC)
+-BUILD_CFLAGS := $(CFLAGS) $(IPATH)
+-AR := ar
+-RANLIB := ranlib
+-DEBUG = -g #-DDEBUG
+-WARNINGS=-fPIC -Wall -Wwrite-strings \
++CC ?= gcc
++BUILD_CC ?= $(CC)
++AR ?= ar
++RANLIB ?= ranlib
++CFLAGS ?= -O2
++BUILD_CFLAGS ?= $(CFLAGS)
++WARNINGS=-Wall -Wwrite-strings \
+         -Wpointer-arith -Wcast-qual -Wcast-align \
+         -Wstrict-prototypes -Wmissing-prototypes \
+         -Wnested-externs -Winline -Wshadow
+ LD=$(CC) -Wl,-x -shared
+-LDFLAGS := #-g
++LDFLAGS ?= #-g
+-SYSTEM_HEADERS = /usr/include
++KERNEL_HEADERS = $(topdir)/libcap/include
++LIBCAP_CPPFLAGS = -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
++CPPFLAGS += $(LIBCAP_CPPFLAGS)
++BUILD_CPPFLAGS += $(LIBCAP_CPPFLAGS)
+ INCS=$(topdir)/libcap/include/sys/capability.h
+ LDFLAGS += -L$(topdir)/libcap
+-CFLAGS += -Dlinux $(WARNINGS) $(DEBUG) $(IPATH)
++CPPFLAGS += -Dlinux
++CFLAGS += $(WARNINGS)
+ PAM_CAP := $(shell if [ -f /usr/include/security/pam_modules.h ]; then echo yes ; else echo no ; fi)
+ INDENT := $(shell if [ -n "$(which indent 2>/dev/null)" ]; then echo "| indent -kr" ; fi)
+ DYNAMIC := $(shell if [ ! -d "$(topdir)/.git" ]; then echo yes; fi)
+diff --git a/libcap/Makefile b/libcap/Makefile
+index 8a61752..cf99523 100644
+--- a/libcap/Makefile
++++ b/libcap/Makefile
+@@ -16,7 +16,7 @@ FILES=cap_alloc cap_proc cap_extint cap_flag cap_text
+ # no support).
+ ifeq ($(LIBATTR),yes)
+ FILES += cap_file
+-LDFLAGS += -lattr
++LDLIBS += -lattr
+ endif
+ INCLS=libcap.h cap_names.h $(INCS)
+@@ -24,6 +24,7 @@ OBJS=$(addsuffix .o, $(FILES))
+ MAJLIBNAME=$(LIBNAME).$(VERSION)
+ MINLIBNAME=$(MAJLIBNAME).$(MINOR)
+ GPERF_OUTPUT = _caps_output.gperf
++CFLAGS += -fPIC
+ all: $(MINLIBNAME) $(STALIBNAME)
+@@ -33,7 +34,7 @@ INCLUDE_GPERF_OUTPUT = -include $(GPERF_OUTPUT)
+ endif
+ _makenames: _makenames.c cap_names.list.h
+-      $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
++      $(BUILD_CC) $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $< -o $@
+ cap_names.h: _makenames
+       ./_makenames > cap_names.h
+@@ -50,15 +51,15 @@ $(STALIBNAME): $(OBJS)
+       $(RANLIB) $@
+ $(MINLIBNAME): $(OBJS)
+-      $(LD) $(CFLAGS) $(LDFLAGS) -Wl,-soname,$(MAJLIBNAME) -o $@ $^
++      $(LD) $(CFLAGS) $(LDFLAGS) -Wl,-soname,$(MAJLIBNAME) -o $@ $^ $(LDLIBS)
+       ln -sf $(MINLIBNAME) $(MAJLIBNAME)
+       ln -sf $(MAJLIBNAME) $(LIBNAME)
+ %.o: %.c $(INCLS)
+-      $(CC) $(CFLAGS) -c $< -o $@
++      $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+ cap_text.o: cap_text.c $(USE_GPERF_OUTPUT) $(INCLS)
+-      $(CC) $(CFLAGS) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
++      $(CC) $(CFLAGS) $(CPPFLAGS) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
+ install: all
+       mkdir -p -m 0755 $(INCDIR)/sys
+diff --git a/pam_cap/Makefile b/pam_cap/Makefile
+index eae88ed..bef59d2 100644
+--- a/pam_cap/Makefile
++++ b/pam_cap/Makefile
+@@ -14,13 +14,13 @@ install: all
+       install -m 0755 pam_cap.so $(LIBDIR)/security
+ pam_cap.so: pam_cap.o
+-      $(LD) $(LDFLAGS) -o pam_cap.so $< $(LDLIBS)
++      $(LD) $(CFLAGS) $(LDFLAGS) -o pam_cap.so $< $(LDLIBS) -lpam
+ pam_cap.o: pam_cap.c
+-      $(CC) $(CFLAGS) -c $< -o $@
++      $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+ testcompile: test.c pam_cap.o
+-      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $+ -lpam -ldl $(LDLIBS)
++      $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $+ -lpam -ldl $(LDLIBS)
+ clean:
+       rm -f *.o *.so testcompile *~
+diff --git a/progs/Makefile b/progs/Makefile
+index a1542dc..612cf86 100644
+--- a/progs/Makefile
++++ b/progs/Makefile
+@@ -22,7 +22,7 @@ $(BUILD): %: %.o
+       $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< $(LDLIBS)
+ %.o: %.c $(INCS)
+-      $(CC) $(CFLAGS) -c $< -o $@
++      $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+ install: all
+       mkdir -p -m 0755 $(SBINDIR)
+-- 
+1.6.0.4
+
diff --git a/recipes/libcap/libcap2-2.16/make.patch b/recipes/libcap/libcap2-2.16/make.patch
deleted file mode 100644 (file)
index 3672f77..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- libcap-2.16/Make.Rules.orig        2009-03-07 18:50:23.000000000 +0100
-+++ libcap-2.16/Make.Rules     2009-03-07 18:50:44.000000000 +0100
-@@ -45,19 +45,12 @@
- KERNEL_HEADERS := $(topdir)/libcap/include
- IPATH += -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
--CC := gcc
--CFLAGS := -O2
--BUILD_CC := $(CC)
--BUILD_CFLAGS := $(CFLAGS) $(IPATH)
--AR := ar
--RANLIB := ranlib
-+LD=$(CC) -Wl,-x -shared
- DEBUG = -g #-DDEBUG
- WARNINGS=-fPIC -Wall -Wwrite-strings \
-         -Wpointer-arith -Wcast-qual -Wcast-align \
-         -Wstrict-prototypes -Wmissing-prototypes \
-         -Wnested-externs -Winline -Wshadow
--LD=$(CC) -Wl,-x -shared
--LDFLAGS := #-g
- SYSTEM_HEADERS = /usr/include
- INCS=$(topdir)/libcap/include/sys/capability.h
index 8c9803d..09d7094 100644 (file)
@@ -3,13 +3,13 @@ PRIORITY = "optional"
 SECTION = "libs"
 LICENSE = "GPL"
 DEPENDS = "bison-native flex-native libattr"
-PR = "r0"
+PR = "r1"
 
 CFLAGS_append = " -I${S}/libcap/include"
 LDFLAGS_prepend = "-L../libcap"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/security/linux-privs/libcap2/libcap-${PV}.tar.bz2 \
-          file://make.patch;patch=1 \
+          file://0001-build-system-fixes.patch;patch=1 \
        "
 
 S = "${WORKDIR}/libcap-${PV}"