gnome-vfs: added 2.22.0 - partially close #4061
authorMarcin Juszkiewicz <hrw@openembedded.org>
Sun, 16 Mar 2008 08:36:55 +0000 (08:36 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Sun, 16 Mar 2008 08:36:55 +0000 (08:36 +0000)
packages/gnome/gnome-vfs-2.22.0/.mtn2git_empty [new file with mode: 0644]
packages/gnome/gnome-vfs-2.22.0/gconftool-lossage.patch [new file with mode: 0644]
packages/gnome/gnome-vfs-2.22.0/gnome-vfs-no-kerberos.patch [new file with mode: 0644]
packages/gnome/gnome-vfs_2.22.0.bb [new file with mode: 0644]

diff --git a/packages/gnome/gnome-vfs-2.22.0/.mtn2git_empty b/packages/gnome/gnome-vfs-2.22.0/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gnome/gnome-vfs-2.22.0/gconftool-lossage.patch b/packages/gnome/gnome-vfs-2.22.0/gconftool-lossage.patch
new file mode 100644 (file)
index 0000000..3dbc130
--- /dev/null
@@ -0,0 +1,11 @@
+--- gnome-vfs-2.6.0/configure.in~      2004-03-22 12:36:23.000000000 +0000
++++ gnome-vfs-2.6.0/configure.in       2004-06-07 16:04:34.000000000 +0100
+@@ -154,7 +154,7 @@
+ AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
+ if test x"$GCONFTOOL" = xno; then
+-  AC_MSG_ERROR([gconftool-2 executable not found in your path - should be installed with GConf])
++  AC_MSG_WARN([gconftool-2 executable not found in your path - should be installed with GConf])
+ fi
+ AM_GCONF_SOURCE_2
diff --git a/packages/gnome/gnome-vfs-2.22.0/gnome-vfs-no-kerberos.patch b/packages/gnome/gnome-vfs-2.22.0/gnome-vfs-no-kerberos.patch
new file mode 100644 (file)
index 0000000..e25ecdd
--- /dev/null
@@ -0,0 +1,51 @@
+removes kerberos completely to avoid conflicts with installed kerberos
+--- configure.in.orig  2007-01-05 19:42:26.418541610 +0200
++++ configure.in       2007-01-05 19:42:56.604261797 +0200
+@@ -436,47 +436,6 @@
+ ])
+ AM_CONDITIONAL(HAVE_CDDA, test $have_cdda = yes)
+ AC_SUBST(CDDA_LIBS)
+-
+-dnl GSSAPI
+-dnl Check for Kerberos installation
+-have_gssapi=no
+-AC_PATH_PROG([KRB5_CONFIG], krb5-config, none, $PATH:/usr/kerberos/bin)
+-                                         
+-if test "x$KRB5_CONFIG" != "xnone"; then
+-   GSSAPI_LIBS="`${KRB5_CONFIG} --libs gssapi`"
+-   GSSAPI_CFLAGS="`${KRB5_CONFIG} --cflags gssapi`"
+-   
+-   saved_CPPFLAGS="$CPPFLAGS"
+-   saved_LIBS="$LIBS"
+-   LIBS="$LIBS $GSSAPI_LIBS"
+-   CPPFLAGS="$CPPFLAGS $GSSAPI_CFLAGS"
+-   # MIT and Heimdal put gssapi.h in different places
+-   AC_CHECK_HEADERS(gssapi/gssapi.h gssapi.h, [
+-       AC_CHECK_FUNCS(gss_init_sec_context, [
+-           AC_MSG_NOTICE([GSSAPI authentication support enabled])
+-           AC_DEFINE(HAVE_GSSAPI, 1, [Define if GSSAPI support is enabled])
+-           AC_CHECK_HEADERS(gssapi/gssapi_generic.h)
+-               have_gssapi=yes
+-       
+-       # MIT Kerberos lacks GSS_C_NT_HOSTBASED_SERVICE
+-       AC_CHECK_DECL([GSS_C_NT_HOSTBASED_SERVICE],,
+-          [AC_DEFINE([GSS_C_NT_HOSTBASED_SERVICE], gss_nt_service_name, 
+-             [Define if GSS_C_NT_HOSTBASED_SERVICE is not defined otherwise])
+-              ], [
+-                  #ifdef HAVE_GSSAPI_GSSAPI_H
+-                  #include <gssapi/gssapi.h>
+-                  #else          
+-                  #include <gssapi.h>
+-                  #endif
+-              ])
+-        ])
+-     break
+-   ])
+-   LIBS="$saved_LIBS" 
+-   CPPFLAGS="$saved_CPPFLAGS" 
+-fi   
+-AC_SUBST(GSSAPI_LIBS)
+-AC_SUBST(GSSAPI_CFLAGS)
+          
+ dnl ******************************
+ dnl http-method (neon checks)
diff --git a/packages/gnome/gnome-vfs_2.22.0.bb b/packages/gnome/gnome-vfs_2.22.0.bb
new file mode 100644 (file)
index 0000000..5631a9c
--- /dev/null
@@ -0,0 +1,42 @@
+LICENSE = "GPL"
+DEPENDS = "libxml2 gconf gnutls avahi dbus bzip2 gnome-mime-data zlib"
+RRECOMMENDS = "gnome-vfs-plugin-file shared-mime-info"
+# Some legacy packages will require gnome-mime-data to be installed, but use of
+# it is deprecated.
+PR = "r0"
+
+inherit gnome
+
+SRC_URI += "file://gconftool-lossage.patch;patch=1;pnum=1 \
+           file://gnome-vfs-no-kerberos.patch;patch=1;pnum=0"
+
+# This is to provide compatibility with the gnome-vfs DBus fork
+PROVIDES = "gnome-vfs-plugin-dbus"
+RREPLACES = "gnome-vfs-dbus"
+
+EXTRA_OECONF = " \
+                 --disable-openssl \
+                 --enable-gnutls \
+                 --enable-avahi \
+                 --with-samba-includes=${STAGING_INCDIR} \
+               "
+
+FILES_${PN} += " ${libdir}/vfs ${datadir}/dbus-1/services"
+FILES_${PN}-dbg += " ${libdir}/gnome-vfs-2.0/modules/.debug"
+FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/include"
+FILES_${PN}-doc += " ${datadir}/gtk-doc"
+
+do_stage () {
+autotools_stage_all
+}
+
+PACKAGES_DYNAMIC = "gnome-vfs-plugin-*"
+
+python populate_packages_prepend () {
+       print bb.data.getVar('FILES_gnome-vfs', d, 1)
+
+       plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d)
+       do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s')
+}
+
+