kexecboot/kexecboot_0.4.bb : add refreshed patches from Dmitry Baryshkov for
authorGraeme Gregory <dp@xora.org.uk>
Thu, 29 Jan 2009 00:44:28 +0000 (00:44 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Thu, 29 Jan 2009 01:46:20 +0000 (01:46 +0000)
tosa support to kexecboot.

Add few more keys that can be used on tosa to select correct variant

Signed-off-by: Dmitry Baryshkov <dbaryshkov@gmail.com>
packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch [new file with mode: 0644]
packages/kexecboot/kexecboot_0.4.bb

diff --git a/packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch b/packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch
new file mode 100644 (file)
index 0000000..e10d1d7
--- /dev/null
@@ -0,0 +1,15 @@
+Index: kexecboot-0.4/kexecboot.c
+===================================================================
+--- kexecboot-0.4.orig/kexecboot.c     2009-01-29 00:38:21.000000000 +0000
++++ kexecboot-0.4/kexecboot.c  2009-01-29 00:39:05.000000000 +0000
+@@ -566,7 +566,9 @@
+                       break;
+               }
+-      }while(evt.code != 87 && evt.code != 63);
++      }while(evt.code != 87 && evt.code != 63 &&
++              evt.code != KEY_SPACE && evt.code != KEY_ENTER &&
++              evt.code != KEY_HIRAGANA && evt.code != KEY_HENKAN);
+       fclose(f);
+       // reset terminal
+       tcsetattr(fileno(stdin), TCSANOW, &old);
index 557c5be..c370b22 100644 (file)
@@ -1,5 +1,5 @@
 LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
 DEPENDS = "klibc"
 RDEPENDS = "kexec-static"
 
@@ -15,6 +15,7 @@ SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
        file://switch-cursor-off.patch;patch=1 \
        file://add-sleep.patch;patch=1 \
        file://silent-output-hack.patch;patch=1 \
+       file://kexecboot-tosa.patch;patch=1 \
        "
 
 S = "${WORKDIR}/kexecboot-${PV}"