merge of '01bddb578c9dd04edfbb56d0c1c15f81b4161479'
authorRobert Schuster <thebohemian@gmx.net>
Sun, 13 Jul 2008 22:42:06 +0000 (22:42 +0000)
committerRobert Schuster <thebohemian@gmx.net>
Sun, 13 Jul 2008 22:42:06 +0000 (22:42 +0000)
     and '400e8684128097359c7f2556772f3c2e15c3e752'

16 files changed:
packages/abiword/abiword-plugins_2.6.4.bb [new file with mode: 0644]
packages/abiword/abiword_2.6.4.bb [new file with mode: 0644]
packages/asio/.mtn2git_empty [new file with mode: 0644]
packages/asio/asio_1.1.1.bb [new file with mode: 0644]
packages/evince/evince_2.23.4.bb [new file with mode: 0644]
packages/ffmpeg/ffmpeg_git.bb
packages/lcd4linux/files/lcd4linux.init
packages/lcd4linux/lcd4linux_0.10.0.bb
packages/libwpd/libwpd_0.8.14.bb [new file with mode: 0644]
packages/mml-widget/files/.mtn2git_empty [new file with mode: 0644]
packages/mml-widget/files/mathview-gcc43x.diff [new file with mode: 0644]
packages/mml-widget/gtkmathview_0.7.6.bb
packages/mml-widget/gtkmathview_0.8.0.bb [new file with mode: 0644]
packages/t1lib/t1lib_5.0.2.bb
packages/u-boot/u-boot-git/beagleboard/base.patch
packages/u-boot/u-boot_git.bb

diff --git a/packages/abiword/abiword-plugins_2.6.4.bb b/packages/abiword/abiword-plugins_2.6.4.bb
new file mode 100644 (file)
index 0000000..94baeaf
--- /dev/null
@@ -0,0 +1,45 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "asio boost loudmouth libwpd librsvg goffice poppler libglade"
+RDEPENDS = "abiword"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+           http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+#           file://abiword-cxx-for-ld-fix.patch;patch=1 \
+          "
+
+DEFAULT_PREFERENCE = "2"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+#export LDFLAGS += " -lstdc++ "
+
+EXTRA_OECONF = " --enable-shared=yes \
+                 --enable-static \
+                --without-libwmf \
+                 --without-inter7eps \
+                --with-abiword=${WORKDIR}/abiword-${PV} \
+                --with-boost=${STAGING_DIR_HOST} \ 
+                --with-boost-thread=boost_thread-mt \
+               "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+       abiword_libdir    = bb.data.expand('${libdir}/abiword-2.6/plugins', d)
+       do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+        do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
+}
+
+
+PACKAGES =+ "abiword-plugin-collab-glade"
+
+FILES_abiword-plugin-collab-glade += "${datadir}"
+RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
+
+FILES_${PN}-dbg += "${libdir}/abiword-2.6/plugins/.debug"
+
diff --git a/packages/abiword/abiword_2.6.4.bb b/packages/abiword/abiword_2.6.4.bb
new file mode 100644 (file)
index 0000000..fe63992
--- /dev/null
@@ -0,0 +1,10 @@
+require abiword-2.5.inc
+
+PR = "r1"
+
+RCONFLICTS = "abiword-embedded"
+
+FILES_${PN}                    += "${datadir}/mime-info"
+FILES_abiword-strings           += "${datadir}/abiword-${SHRT_VER}/strings"
+FILES_abiword-systemprofiles    += "${datadir}/abiword-${SHRT_VER}/system.profile*"
+
diff --git a/packages/asio/.mtn2git_empty b/packages/asio/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/asio/asio_1.1.1.bb b/packages/asio/asio_1.1.1.bb
new file mode 100644 (file)
index 0000000..89b363d
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "Asio"
+HOMEPAGE = "http://asio.sf.net/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/asio/${PN}-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+do_stage() {
+       autotools_stage_all
+}      
+
diff --git a/packages/evince/evince_2.23.4.bb b/packages/evince/evince_2.23.4.bb
new file mode 100644 (file)
index 0000000..f5303ca
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Evince is a document viewer for document formats like pdf, ps, djvu."
+LICENSE = "GPL"
+SECTION = "x11/office"
+DEPENDS = "gnome-icon-theme tiff libxt espgs gnome-doc-utils poppler libxml2 gtk+ gnome-vfs gconf libglade gnome-keyring "
+RDEPENDS = "espgs gnome-icon-theme"
+RRECOMMENDS = "gnome-vfs-plugin-file"
+PR = "r2"
+
+inherit gnome pkgconfig gtk-icon-cache
+
+SRC_URI += " file://no-help-dir.patch;patch=1"
+
+EXTRA_OECONF = " --without-libgnome \
+                 --disable-thumbnailer \
+                --disable-scrollkeeper \
+                --enable-djvu \
+                "
+FILES_${PN}-dbg = "${libdir}/evince/backends/.debug"
+
index 294b6af..0fb739a 100644 (file)
@@ -3,7 +3,7 @@ require ffmpeg.inc
 DEPENDS += "libgsm"
 
 PV = "0.4.9+${PR}+gitr${SRCREV}" 
-PR = "r12"
+PR = "r13"
 
 DEFAULT_PREFERENCE = "-1"
 DEFAULT_PREFERENCE_armv7a = "1"
@@ -12,7 +12,7 @@ FFBRANCH_arm = "arm-neon"
 FFBRANCH ?= "master"
 
 SRCREV = "1e8300e71f79963eacdad6b180d9a12c4f56318d"
-SRCREV_arm = "749766cea9969418633abb77b6c8677a884dfcb9"
+SRCREV_arm = "d0e4a018bb80814e4aee450ddf9b4f6d3cb97064"
 SRC_URI = "git://git.mansr.com/ffmpeg.mru;protocol=git;branch=${FFBRANCH} \
 "
 
index 0972c90..c27ee37 100644 (file)
@@ -13,7 +13,7 @@
 ### END INIT INFO
 
 PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
-DAEMON=/usr/sbin/lcd4linux
+DAEMON=/usr/bin/lcd4linux
 NAME=lcd4linux
 DESC=lcd4linux
 
index 4c164de..fe73954 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "GPLv2"
 DEPENDS = "libusb-compat ncurses readline virtual/libx11"
 
 PV = "0.10.0+0.10.1-RC2"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://ssl.bulix.org/projects/lcd4linux/raw-attachment/wiki/Download/lcd4linux-0.10.1-RC2.tar.gz \
            file://libusb-compat.diff;patch=1 \ 
diff --git a/packages/libwpd/libwpd_0.8.14.bb b/packages/libwpd/libwpd_0.8.14.bb
new file mode 100644 (file)
index 0000000..f54cfe5
--- /dev/null
@@ -0,0 +1,12 @@
+LICENSE = "LGPL"
+DESCRIPTION = "libwpd is a C++ library designed to help process WordPerfect documents."
+HOMEPAGE = "http://libwpd.sourceforge.net/index.html"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz"
+DEPENDS = "libgsf"
+
+inherit autotools pkgconfig
+
+do_stage() {
+       autotools_stage_all
+}
diff --git a/packages/mml-widget/files/.mtn2git_empty b/packages/mml-widget/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/mml-widget/files/mathview-gcc43x.diff b/packages/mml-widget/files/mathview-gcc43x.diff
new file mode 100644 (file)
index 0000000..4091051
--- /dev/null
@@ -0,0 +1,53 @@
+--- /tmp/mathVariantAux.cc     2008-07-13 15:56:56.000000000 +0200
++++ gtkmathview-0.8.0/src/engine/mathml/mathVariantAux.cc      2008-07-13 15:57:46.893198000 +0200
+@@ -20,6 +20,8 @@
+ #include <cassert>
++#include <string.h>
++
+ #include "mathVariantAux.hh"
+ static MathVariantAttributes vattr[] = {
+--- /tmp/T1_FontDataBase.cc    2008-07-13 16:25:24.000000000 +0200
++++ gtkmathview-0.8.0/src/backend/ps/T1_FontDataBase.cc        2008-07-13 16:25:47.123198000 +0200
+@@ -20,6 +20,7 @@
+ #include <config.h>
+ #include <map>
+ #include <string>
++#include <string.h>
+ #include <stdlib.h>
+ #include <iostream>
+ #include <list>
+--- /tmp/SMS.cc        2008-07-13 16:27:23.000000000 +0200
++++ gtkmathview-0.8.0/mathmlsvg/SMS.cc 2008-07-13 16:27:41.543198000 +0200
+@@ -19,6 +19,7 @@
+ #include <config.h>
+ #include <sstream>
++#include <string.h>
+ #include "defs.h"
+ #include "AbstractLogger.hh"
+ #include "ValueConversion.hh"
+--- /tmp/main.cc       2008-07-13 16:29:11.000000000 +0200
++++ gtkmathview-0.8.0/mathmlsvg/main.cc        2008-07-13 16:29:28.813198000 +0200
+@@ -20,7 +20,7 @@
+ #include <cassert>
+ #include <fstream>
+-
++#include <string.h>
+ #include <popt.h>
+ // needed for old versions of GCC, must come before String.hh!
+--- /tmp/main.cc       2008-07-13 16:30:11.000000000 +0200
++++ gtkmathview-0.8.0/mathmlps/main.cc 2008-07-13 16:30:33.183198000 +0200
+@@ -20,7 +20,7 @@
+ #include <cassert>
+ #include <fstream>
+-
++#include <string.h>
+ #include <popt.h>
+ // needed for old versions of GCC, must come before String.hh!
index 7cb91b4..55f4328 100644 (file)
@@ -9,10 +9,10 @@ inherit autotools pkgconfig
 EXTRA_OECONF = "--disable-binreloc"
 
 do_configure() {
-oe_runconf
+       oe_runconf
 }
 
 do_stage() {
-autotools_stage_all
+       autotools_stage_all
 }
 
diff --git a/packages/mml-widget/gtkmathview_0.8.0.bb b/packages/mml-widget/gtkmathview_0.8.0.bb
new file mode 100644 (file)
index 0000000..2fe48ea
--- /dev/null
@@ -0,0 +1,24 @@
+LICENSE = "GPL"
+HOMEPAGE = "http://helm.cs.unibo.it/mml-widget/"
+DEPENDS = "t1lib gtk+ popt libxslt libxml2"
+
+SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \
+           file://mathview-gcc43x.diff;patch=1 \
+         "
+
+inherit autotools 
+AUTOTOOLS_STAGE_PKGCONFIG = 1
+
+EXTRA_OECONF = "--disable-binreloc"
+
+do_configure_prepend() {
+       sed -i -e s:AM_BINRELOC::g ${S}/configure.ac
+}
+
+do_stage() {
+       autotools_stage_all
+       for i in ${PKG_CONFIG_DIR}/*math*.pc ; do
+               sed -i -e s:${STAGING_INCDIR}:'${libdir}':g $i
+       done    
+}
+
index 3934016..5da31f7 100644 (file)
@@ -1,7 +1,8 @@
 DESCRIPTION = "A Type1 Font Rastering Library"
 SECTION = "libs"
 PRIORITY = "optional"
-PR = "r3"
+DEPENDS = "virtual/libx11"
+PR = "r4"
 LICENSE = "LGPL GPL"
 SRC_URI = "${DEBIAN_MIRROR}/main/t/t1lib/t1lib_${PV}.orig.tar.gz \
            file://configure.patch;patch=1 \
@@ -10,7 +11,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/t/t1lib/t1lib_${PV}.orig.tar.gz \
 
 inherit autotools
 
-EXTRA_OECONF = "--without-x --without-athena"
+EXTRA_OECONF = "--with-x --without-athena"
 EXTRA_OEMAKE = "without_doc"
 
 do_configure() {
@@ -19,9 +20,7 @@ do_configure() {
 }
 
 do_stage() {
-       oe_libinstall -so -C lib libt1 ${STAGING_LIBDIR}
-       install lib/t1lib/t1lib.h ${STAGING_INCDIR}/
-       install lib/t1lib/t1libx.h ${STAGING_INCDIR}/
+       autotools_stage_all
 }
 
 FILES_${PN} = "${bindir}/* ${libdir}/*.so* ${datadir}/t1lib/t1lib.config"
index dedc343..d4f726c 100644 (file)
@@ -1,5 +1,5 @@
 diff --git a/Makefile b/Makefile
-index 8bfc891..e9bf61a 100644
+index e557d0d..3eac691 100644
 --- a/Makefile
 +++ b/Makefile
 @@ -141,7 +141,7 @@ ifeq ($(ARCH),ppc)
@@ -11,7 +11,7 @@ index 8bfc891..e9bf61a 100644
  endif
  ifeq ($(ARCH),i386)
  CROSS_COMPILE = i386-linux-
-@@ -252,7 +252,7 @@ LIBBOARD = board/$(BOARDDIR)/lib$(BOARD).a
+@@ -253,7 +253,7 @@ LIBBOARD = board/$(BOARDDIR)/lib$(BOARD).a
  LIBBOARD := $(addprefix $(obj),$(LIBBOARD))
  
  # Add GCC lib
@@ -20,7 +20,7 @@ index 8bfc891..e9bf61a 100644
  
  # The "tools" are needed early, so put this first
  # Don't include stuff already done in $(LIBS)
-@@ -2565,6 +2565,12 @@ SMN42_config    :       unconfig
+@@ -2569,6 +2569,12 @@ SMN42_config    :       unconfig
        @$(MKCONFIG) $(@:_config=) arm arm720t SMN42 siemens lpc2292
  
  #########################################################################
@@ -1467,10 +1467,10 @@ index 0000000..2f94684
 +#endif /* (CONFIG_COMMANDS & CFG_CMD_NAND) */
 diff --git a/board/omap3530beagle/omap3530beagle.c b/board/omap3530beagle/omap3530beagle.c
 new file mode 100644
-index 0000000..0bdfb72
+index 0000000..7d9a566
 --- /dev/null
 +++ b/board/omap3530beagle/omap3530beagle.c
-@@ -0,0 +1,390 @@
+@@ -0,0 +1,388 @@
 +/*
 + * (C) Copyright 2004-2008
 + * Texas Instruments, <www.ti.com>
@@ -1740,8 +1740,6 @@ index 0000000..0bdfb72
 +      *((uint *) 0x49058094) = 0x00000506;
 +      *((uint *) 0x49056094) = 0xF060F000;
 +
-+      /* set clksel_tv and clksel_dss1 */
-+      *((uint *) 0x48004E40) = 0x00001002;
 +      return (0);
 +}
 +
@@ -2323,19 +2321,60 @@ index 0000000..72f15f6
 +      .bss : { *(.bss) }
 +      _end = .;
 +}
-diff --git a/common/env_nand.c b/common/env_nand.c
-index a48e98e..8b04a01 100644
---- a/common/env_nand.c
-+++ b/common/env_nand.c
-@@ -231,6 +231,8 @@ int saveenv(void)
-       size_t total;
-       int ret = 0;
+diff --git a/common/cmd_nand.c b/common/cmd_nand.c
+index 9e38bf7..0ae362c 100644
+--- a/common/cmd_nand.c
++++ b/common/cmd_nand.c
+@@ -37,6 +37,12 @@ int find_dev_and_part(const char *id, struct mtd_device **dev,
+               u8 *part_num, struct part_info **part);
+ #endif
  
-+      nand_erase_options_t nand_erase_options;
++#if defined(CONFIG_OMAP) && (defined(CONFIG_OMAP3_BEAGLE))
++extern void omap_nand_switch_ecc(nand_info_t *nand, int hardware);
++#else
++#define omap_nand_switch_ecc(x, y) do {} while(0)
++#endif
 +
-       nand_erase_options.length = CFG_ENV_RANGE;
-       nand_erase_options.quiet = 0;
-       nand_erase_options.jffs2 = 0;
+ static int nand_dump_oob(nand_info_t *nand, ulong off)
+ {
+       return 0;
+@@ -222,7 +228,7 @@ int do_nand(cmd_tbl_t * cmdtp, int flag, int argc, char *argv[])
+           strncmp(cmd, "dump", 4) != 0 &&
+           strncmp(cmd, "read", 4) != 0 && strncmp(cmd, "write", 5) != 0 &&
+           strcmp(cmd, "scrub") != 0 && strcmp(cmd, "markbad") != 0 &&
+-          strcmp(cmd, "biterr") != 0 &&
++          strcmp(cmd, "biterr") != 0 && strncmp(cmd, "ecc", 3) != 0 &&
+           strcmp(cmd, "lock") != 0 && strcmp(cmd, "unlock") != 0 )
+               goto usage;
+@@ -307,6 +313,19 @@ int do_nand(cmd_tbl_t * cmdtp, int flag, int argc, char *argv[])
+       }
++      if (strncmp(cmd, "ecc", 3) == 0) {
++              if (argc < 2)
++                      goto usage;
++              if (strncmp(argv[2], "hw", 2) == 0)
++                      omap_nand_switch_ecc(nand, 1);
++              else if (strncmp(argv[2], "sw", 2) == 0)
++                      omap_nand_switch_ecc(nand, 0);
++              else
++                      goto usage;
++
++              return 0;
++      }
++
+       /* read write */
+       if (strncmp(cmd, "read", 4) == 0 || strncmp(cmd, "write", 5) == 0) {
+               int read;
+@@ -472,6 +491,7 @@ U_BOOT_CMD(nand, 5, 1, do_nand,
+       "nand scrub - really clean NAND erasing bad blocks (UNSAFE)\n"
+       "nand markbad off - mark bad block at offset (UNSAFE)\n"
+       "nand biterr off - make a bit error at offset (UNSAFE)\n"
++      "nand ecc [hw/sw] - switch the ecc calculation algorithm \n"
+       "nand lock [tight] [status] - bring nand to lock state or display locked pages\n"
+       "nand unlock [offset] [size] - unlock section\n");
 diff --git a/cpu/omap3/Makefile b/cpu/omap3/Makefile
 new file mode 100644
 index 0000000..097447a
@@ -4122,10 +4161,10 @@ index 7dab786..7782e9d 100644
                        udelay(1000);
                }else
 diff --git a/fs/jffs2/jffs2_1pass.c b/fs/jffs2/jffs2_1pass.c
-index 7e27ee1..e552e08 100644
+index d1423c1..a75c606 100644
 --- a/fs/jffs2/jffs2_1pass.c
 +++ b/fs/jffs2/jffs2_1pass.c
-@@ -303,7 +303,9 @@ static inline void *get_node_mem_nor(u32 off)
+@@ -304,7 +304,9 @@ static inline void *get_node_mem_nor(u32 off)
   */
  static inline void *get_fl_mem(u32 off, u32 size, void *ext_buf)
  {
@@ -4135,7 +4174,7 @@ index 7e27ee1..e552e08 100644
  
  #if defined(CONFIG_CMD_FLASH)
        if (id->type == MTD_DEV_TYPE_NOR)
-@@ -321,7 +323,9 @@ static inline void *get_fl_mem(u32 off, u32 size, void *ext_buf)
+@@ -322,7 +324,9 @@ static inline void *get_fl_mem(u32 off, u32 size, void *ext_buf)
  
  static inline void *get_node_mem(u32 off)
  {
@@ -4270,7 +4309,7 @@ index 0000000..7cdd58c
 +#endif
 diff --git a/include/asm-arm/arch-omap3/clocks_omap3.h b/include/asm-arm/arch-omap3/clocks_omap3.h
 new file mode 100644
-index 0000000..9bb4700
+index 0000000..fdb0c4c
 --- /dev/null
 +++ b/include/asm-arm/arch-omap3/clocks_omap3.h
 @@ -0,0 +1,101 @@
@@ -4319,7 +4358,7 @@ index 0000000..9bb4700
 +/* PER DPLL */
 +# define PER_M6X2       3     /* 288MHz: CM_CLKSEL1_EMU */
 +# define PER_M5X2       4     /* 216MHz: CM_CLKSEL_CAM */
-+# define PER_M4X2       9     /* 96MHz : CM_CLKSEL_DSS-dss1 */
++# define PER_M4X2       2     /* 432MHz : CM_CLKSEL_DSS-dss1 */
 +# define PER_M3X2       16    /* 54MHz : CM_CLKSEL_DSS-tv */
 +
 +#  define CLSEL1_EMU_VAL ((CORE_M3X2 << 16) | (PER_M6X2 << 24) | (0x0a50))
@@ -5406,7 +5445,7 @@ index 0000000..37aaa08
 +#endif /* MMC_HOST_DEF_H */
 diff --git a/include/asm-arm/arch-omap3/mux.h b/include/asm-arm/arch-omap3/mux.h
 new file mode 100644
-index 0000000..33947b9
+index 0000000..ec4aeb0
 --- /dev/null
 +++ b/include/asm-arm/arch-omap3/mux.h
 @@ -0,0 +1,757 @@
@@ -6046,8 +6085,8 @@ index 0000000..33947b9
 +      MUX_VAL(CP(HSUSB0_DATA7),   (IEN  | PTD | DIS | M0)) /*HSUSB0_DATA7*/\
 +      MUX_VAL(CP(I2C1_SCL),       (IEN  | PTU | EN  | M0)) /*I2C1_SCL*/\
 +      MUX_VAL(CP(I2C1_SDA),       (IEN  | PTU | EN  | M0)) /*I2C1_SDA*/\
-+      MUX_VAL(CP(I2C2_SCL),       (IDIS | PTU | DIS | M4)) /*GPIO_168*/\
-+      MUX_VAL(CP(I2C2_SDA),       (IEN  | PTU | EN  | M4)) /*GPIO_183*/\
++      MUX_VAL(CP(I2C2_SCL),       (IEN  | PTU | EN  | M0)) /*I2C2_SCL*/\
++      MUX_VAL(CP(I2C2_SDA),       (IEN  | PTU | EN  | M0)) /*I2C2_SDA*/\
 +      MUX_VAL(CP(I2C3_SCL),       (IEN  | PTU | EN  | M0)) /*I2C3_SCL*/\
 +      MUX_VAL(CP(I2C3_SDA),       (IEN  | PTU | EN  | M0)) /*I2C3_SDA*/\
 +      MUX_VAL(CP(I2C4_SCL),       (IEN  | PTU | EN  | M0)) /*I2C4_SCL*/\
@@ -6376,7 +6415,7 @@ index 0000000..271b554
 +#endif
 diff --git a/include/configs/omap3530beagle.h b/include/configs/omap3530beagle.h
 new file mode 100644
-index 0000000..fd21ab3
+index 0000000..20efbf3
 --- /dev/null
 +++ b/include/configs/omap3530beagle.h
 @@ -0,0 +1,292 @@
@@ -6532,9 +6571,9 @@ index 0000000..fd21ab3
 +/* Environment information */
 +#define CONFIG_BOOTDELAY         10
 +
-+#define CONFIG_BOOTCOMMAND "mmcinit;fatload mmc 0 0x80300000 uImage; fatload mmc 0 0x81600000 rd-ext2.bin; bootm 0x80300000\0"
++#define CONFIG_BOOTCOMMAND "nand read 80200000 280000 400000 ; bootm 80200000"
 +
-+#define CONFIG_BOOTARGS "setenv bootargs console=ttyS2,115200n8 ramdisk_size=3072 root=/dev/ram0 rw rootfstype=ext2 initrd=0x81600000,3M "
++#define CONFIG_BOOTARGS "setenv bootargs console=ttyS2,115200n8 noinitrd root=/dev/mtdblock4 rw rootfstype=jffs2"
 +
 +#define CONFIG_NETMASK           255.255.254.0
 +#define CONFIG_IPADDR            128.247.77.90
index e900ab4..8184292 100644 (file)
@@ -1,8 +1,8 @@
 require u-boot.inc
-PR="r9"
+PR="r10"
 
 SRCREV_davinci-sffsdr = "a524e112b424c6843800ea2f19d3a8cf01d0aa94"
-SRCREV_beagleboard = "9b55a2536919f4de1bb1044e6eb8262c2f53bc96"
+SRCREV_beagleboard = "bde63587622c4b830a27d1ddf7265843de9e994f"
 SRCREV_neuros-osd2 = "482dfe48845192c7f810bccfc93db93d0f1654f7"
 
 SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git "