lowpan-tools: fix building
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Mon, 25 May 2009 12:46:13 +0000 (16:46 +0400)
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Mon, 25 May 2009 12:46:13 +0000 (16:46 +0400)
1) upstream has changed naming to be 'lowpan-tools' instead of 'lowpan-utils'
2) bump git revision (and thus PR) to use upstream fix for supporting
   installation w/o manpages and add '--disable-manpages' to EXTRA_OECONF

Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
recipes/lowpan-tools/lowpan-tools_git.bb [new file with mode: 0644]
recipes/lowpan-utils/lowpan-utils_git.bb [deleted file]

diff --git a/recipes/lowpan-tools/lowpan-tools_git.bb b/recipes/lowpan-tools/lowpan-tools_git.bb
new file mode 100644 (file)
index 0000000..1fde232
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "LoWPAN utilities (IEEE802.15.4)"
+LICENSE = "GPL"
+SRCREV = "e9e80a2eefa7aadbbb15bef1519b373e2e907aa0"
+#SRC_URI = "git://github.com/lumag/lowpan-utils.git;protocol=git"
+SRC_URI = "git://linux-zigbee.git.sourceforge.net/gitroot/linux-zigbee;protocol=git"
+DEPENDS = "libnl bison-native flex-native"
+PR = "r6"
+
+S = "${WORKDIR}/git"
+PACKAGES += "${PN}-tests-dbg"
+PACKAGES += "${PN}-tests"
+FILES_${PN} = "${sbindir}/iz ${sbindir}/izconfig \
+               ${bindir}/izchat ${bindir}/izlisten ${sbindir}/izcoordinator \
+               ${sbindir}/izattach"
+FILES_${PN}-tests = "${libexecdir}/lowpan-tools ${libdir}/python*/site-packages"
+FILES_${PN}-tests-dbg = "${libexecdir}/lowpan-tools/.debug"
+
+EXTRA_OECONF = "--disable-manpages"
+
+inherit autotools_stage
diff --git a/recipes/lowpan-utils/lowpan-utils_git.bb b/recipes/lowpan-utils/lowpan-utils_git.bb
deleted file mode 100644 (file)
index 89a5e43..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-DESCRIPTION = "LoWPAN utilities (IEEE802.15.4)"
-LICENSE = "GPL"
-SRCREV = "master"
-SRC_URI = "git://github.com/lumag/lowpan-utils.git;protocol=git"
-DEPENDS = "libnl bison-native flex-native"
-PR = "r4"
-
-S = "${WORKDIR}/git"
-PACKAGES += "${PN}-tests-dbg"
-PACKAGES += "${PN}-tests"
-FILES_${PN} = "${sbindir}/iz ${sbindir}/izconfig \
-               ${bindir}/izchat ${bindir}/izlisten ${sbindir}/izcoordinator \
-               ${sbindir}/izattach"
-FILES_${PN}-tests = "${libexecdir}/zigbee ${libdir}/python*/site-packages"
-FILES_${PN}-tests-dbg = "${libexecdir}/zigbee/.debug"
-
-inherit autotools
-
-do_stage() {
-     autotools_stage_all
-}