Fix vuplus related stuffs
authorschon <schon@dev03-server>
Mon, 6 Dec 2010 09:22:32 +0000 (18:22 +0900)
committerschon <schon@dev03-server>
Mon, 6 Dec 2010 09:22:32 +0000 (18:22 +0900)
17 files changed:
conf/distro/vuplus.conf
recipes/busybox/busybox_1.15.3.bb
recipes/enigma2/enigma2-plugins.bb
recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_ac3lipsync_dolby.patch [new file with mode: 0644]
recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_mytube_tpm.patch [new file with mode: 0644]
recipes/enigma2/enigma2.bb
recipes/enigma2/enigma2/vuplus/enigma2_vuplus_duo.patch
recipes/enigma2/enigma2/vuplus/enigma2_vuplus_skin.patch
recipes/gstreamer/gst-plugins-bad_0.10.20.bb
recipes/gstreamer/gst-plugins-ugly_0.10.16.bb
recipes/openssl/openssl.inc
recipes/qt4/qt-4.7.0.inc
recipes/qt4/qt4-tools-native_4.7.0.bb
recipes/tasks/task-vuplus-enigma2.bb
recipes/vuplus/vuplus-dvb-modules.bb
recipes/vuplus/vuplus-feed-configs.bb
recipes/xbmc/libcdio_0.81.bb

index c4ade39..5afbb16 100644 (file)
@@ -10,7 +10,7 @@ INHERIT += "package_ipk debian"
 
 DISTRO = "vuplus"
 DISTRO_NAME = "Vuplus"
-DISTRO_VERSION = "2.0.2"
+DISTRO_VERSION = "2.0.3"
 
 
 TARGET_OS = "linux"
@@ -64,7 +64,7 @@ PREFERRED_VERSION_libsigc++-1.2 ?= "1.2.5"
 #PREFERRED_VERSION_linux-libc-headers ?= "2.6.12.0"
 PREFERRED_VERSION_linux-libc-headers ?= "2.6.18"
 PREFERRED_VERSION_swig-native ?= "1.3.39"
-PREFERRED_VERSION_wpa-supplicant ?= "0.6.7"
+PREFERRED_VERSION_wpa-supplicant ?= "0.6.9"
 #PREFERRED_VERSION_samba = "3.3.13"
 PREFERRED_VERSION_samba = "3.0.37"
 PREFERRED_VERSION_ushare = "1.1a"
index 90549e7..1964567 100755 (executable)
@@ -32,7 +32,6 @@ SRC_URI_append_opendreambox = "\
   file://nptl_task.patch;patch=1 \
 "
 SRC_URI_append_vuplus = "\
-  file://hdparm_M.patch;patch=1 \
   file://dhcp-hostname.patch;patch=1 \
   file://keymap_endianess.patch;patch=1 \
   file://nptl_task.patch;patch=1 \
index bb8b032..188c510 100755 (executable)
@@ -25,9 +25,15 @@ PR_vuplus = "r1"
 
 SRC_URI = "cvs://anonymous@cvs.schwerkraft.elitedvb.net/cvsroot/enigma2-plugins;module=enigma2-plugins;method=pserver${TAG};date=${SRCDATE}"
 
+#SRC_URI_append_vuplus = " \
+#         file://enigma2_plugins_mytube_vuplus.patch;patch=1;pnum=1 \
+#         file://enigma2_plugins_mytube_entry_vuplus.patch;patch=1;pnum=1 \
+#           file://dreamboxweb.png \
+#           file://favicon.ico"
+
 SRC_URI_append_vuplus = " \
-          file://enigma2_plugins_mytube_vuplus.patch;patch=1;pnum=1 \
-          file://enigma2_plugins_mytube_entry_vuplus.patch;patch=1;pnum=1 \
+          file://enigma2_plugins_mytube_tpm.patch;patch=1;pnum=1 \
+          file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
            file://dreamboxweb.png \
            file://favicon.ico"
 
diff --git a/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_ac3lipsync_dolby.patch b/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_ac3lipsync_dolby.patch
new file mode 100644 (file)
index 0000000..14d424c
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/ac3lipsync/src/AC3delay.py b/ac3lipsync/src/AC3delay.py
+index a92c859..6bbc86d 100644
+--- a/ac3lipsync/src/AC3delay.py
++++ b/ac3lipsync/src/AC3delay.py
+@@ -177,7 +177,7 @@ class AC3delay:
+                 tlist.append((description, x))
+                 if x == self.selectedAudioIndex:
+-                    if ((description.find("AC3") != -1 or description.find("AC-3") != -1) and not bDownmixEnabled) or description.find("DTS") != -1:
++                    if ((description.find("Dolby") != -1 or description.find("AC3") != -1 or description.find("AC-3") != -1) and not bDownmixEnabled) or description.find("DTS") != -1:
+                         self.whichAudio = AC3
+                         self.channelAudio = AC3
+                     else:
diff --git a/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_mytube_tpm.patch b/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_mytube_tpm.patch
new file mode 100644 (file)
index 0000000..53f3173
--- /dev/null
@@ -0,0 +1,149 @@
+diff --git a/mytube/src/plugin.py b/mytube/src/plugin.py
+index d6fbe85..93b54c1 100755
+--- a/mytube/src/plugin.py
++++ b/mytube/src/plugin.py
+@@ -385,44 +385,10 @@ class MyTubePlayerMainScreen(Screen, ConfigListScreen):
+               current = self["config"].getCurrent()
+               if current[1].help_window.instance is not None:
+                       current[1].help_window.instance.hide()
+-
+-              l3cert = etpm.getCert(eTPM.TPMD_DT_LEVEL3_CERT)
+-              if l3cert is None or l3cert is "":
+-                      self["videoactions"].setEnabled(False)
+-                      self["searchactions"].setEnabled(False)
+-                      self["config_actions"].setEnabled(False)
+-                      self["historyactions"].setEnabled(False)
+-                      self["statusactions"].setEnabled(True)
+-                      self.hideSuggestions()
+-                      self.statuslist = []
+-                      self.statuslist.append(( _("Genuine Dreambox validation failed!"), _("Verify your Dreambox authenticity by running the genuine dreambox plugin!" ) ))
+-                      self["feedlist"].style = "state"
+-                      self['feedlist'].setList(self.statuslist)
+-                      return
+-
+-              self.l3key = validate_cert(l3cert, self.l2key)
+-              if self.l3key is None:
+-                      print "l3cert invalid"
+-                      return
+-              rnd = get_rnd()
+-              if rnd is None:
+-                      print "random error"
+-                      return
+-
+-              val = etpm.challenge(rnd)
+-              result = decrypt_block(val, self.l3key)
+-
+-              self.statuslist = []
+-              if result[80:88] == rnd:
+-                      self.statuslist.append(( _("Fetching feed entries"), _("Trying to download the Youtube feed entries. Please wait..." ) ))
+-                      self["feedlist"].style = "state"
+-                      self['feedlist'].setList(self.statuslist)
+-                      self.Timer.start(200)
+-              else:
+-                      self.statuslist.append(( _("Genuine Dreambox validation failed!"), _("Verify your Dreambox authenticity by running the genuine dreambox plugin!" ) ))
+-                      self["feedlist"].style = "state"
+-                      self['feedlist'].setList(self.statuslist)               
+-      
++              self.statuslist.append(( _("Fetching feed entries"), _("Trying to download the Youtube feed entries. Please wait..." ) ))
++              self["feedlist"].style = "state"
++              self['feedlist'].setList(self.statuslist)
++              self.Timer.start(200)
+       def TimerFire(self):
+               self.Timer.stop()
+               if config.plugins.mytube.general.loadFeedOnOpen.value:
+@@ -453,49 +419,36 @@ class MyTubePlayerMainScreen(Screen, ConfigListScreen):
+                       self.statuslist = []
+                       self.hideSuggestions()
+                       result = None
+-                      if self.l3key is not None:
+-                              rnd = get_rnd()
+-                              if rnd is None:
+-                                      return
+-                              val = etpm.challenge(rnd)
+-                              result = decrypt_block(val, self.l3key)
+-                      if not result or result[80:88] != rnd:
++                      print "Genuine Dreambox validation passed"
++                      if self.FirstRun == True:
++                              self.appendEntries = False
++                              myTubeService.startService()
++                      if self.HistoryWindow is not None:
++                              self.HistoryWindow.deactivate()
++                              self.HistoryWindow.instance.hide()
++                      if status == 'getFeed':
++                              self.statuslist.append(( _("Fetching feed entries"), _("Trying to download the Youtube feed entries. Please wait..." ) ))
++                      elif status == 'getSearchFeed':
++                              self.statuslist.append(( _("Fetching search entries"), _("Trying to download the Youtube search results. Please wait..." ) ))
++                      elif status == 'Error':
++                              self.statuslist.append(( _("An error occured."), _("There was an error getting the feed entries. Please try again." ) ))
++                      elif status == 'noVideos':
+                               self["key_green"].show()
+-                              self.statuslist.append(( _("Genuine Dreambox validation failed!"), _("Verify your Dreambox authenticity by running the genuine dreambox plugin!" ) ))
+-                              self["feedlist"].style = "state"
+-                              self['feedlist'].setList(self.statuslist)
+-                      else:
+-                              print "Genuine Dreambox validation passed"
+-                              if self.FirstRun == True:
+-                                      self.appendEntries = False
+-                                      myTubeService.startService()
+-                              if self.HistoryWindow is not None:
+-                                      self.HistoryWindow.deactivate()
+-                                      self.HistoryWindow.instance.hide()
+-                              if status == 'getFeed':
+-                                      self.statuslist.append(( _("Fetching feed entries"), _("Trying to download the Youtube feed entries. Please wait..." ) ))
+-                              elif status == 'getSearchFeed':
+-                                      self.statuslist.append(( _("Fetching search entries"), _("Trying to download the Youtube search results. Please wait..." ) ))
+-                              elif status == 'Error':
+-                                      self.statuslist.append(( _("An error occured."), _("There was an error getting the feed entries. Please try again." ) ))
+-                              elif status == 'noVideos':
+-                                      self["key_green"].show()
+-                                      self.statuslist.append(( _("No videos to display"), _("Please select a standard feed or try searching for videos." ) ))
+-                              elif status == 'byPass':
+-                                      self.statuslist.append(( _("Not fetching feed entries"), _("Please enter your search term." ) ))
+-                                      self["feedlist"].style = "state"
+-                                      self['feedlist'].setList(self.statuslist)
+-                                      self.switchToConfigList()
++                              self.statuslist.append(( _("No videos to display"), _("Please select a standard feed or try searching for videos." ) ))
++                      elif status == 'byPass':
++                              self.statuslist.append(( _("Not fetching feed entries"), _("Please enter your search term." ) ))
+                               self["feedlist"].style = "state"
+                               self['feedlist'].setList(self.statuslist)
+-                              if self.FirstRun == True:
+-                                      if config.plugins.mytube.general.loadFeedOnOpen.value:
+-                                              if config.plugins.mytube.general.startFeed.value == 'hd':
+-                                                      self.FeedURL = "http://gdata.youtube.com/feeds/api/videos/-/HD"
+-                                              else:
+-                                                      self.FeedURL = self.BASE_STD_FEEDURL + str(config.plugins.mytube.general.startFeed.value)
+-                                              self.getFeed(self.FeedURL, str(config.plugins.mytube.general.startFeed.value))
+-
++                              self.switchToConfigList()
++                      self["feedlist"].style = "state"
++                      self['feedlist'].setList(self.statuslist)
++                      if self.FirstRun == True:
++                              if config.plugins.mytube.general.loadFeedOnOpen.value:
++                                      if config.plugins.mytube.general.startFeed.value == 'hd':
++                                              self.FeedURL = "http://gdata.youtube.com/feeds/api/videos/-/HD"
++                                      else:
++                                              self.FeedURL = self.BASE_STD_FEEDURL + str(config.plugins.mytube.general.startFeed.value)
++                                      self.getFeed(self.FeedURL, str(config.plugins.mytube.general.startFeed.value))
+       def handleHelpWindow(self):
+               print "[handleHelpWindow]"
+@@ -1775,17 +1728,8 @@ class MyTubePlayer(Screen, InfoBarNotifications):
+ def MyTubeMain(session, **kwargs):
+-      l2 = False
+-      l2cert = etpm.getCert(eTPM.TPMD_DT_LEVEL2_CERT)
+-      if l2cert is None:
+-              print "l2cert not found"
+-              return
+-      
+-      l2key = validate_cert(l2cert, rootkey)
+-      if l2key is None:
+-              print "l2cert invalid"
+-              return
+       l2 = True
++      l2key = None
+       if l2:
+               session.open(MyTubePlayerMainScreen,l2key)
index 078eb64..42a8798 100644 (file)
@@ -102,7 +102,11 @@ SRCREV_vuplus = ""
 SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
 
 
-SRC_URI_bm750 = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
+#SRC_URI_bm750 = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
+
+
+
+SRC_URI_bm750 = "git:///home/shcheong/work/stb/sw/oe_1.6/dm/enigma2_test/enigma2;protocol=file;branch=test_1130_mod;tag=${SRCREV} \
           file://enigma2_vuplus_duo.patch;patch=1;pnum=1 \
           file://enigma2_vuplus_swloop.patch;patch=1;pnum=1 \
            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
@@ -113,7 +117,7 @@ SRC_URI_bm750 = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=$
            file://750S \
            file://Vu_HD \
            file://number_key \
-           file://enigma2.sh"
+           "
 
 
 SRC_URI_vusolo = "git://archive.vuplus.com/git/enigma2.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
@@ -163,11 +167,6 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 inherit autotools pkgconfig
 
-<<<<<<< HEAD:recipes/enigma2/enigma2.bb
-bindir = "/usr/bin"
-sbindir = "/usr/sbin"
-
-EXTRA_OECONF = "--with-target=native --with-libsdl=no"
 
 do_compile_prepend_vuplus() {
         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
@@ -187,17 +186,12 @@ do_compile_prepend_vuplus() {
         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
 }
 
-do_install_append() {
-       install -m 0755 ${WORKDIR}/enigma2.sh ${D}/usr/bin/
-}
-=======
 EXTRA_OECONF = " \
         BUILD_SYS=${BUILD_SYS} \
         HOST_SYS=${HOST_SYS} \
         STAGING_INCDIR=${STAGING_INCDIR} \
         STAGING_LIBDIR=${STAGING_LIBDIR} \
 "
->>>>>>> dm/opendreambox-1.6:recipes/enigma2/enigma2.bb
 
 python populate_packages_prepend () {
        enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
index d81688a..871d848 100644 (file)
@@ -1,16 +1,13 @@
-diff --git a/acinclude.m4 b/acinclude.m4
-index ab3835e..dd6ef07 100755
---- a/acinclude.m4
-+++ b/acinclude.m4
-@@ -159,6 +159,8 @@ fi
-  #csh
- AC_DEFINE(BUILD_VUPLUS,1,[Define to 1 for 750])
-+ # ikseong
-+AC_DEFINE(BUILD_VUPLUS_DUO,1,[Define to 1 for 750])
- if test "$DVB_API_VERSION"; then
-       AC_DEFINE(HAVE_DVB,1,[Define to 1 if you have the dvb includes])
+diff --git a/configure.ac b/configure.ac
+index 4902a9c..4bd2117 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -207,4 +207,5 @@ tools/enigma2.sh
+ enigma2.pc
+ ])
+ AC_DEFINE(BUILD_VUPLUS,1,[Define to 1 for vuplus])
++AC_DEFINE(BUILD_VUPLUS_DUO,1,[Define to 1 for duo])
+ AC_OUTPUT
 diff --git a/lib/dvb/frontend.cpp b/lib/dvb/frontend.cpp
 index 6b09d3d..40c2289 100755
 --- a/lib/dvb/frontend.cpp
index a218b07..8239847 100644 (file)
@@ -1,8 +1,8 @@
 diff --git a/configure.ac b/configure.ac
-index 0953e4c..85b8f78 100755
+index 4902a9c..5c74eda 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -98,6 +98,16 @@ data/skin_default/menu/Makefile
+@@ -109,6 +109,16 @@ data/skin_default/menu/Makefile
  data/skin_default/icons/Makefile
  data/skin_default/buttons/Makefile
  data/skin_default/spinner/Makefile
@@ -27,7 +27,7 @@ index 0000000..a516e82
 @@ -0,0 +1,6 @@
 +SUBDIRS = menu icons buttons countries
 +
-+installdir = $(DATADIR)/enigma2/750S
++installdir = $(pkgdatadir)/750S
 +
 +install_DATA = \
 +      *.xml *.png
@@ -39,7 +39,7 @@ index 0000000..eb83d1c
 @@ -0,0 +1,6 @@
 +AUTOMAKE_OPTIONS = gnu
 +
-+installdir = $(DATADIR)/enigma2/750S/buttons
++installdir = $(pkgdatadir)/750S/buttons
 +
 +install_DATA = \
 +      *.png
@@ -51,7 +51,7 @@ index 0000000..4517ada
 @@ -0,0 +1,6 @@
 +AUTOMAKE_OPTIONS = gnu
 +
-+installdir = $(DATADIR)/enigma2/750S/countries
++installdir = $(pkgdatadir)/750S/countries
 +
 +install_DATA = \
 +      *.png
@@ -63,7 +63,7 @@ index 0000000..9277cc5
 @@ -0,0 +1,6 @@
 +AUTOMAKE_OPTIONS = gnu
 +
-+installdir = $(DATADIR)/enigma2/750S/icons
++installdir = $(pkgdatadir)/750S/icons
 +
 +install_DATA = \
 +      *.png
@@ -75,7 +75,7 @@ index 0000000..ff165af
 @@ -0,0 +1,6 @@
 +AUTOMAKE_OPTIONS = gnu
 +
-+installdir = $(DATADIR)/enigma2/750S/menu
++installdir = $(pkgdatadir)/750S/menu
 +
 +install_DATA = \
 +      *.png
@@ -2575,15 +2575,15 @@ index 0000000..7be3bca
 +      
 +</skin>
 diff --git a/data/Makefile.am b/data/Makefile.am
-index 1ed9444..d75b822 100644
+index 0eaa082..869a16e 100644
 --- a/data/Makefile.am
 +++ b/data/Makefile.am
 @@ -1,4 +1,4 @@
--SUBDIRS = countries fonts defaults extensions skin_default
-+SUBDIRS = countries fonts defaults extensions skin_default 750S Vu_HD
+-SUBDIRS = countries fonts defaults extensions keymaps skin_default
++SUBDIRS = countries fonts defaults extensions keymaps skin_default 750S Vu_HD
  
  dist_pkgdata_DATA = \
-       defaultsatlists.xml \
+        defaultsatlists.xml \
 diff --git a/data/Vu_HD/Makefile.am b/data/Vu_HD/Makefile.am
 new file mode 100644
 index 0000000..ee39535
@@ -2592,7 +2592,7 @@ index 0000000..ee39535
 @@ -0,0 +1,6 @@
 +SUBDIRS = menu icons buttons countries
 +
-+installdir = $(DATADIR)/enigma2/Vu_HD
++installdir = $(pkgdatadir)/Vu_HD
 +
 +install_DATA = \
 +      *.xml *.png
@@ -2604,7 +2604,7 @@ index 0000000..cd14ba2
 @@ -0,0 +1,6 @@
 +AUTOMAKE_OPTIONS = gnu
 +
-+installdir = $(DATADIR)/enigma2/Vu_HD/buttons
++installdir = $(pkgdatadir)/Vu_HD/buttons
 +
 +install_DATA = \
 +      *.png
@@ -2616,7 +2616,7 @@ index 0000000..9a025db
 @@ -0,0 +1,6 @@
 +AUTOMAKE_OPTIONS = gnu
 +
-+installdir = $(DATADIR)/enigma2/Vu_HD/countries
++installdir = $(pkgdatadir)/Vu_HD/countries
 +
 +install_DATA = \
 +      *.png
@@ -2628,7 +2628,7 @@ index 0000000..0351458
 @@ -0,0 +1,6 @@
 +AUTOMAKE_OPTIONS = gnu
 +
-+installdir = $(DATADIR)/enigma2/Vu_HD/icons
++installdir = $(pkgdatadir)/Vu_HD/icons
 +
 +install_DATA = \
 +      *.png
@@ -2640,7 +2640,7 @@ index 0000000..ed47ec9
 @@ -0,0 +1,6 @@
 +AUTOMAKE_OPTIONS = gnu
 +
-+installdir = $(DATADIR)/enigma2/Vu_HD/menu
++installdir = $(pkgdatadir)/Vu_HD/menu
 +
 +install_DATA = \
 +      *.png
@@ -5687,19 +5687,18 @@ index 0000000..555c0d6
 +      </screen>
 +</skin>
 diff --git a/data/fonts/Makefile.am b/data/fonts/Makefile.am
-index f743b8c..87650c8 100644
+index 2f7e7c7..832b582 100644
 --- a/data/fonts/Makefile.am
 +++ b/data/fonts/Makefile.am
-@@ -4,4 +4,8 @@ dist_install_DATA = \
-       ae_AlMateen.ttf \
+@@ -5,4 +5,7 @@ dist_install_DATA = \
        lcd.ttf \
        md_khmurabi_10.ttf \
--      nmsbd.ttf
-+      nmsbd.ttf \
+       nmsbd.ttf \
+-      tuxtxt.ttf
++      tuxtxt.ttf \
 +      MyriadPro-Regular.otf \
 +      MyriadPro-Semibold.otf \
 +      MyriadPro-SemiboldIt.otf 
-+
 diff --git a/data/skin.xml b/data/skin.xml
 index cde03f4..77c5f64 100755
 --- a/data/skin.xml
index 48aee2b..a69165f 100644 (file)
@@ -10,11 +10,17 @@ do_configure_prepend() {
 DEPENDS += "gst-plugins-base"
 
 EXTRA_OECONF_opendreambox += "--disable-apexsink --disable-dvdnav --disable-cdaudio --disable-mpeg2enc --disable-mplex"
+EXTRA_OECONF_vuplus += "--disable-apexsink --disable-dvdnav --disable-cdaudio --disable-mpeg2enc --disable-mplex"
 
 SRC_URI_append_opendreambox += " file://mpegpsdemux_speedup.diff;patch=1;pnum=0 \
                                 file://mpegtsdemux_fix_ac3_detection.diff;patch=1;pnum=0 \
                                 file://aacparse-fix-rank.diff;patch=1;pnum=1 \
                                 file://ac3parse-fix-rank.diff;patch=1;pnum=1"
 
+SRC_URI_append_vuplus += " file://mpegpsdemux_speedup.diff;patch=1;pnum=0 \
+                                file://mpegtsdemux_fix_ac3_detection.diff;patch=1;pnum=0 \
+                                file://aacparse-fix-rank.diff;patch=1;pnum=1 \
+                                file://ac3parse-fix-rank.diff;patch=1;pnum=1"
+
 RCONFLICTS_gst-plugin-mpegdemux = "gst-plugin-fluendo-mpegdemux"
 RREPLACES_gst-plugin-mpegdemux = "gst-plugin-fluendo-mpegdemux"
index 140fd50..5da9306 100644 (file)
@@ -1,6 +1,7 @@
 require gst-plugins.inc
 
 SRC_URI_append_opendreambox = " file://dvdsubdec-addproperty-singlebuffer.patch;patch=1"
+SRC_URI_append_vuplus = " file://dvdsubdec-addproperty-singlebuffer.patch;patch=1"
 
 INC_PR = "r0"
 PR = "${INC_PR}.0"
index 9b3baa9..371f92c 100644 (file)
@@ -26,6 +26,7 @@ FILES_libssl = "${libdir}/libssl.so.*"
 
 # disable unused algos
 EXTRA_OECONF = "${@base_contains('DISTRO', 'opendreambox', ' no-idea no-mdc2 no-rc5', '', d)}"
+EXTRA_OECONF = "${@base_contains('DISTRO', 'vuplus', ' no-idea no-mdc2 no-rc5', '', d)}"
 
 do_configure () {
        cd util
index 196219a..ff1a668 100644 (file)
@@ -1,5 +1,6 @@
 DEFAULT_PREFERENCE = "-1"
 DEFAULT_PREFERENCE_opendreambox = "1"
+DEFAULT_PREFERENCE_vuplus = "1"
 
 FILESPATHPKG .= ":qt-${PV}"
 
index 1625175..b020269 100644 (file)
@@ -1,5 +1,6 @@
 DEFAULT_PREFERENCE = "-1"
 DEFAULT_PREFERENCE_opendreambox = "1"
+DEFAULT_PREFERENCE_vuplus = "1"
 
 require qt4-tools-native.inc
 LICENSE = "LGPLv2.1 GPLv3"
index 1547d26..fb4e0e0 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Vuplus: Enigma2 Task for the Vuplus Distribution"
 SECTION = "vuplus/base"
 LICENSE = "MIT"
-PR = "r0"
+PR = "r1"
 
 inherit task
 
@@ -27,6 +27,9 @@ RDEPENDS_task-vuplus-enigma2 = "\
   enigma2-plugin-systemplugins-factorytest \
   enigma2-streamproxy \
   tuxbox-tuxtxt-32bpp \
+  enigma2-meta \
+  enigma2-plugins-meta \
+  enigma2-skins-meta \   
 "
 
 RRECOMMENDS_task-vuplus-enigma2 = "\
index 20bfffa..53575bc 100755 (executable)
@@ -16,8 +16,8 @@ PV_bm750 = "${KV}"
 PV_vusolo = "${KV}"
 
 
-SRCDATE_bm750 = "20101129"
-SRCDATE_vusolo = "20101129"
+SRCDATE_bm750 = "20101203"
+SRCDATE_vusolo = "20101203"
 
 
 RDEPENDS = "initscripts-vuplus kernel (${KV}) kernel-module-firmware-class kernel-module-input kernel-module-evdev kernel-module-i2c-core kernel-module-snd kernel-module-snd-pcm"
index dfcd0bc..cb48c2e 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "Configuration files for online package repositories aka feeds"
-PR = "r1"
+PR = "r2"
 
 DISTRO_FEED_PREFIX ?= "official"
 DISTRO_FEED_URI ?= "http://archive.vuplus.com/openembedded/${DISTRO_VERSION}/vuplus/${MACHINE}/feeds/stable"
index 528d4ac..f40048d 100644 (file)
@@ -2,9 +2,11 @@ DESCRIPTION = "The GNU Compact Disc Input and Control library (libcdio) contains
 LICENSE = "GPL"
 PR = "r1"
 DEPENDS_opendreambox = "libcddb"
+DEPENDS_vuplus = "libcddb"
 
 SRC_URI = "http://ftp.gnu.org/gnu/libcdio/libcdio-${PV}.tar.gz"
 SRC_URI_append_opendreambox = " file://libcdio-0.81-add-cdtextinfo.patch;patch=1"
+SRC_URI_append_vuplus = " file://libcdio-0.81-add-cdtextinfo.patch;patch=1"
 
 inherit autotools