busybox-1.11.3: fix segfault with fdisk command
authorMike Westerhof <mwester@dls.net>
Sun, 30 Nov 2008 02:23:19 +0000 (20:23 -0600)
committerMike Westerhof <mwester@dls.net>
Sun, 30 Nov 2008 02:23:19 +0000 (20:23 -0600)
(cherrypicked patch from newer busybox version)

packages/busybox/busybox-1.11.3/fdisk_lineedit_segfault.patch [new file with mode: 0644]
packages/busybox/busybox_1.11.3.bb

diff --git a/packages/busybox/busybox-1.11.3/fdisk_lineedit_segfault.patch b/packages/busybox/busybox-1.11.3/fdisk_lineedit_segfault.patch
new file mode 100644 (file)
index 0000000..633153f
--- /dev/null
@@ -0,0 +1,12 @@
+--- old/libbb/lineedit.c       2008/09/27 01:28:56     23530
++++ new/libbb/lineedit.c       2008/11/02 00:41:05     23898
+@@ -1412,7 +1412,8 @@
+       if ((state->flags & SAVE_HISTORY) && state->hist_file)
+               load_history(state->hist_file);
+ #endif
+-      state->cur_history = state->cnt_history;
++      if (state->flags & DO_HISTORY)
++              state->cur_history = state->cnt_history;
+       /* prepare before init handlers */
+       cmdedit_y = 0;  /* quasireal y, not true if line > xt*yt */
index 790bf51..08a4531 100644 (file)
@@ -1,10 +1,11 @@
 require busybox.inc
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "\
   http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
   \
   file://udhcpscript.patch;patch=1 \
+  file://fdisk_lineedit_segfault.patch;patch=1 \
   file://busybox-cron \
   file://busybox-httpd \
   file://busybox-udhcpd \