at76c503a-modules: add patch to build on 2.6.27 kernels.
authorMike Westerhof <mwester@dls.net>
Sat, 14 Feb 2009 07:43:05 +0000 (01:43 -0600)
committerMike Westerhof <mwester@dls.net>
Sat, 14 Feb 2009 07:43:05 +0000 (01:43 -0600)
This patch is constrained to ixp4xx devices right now because thats
all I have to build it for at this particular moment.

packages/at76c503a/at76c503a-modules/at76_usb-0.17-.patch [new file with mode: 0644]
packages/at76c503a/at76c503a-modules_0.17.bb

diff --git a/packages/at76c503a/at76c503a-modules/at76_usb-0.17-.patch b/packages/at76c503a/at76c503a-modules/at76_usb-0.17-.patch
new file mode 100644 (file)
index 0000000..06200f5
--- /dev/null
@@ -0,0 +1,66 @@
+--- at76_usb-0.17/at76_usb.c   2007-09-30 09:21:38.000000000 +0200
++++ at76_usb-0.17.1/at76_usb.c 2008-12-02 17:29:15.000000000 +0100
+@@ -2327,7 +2327,7 @@
+               iwe->cmd = SIOCGIWAP;
+               iwe->u.ap_addr.sa_family = ARPHRD_ETHER;
+               memcpy(iwe->u.ap_addr.sa_data, curr_bss->bssid, 6);
+-              curr_pos = iwe_stream_add_event(curr_pos,
++              curr_pos = iwe_stream_add_event(info, curr_pos,
+                                               extra + IW_SCAN_MAX_DATA, iwe,
+                                               IW_EV_ADDR_LEN);
+@@ -2335,7 +2335,7 @@
+               iwe->cmd = SIOCGIWESSID;
+               iwe->u.data.flags = 1;
+-              curr_pos = iwe_stream_add_point(curr_pos,
++              curr_pos = iwe_stream_add_point(info, curr_pos,
+                                               extra + IW_SCAN_MAX_DATA, iwe,
+                                               curr_bss->ssid);
+@@ -2346,14 +2346,14 @@
+                   IW_MODE_MASTER : IW_MODE_AUTO;
+               /* IW_MODE_AUTO = 0 which I thought is
+                * the most logical value to return in this case */
+-              curr_pos = iwe_stream_add_event(curr_pos,
++              curr_pos = iwe_stream_add_event(info, curr_pos,
+                                               extra + IW_SCAN_MAX_DATA, iwe,
+                                               IW_EV_UINT_LEN);
+               iwe->cmd = SIOCGIWFREQ;
+               iwe->u.freq.m = curr_bss->channel;
+               iwe->u.freq.e = 0;
+-              curr_pos = iwe_stream_add_event(curr_pos,
++              curr_pos = iwe_stream_add_event(info, curr_pos,
+                                               extra + IW_SCAN_MAX_DATA, iwe,
+                                               IW_EV_FREQ_LEN);
+@@ -2364,7 +2364,7 @@
+                       iwe->u.data.flags = IW_ENCODE_DISABLED;
+               iwe->u.data.length = 0;
+-              curr_pos = iwe_stream_add_point(curr_pos,
++              curr_pos = iwe_stream_add_point(info, curr_pos,
+                                               extra + IW_SCAN_MAX_DATA, iwe,
+                                               NULL);
+@@ -2383,7 +2383,7 @@
+                       iwe->u.qual.updated |= IW_QUAL_QUAL_INVALID;
+               }
+               /* Add new value to event */
+-              curr_pos = iwe_stream_add_event(curr_pos,
++              curr_pos = iwe_stream_add_event(info, curr_pos,
+                                               extra + IW_SCAN_MAX_DATA, iwe,
+                                               IW_EV_QUAL_LEN);
+@@ -2401,8 +2401,8 @@
+                       iwe->u.bitrate.value =
+                           ((curr_bss->rates[i] & 0x7f) * 500000);
+                       /* Add new value to event */
+-                      curr_val = iwe_stream_add_value(curr_pos, curr_val,
+-                                                      extra +
++                      curr_val = iwe_stream_add_value(info, curr_pos,
++                                                      curr_val, extra +
+                                                       IW_SCAN_MAX_DATA, iwe,
+                                                       IW_EV_PARAM_LEN);
+               }
index 58b782b..e0230de 100644 (file)
@@ -2,11 +2,13 @@ DESCRIPTION = "Driver for at76 based usb-wifi devices"
 SECTION = "base"
 LICENSE = "GPL"
 
-PR = "r1"
+PR = "r2"
 
 RDEPENDS = "at76c503-firmware"
 
 SRC_URI = "http://download.berlios.de/at76c503a/at76_usb-0.17.tar.gz"
+SRC_URI_ixp4xx = "http://download.berlios.de/at76c503a/at76_usb-0.17.tar.gz \
+                  file://at76_usb-0.17-.patch;patch=1"
 S = "${WORKDIR}/at76_usb-${PV}/"
 
 inherit module