rpm, yum: Reverted back python "site-recipes" to "site-packages".
authorStanislav Brabec <sbrabec@suse.cz>
Fri, 20 Mar 2009 14:06:09 +0000 (14:06 +0000)
committerutx@penguin.cz <utx@penguin.cz>
Fri, 20 Mar 2009 14:06:09 +0000 (14:06 +0000)
recipes/rpm/rpm_4.4.2.3.bb
recipes/yum/files/paths2.patch

index 6c2dc55..cb8bdd6 100644 (file)
@@ -30,7 +30,7 @@ EXTRA_OECONF = "--with-python \
                --without-efence"
 
 PACKAGES += "python-rpm"
-FILES_python-rpm = "${libdir}/python*/site-recipes/rpm/_*"
+FILES_python-rpm = "${libdir}/python*/site-packages/rpm/_*"
 
 # Handle the db MUTEX settings here, the POSIX library is
 # the default - "POSIX/pthreads/library".
index db614df..2e11bdc 100644 (file)
@@ -13,7 +13,7 @@
 -PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
 +PYSYSDIR = $(prefix)
  PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
- PKGDIR = $(PYLIBDIR)/site-recipes/$(PACKAGE)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
  
  all: 
        echo "Nothing to do"
@@ -27,7 +27,7 @@
 -PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
 +PYSYSDIR = $(prefix)
  PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
- PKGDIR = $(PYLIBDIR)/site-recipes/$(PACKAGE)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
  
  all: 
        echo "Nothing to do"