gstreamer: add the latest 0.10 versions of gstreamer and gst-plugins-*.
authorMatt Reimer <mattjreimer@gmail.com>
Fri, 15 Dec 2006 01:42:50 +0000 (01:42 +0000)
committerMatt Reimer <mattjreimer@gmail.com>
Fri, 15 Dec 2006 01:42:50 +0000 (01:42 +0000)
packages/gstreamer/gst-plugins-bad_0.10.3.bb [new file with mode: 0644]
packages/gstreamer/gst-plugins-base_0.10.11.bb [new file with mode: 0644]
packages/gstreamer/gst-plugins-good_0.10.4.bb [new file with mode: 0644]
packages/gstreamer/gstreamer_0.10.11.bb [new file with mode: 0644]

diff --git a/packages/gstreamer/gst-plugins-bad_0.10.3.bb b/packages/gstreamer/gst-plugins-bad_0.10.3.bb
new file mode 100644 (file)
index 0000000..7c548ac
--- /dev/null
@@ -0,0 +1,2 @@
+require gst-plugins.inc
+DEPENDS += "gst-plugins-base"
diff --git a/packages/gstreamer/gst-plugins-base_0.10.11.bb b/packages/gstreamer/gst-plugins-base_0.10.11.bb
new file mode 100644 (file)
index 0000000..4286a50
--- /dev/null
@@ -0,0 +1,7 @@
+require gst-plugins.inc
+PROVIDES += "gst-plugins"
+
+do_stage() {
+       autotools_stage_all
+}
+
diff --git a/packages/gstreamer/gst-plugins-good_0.10.4.bb b/packages/gstreamer/gst-plugins-good_0.10.4.bb
new file mode 100644 (file)
index 0000000..7c548ac
--- /dev/null
@@ -0,0 +1,2 @@
+require gst-plugins.inc
+DEPENDS += "gst-plugins-base"
diff --git a/packages/gstreamer/gstreamer_0.10.11.bb b/packages/gstreamer/gstreamer_0.10.11.bb
new file mode 100644 (file)
index 0000000..d44630f
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
+It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
+SECTION = "multimedia"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+HOMEPAGE = "http://www.gstreamer.net/"
+DEPENDS = "libxml2 glib-2.0 gettext-native popt"
+
+PR = "r0"
+# until we have decided a final naming scheme, 
+# don't use this package as a replacement for
+# version 0.8
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2"
+EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no"
+
+do_stage() {
+       oe_runmake install prefix=${STAGING_DIR} \
+              bindir=${STAGING_BINDIR} \
+              includedir=${STAGING_INCDIR} \
+              libdir=${STAGING_LIBDIR} \
+              datadir=${STAGING_DATADIR} \
+              mandir=${STAGING_DIR}/share/man
+}
+
+FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"