gcc 4.0.2: Disable libmudflap/ssp, add gcc-posix-open-fix.patch, really honor LDFLAGS...
authorTom Rini <trini@embeddedalley.com>
Thu, 30 Apr 2009 15:59:11 +0000 (08:59 -0700)
committerTom Rini <trini@embeddedalley.com>
Thu, 30 Apr 2009 16:16:41 +0000 (09:16 -0700)
recipes/gcc/gcc-4.0.2.inc
recipes/gcc/gcc-4.0.2/ldflags.patch [deleted file]
recipes/gcc/gcc-cross-initial_4.0.2.bb
recipes/gcc/gcc-cross-intermediate_4.0.2.bb
recipes/gcc/gcc-cross_4.0.2.bb
recipes/gcc/gcc_4.0.2.bb

index e3fafb8..a80e401 100644 (file)
@@ -3,9 +3,9 @@ require gcc-common.inc
 DEPENDS = "mpfr gmp"
 
 SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
+       file://gcc-posix-open-fix.patch;patch=1 \
        file://arm-nolibfloat.patch;patch=1 \
        file://arm-softfloat.patch;patch=1 \
-       file://ldflags.patch;patch=1 \
        file://GCOV_PREFIX_STRIP-cross-profile_4.1.patch;patch=1 \
        file://zecke-xgcc-cpp.patch;patch=1 "
 
@@ -25,5 +25,4 @@ SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
 # Language Overrides
 FORTRAN = ""
 
-EXTRA_OECONF_BASE = "--disable-libssp"
-
+EXTRA_OECONF_BASE = "--disable-libssp --disable-libmudflap"
diff --git a/recipes/gcc/gcc-4.0.2/ldflags.patch b/recipes/gcc/gcc-4.0.2/ldflags.patch
deleted file mode 100644 (file)
index 1196bf0..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- gcc-4.0.0/Makefile.tpl.old 2005-06-10 13:05:09.000000000 +0100
-+++ gcc-4.0.0/Makefile.tpl     2005-06-10 13:05:10.000000000 +0100
-@@ -339,7 +339,7 @@
- NM = @NM@
- LD = @LD@
--LDFLAGS = 
-+LDFLAGS = @LDFLAGS@
- RANLIB = @RANLIB@
---- gcc-4.0.0/Makefile.in.old  2005-06-10 17:13:12.000000000 +0100
-+++ gcc-4.0.0/Makefile.in      2005-06-10 17:13:22.000000000 +0100
-@@ -336,7 +336,7 @@
- NM = @NM@
- LD = @LD@
--LDFLAGS = 
-+LDFLAGS = @LDFLAGS@
- RANLIB = @RANLIB@
index 70877fe..ffe5fe3 100644 (file)
@@ -1,4 +1,4 @@
 require gcc-cross_${PV}.bb
 require gcc-cross-initial.inc
 
-EXTRA_OECONF += "--disable-multilib"
+EXTRA_OECONF += "--disable-multilib --disable-libssp --disable-libmudflap"
index 8df8d59..1feb434 100644 (file)
@@ -1,4 +1,4 @@
 require gcc-cross_${PV}.bb
 require gcc-cross-intermediate.inc
 
-EXTRA_OECONF += "--disable-multilib"
+EXTRA_OECONF += "--disable-multilib --disable-libssp --disable-libmudflap"
index 5324ee0..1aa527f 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r14"
+PR = "r15"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index 5bc3761..43d55fa 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r10"
+PR = "r11"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc