apt_0.7.19.bb, apt-native_0.7.19.bb : add a new fetchable version of apt
authorGraeme Gregory <dp@xora.org.uk>
Mon, 15 Dec 2008 14:10:58 +0000 (14:10 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Mon, 15 Dec 2008 14:12:31 +0000 (14:12 +0000)
packages/apt/apt-0.7.19/no-curl.patch [new file with mode: 0644]
packages/apt/apt-0.7.19/noconfigure.patch [new file with mode: 0644]
packages/apt/apt-0.7.19/nodoc.patch [new file with mode: 0644]
packages/apt/apt-native_0.7.19.bb [new file with mode: 0644]
packages/apt/apt.inc
packages/apt/apt_0.7.19.bb [new file with mode: 0644]

diff --git a/packages/apt/apt-0.7.19/no-curl.patch b/packages/apt/apt-0.7.19/no-curl.patch
new file mode 100644 (file)
index 0000000..3e5aff1
--- /dev/null
@@ -0,0 +1,40 @@
+---
+ configure.in     |    6 ------
+ methods/makefile |    7 -------
+ 2 files changed, 13 deletions(-)
+
+Index: apt-0.7.19/configure.in
+===================================================================
+--- apt-0.7.19.orig/configure.in       2008-12-15 13:44:44.000000000 +0000
++++ apt-0.7.19/configure.in    2008-12-15 13:57:16.000000000 +0000
+@@ -86,12 +86,6 @@
+ LIBS="$saveLIBS"
+-AC_CHECK_LIB(curl, curl_easy_init,
+-     [AC_CHECK_HEADER(curl/curl.h,
+-        curl_ok=yes,
+-        curl_ok=no)],
+-     AC_MSG_ERROR([failed: I need CURL due https support]),
+-)
+ AC_SUBST(BDBLIB)
+Index: apt-0.7.19/methods/makefile
+===================================================================
+--- apt-0.7.19.orig/methods/makefile   2008-11-24 09:32:23.000000000 +0000
++++ apt-0.7.19/methods/makefile        2008-12-15 13:57:44.000000000 +0000
+@@ -52,13 +52,6 @@
+ SOURCE = http.cc rfc2553emu.cc connect.cc
+ include $(PROGRAM_H)
+-# The https method
+-PROGRAM=https
+-SLIBS = -lapt-pkg -lcurl $(INTLLIBS)
+-LIB_MAKES = apt-pkg/makefile
+-SOURCE = https.cc
+-include $(PROGRAM_H)
+-
+ # The ftp method
+ PROGRAM=ftp
+ SLIBS = -lapt-pkg $(SOCKETLIBS) $(INTLLIBS)
diff --git a/packages/apt/apt-0.7.19/noconfigure.patch b/packages/apt/apt-0.7.19/noconfigure.patch
new file mode 100644 (file)
index 0000000..682a96d
--- /dev/null
@@ -0,0 +1,35 @@
+---
+ apt-pkg/packagemanager.cc |    4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
++++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
+@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
+    
+    List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
+    
++#if 0
+    // Perform immedate configuration of the package.
+    if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
+       if (SmartConfigure(Pkg) == false)
+        return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
++#endif
+    
+    return true;
+ }
+@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
+       DoneSomething = true;
+    }
+    
++#if 0
+    // Final run through the configure phase
+    if (ConfigureAll() == false)
+       return Failed;
+@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
+        return Failed;
+       }
+    }   
++#endif
+        
+    return Completed;
+ }
diff --git a/packages/apt/apt-0.7.19/nodoc.patch b/packages/apt/apt-0.7.19/nodoc.patch
new file mode 100644 (file)
index 0000000..db8cf93
--- /dev/null
@@ -0,0 +1,19 @@
+---
+ Makefile |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- apt-0.7.14.orig/Makefile
++++ apt-0.7.14/Makefile
+@@ -15,11 +15,11 @@ all headers library clean veryclean bina
+       $(MAKE) -C apt-inst $@
+       $(MAKE) -C methods $@
+       $(MAKE) -C cmdline $@
+       $(MAKE) -C ftparchive $@
+       $(MAKE) -C dselect $@
+-      $(MAKE) -C doc $@
++#     $(MAKE) -C doc $@
+       $(MAKE) -C po $@
+ # Some very common aliases
+ .PHONY: maintainer-clean dist-clean distclean pristine sanity 
+ maintainer-clean dist-clean distclean pristine sanity: veryclean
diff --git a/packages/apt/apt-native_0.7.19.bb b/packages/apt/apt-native_0.7.19.bb
new file mode 100644 (file)
index 0000000..268e9df
--- /dev/null
@@ -0,0 +1,7 @@
+require apt-native.inc
+
+PR = "r2"
+
+SRC_URI += "file://nodoc.patch;patch=1 \
+            file://noconfigure.patch;patch=1 \
+           file://no-curl.patch;patch=1"
index 5c49887..4a4de17 100644 (file)
@@ -2,8 +2,7 @@ DESCRIPTION = "Advanced front-end for dpkg."
 LICENSE = "GPL"
 SECTION = "base"
 
-SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
-           file://environment.patch;patch=1"
+SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz"
 
 S = "${WORKDIR}/apt-${PV}"
 
diff --git a/packages/apt/apt_0.7.19.bb b/packages/apt/apt_0.7.19.bb
new file mode 100644 (file)
index 0000000..251ed64
--- /dev/null
@@ -0,0 +1,27 @@
+DEPENDS = "curl db"
+RDEPENDS = "dpkg"
+
+require apt.inc
+
+SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
+           file://no-ko-translation.patch;patch=1 \
+           file://use-host.patch;patch=1 "
+PR = "r2"
+
+SRC_URI += "file://nodoc.patch;patch=1"
+
+require apt-package.inc
+
+FILES_${PN} += "${bindir}/apt-key"
+apt-manpages += "doc/apt-key.8"
+
+do_stage() {
+       install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/apt-pkg
+       eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
+       oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${STAGING_LIBDIR}/
+       ln -sf libapt-pkg$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-pkg.so
+       oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${STAGING_LIBDIR}/
+       ln -sf libapt-inst$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-inst.so
+
+       install -m 0644 include/apt-pkg/*.h ${STAGING_INCDIR}/apt-pkg/
+}