Add python-urlgrabber, python-iniparser, yum-metadata-parser and native variants...
authorRichard Purdie <richard@openedhand.com>
Mon, 25 Aug 2008 20:44:13 +0000 (20:44 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 19 Mar 2009 19:22:35 +0000 (20:22 +0100)
OE changes:

python-iniparse-native: use distutils_stage_all
python-urlgrabber-native: use distutils_stage_all
yum-metadata-parser-native: use distutils_stage_all

recipes/python/python-iniparse-native_0.2.3.bb [new file with mode: 0644]
recipes/python/python-iniparse_0.2.3.bb [new file with mode: 0644]
recipes/python/python-urlgrabber-native_3.1.0.bb [new file with mode: 0644]
recipes/python/python-urlgrabber_3.1.0.bb [new file with mode: 0644]
recipes/python/yum-metadata-parser-native_1.1.2.bb [new file with mode: 0644]
recipes/python/yum-metadata-parser_1.1.2.bb [new file with mode: 0644]

diff --git a/recipes/python/python-iniparse-native_0.2.3.bb b/recipes/python/python-iniparse-native_0.2.3.bb
new file mode 100644 (file)
index 0000000..68dd218
--- /dev/null
@@ -0,0 +1,9 @@
+require python-iniparse_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+PR = "r1"
+
+do_stage() {
+       distutils_stage_all
+}
diff --git a/recipes/python/python-iniparse_0.2.3.bb b/recipes/python/python-iniparse_0.2.3.bb
new file mode 100644 (file)
index 0000000..27a38f4
--- /dev/null
@@ -0,0 +1,11 @@
+DESCRIPTION = "iniparse is a INI parser for Python"
+HOMEPAGE = "http://code.google.com/p/iniparse/"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://iniparse.googlecode.com/files/iniparse-${PV}.tar.gz"
+S = "${WORKDIR}/iniparse-${PV}"
+
+inherit distutils
diff --git a/recipes/python/python-urlgrabber-native_3.1.0.bb b/recipes/python/python-urlgrabber-native_3.1.0.bb
new file mode 100644 (file)
index 0000000..5c2af55
--- /dev/null
@@ -0,0 +1,9 @@
+require python-urlgrabber_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+PR = "r1"
+
+do_stage() {
+       distutils_stage_all
+}
diff --git a/recipes/python/python-urlgrabber_3.1.0.bb b/recipes/python/python-urlgrabber_3.1.0.bb
new file mode 100644 (file)
index 0000000..a8ccf8a
--- /dev/null
@@ -0,0 +1,11 @@
+DESCRIPTION = "urlgrabber is a pure python package that drastically simplifies the fetching of files."
+HOMEPAGE = "http://linux.duke.edu/projects/urlgrabber/"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://linux.duke.edu/projects/urlgrabber/download/urlgrabber-${PV}.tar.gz"
+S = "${WORKDIR}/urlgrabber-${PV}"
+
+inherit distutils
diff --git a/recipes/python/yum-metadata-parser-native_1.1.2.bb b/recipes/python/yum-metadata-parser-native_1.1.2.bb
new file mode 100644 (file)
index 0000000..15d26a1
--- /dev/null
@@ -0,0 +1,9 @@
+require yum-metadata-parser_${PV}.bb
+inherit native
+DEPENDS = "python-native sqlite3-native glib-2.0-native libxml2-native"
+RDEPENDS = ""
+PR = "r1"
+
+do_stage() {
+       distutils_stage_all
+}
diff --git a/recipes/python/yum-metadata-parser_1.1.2.bb b/recipes/python/yum-metadata-parser_1.1.2.bb
new file mode 100644 (file)
index 0000000..24de761
--- /dev/null
@@ -0,0 +1,13 @@
+DESCRIPTION = "C-based metadata parser to quickly parse xml metadata into sqlite databases."
+HOMEPAGE = "http://linux.duke.edu/projects/yum/download.ptml"
+SECTION = "devel/python"
+PRIORITY = "optional"
+DEPENDS = "python sqlite3 glib-2.0 libxml2"
+LICENSE = "GPL"
+
+SRC_URI = "http://linux.duke.edu/projects/yum/download/yum-metadata-parser/yum-metadata-parser-${PV}.tar.gz"
+S = "${WORKDIR}/yum-metadata-parser-${PV}"
+
+TARGET_CFLAGS += "-I${STAGING_LIBDIR}/glib-2.0"
+
+inherit distutils