icu: Apply patch working around a gcc bug.
authorFlorian Boor <florian.boor@kernelconcepts.de>
Mon, 18 May 2009 13:22:21 +0000 (15:22 +0200)
committerFlorian Boor <florian.boor@kernelconcepts.de>
Mon, 18 May 2009 13:22:21 +0000 (15:22 +0200)
recipes/icu/files/rematch-gcc-bug.patch [new file with mode: 0644]
recipes/icu/icu_3.6.bb

diff --git a/recipes/icu/files/rematch-gcc-bug.patch b/recipes/icu/files/rematch-gcc-bug.patch
new file mode 100644 (file)
index 0000000..4d47056
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/i18n/Makefile.in 2009-05-18 13:55:49.000000000 +0200
++++ b/i18n/Makefile.in 2009-05-18 13:55:49.000000000 +0200
+@@ -105,6 +105,9 @@
+ all-local: $(ALL_TARGETS)
++rematch.o: $(srcdir)/rematch.cpp
++      $(CXX) $(CPPFLAGS) $(DEFS) -c -o $@ $<
++
+ install-local: install-headers install-library
+ install-library: all-local
index 1dbdf94..3eccfb5 100644 (file)
@@ -3,7 +3,8 @@ require icu-3.6.inc
 DEPENDS += "icu-native"
 PR = "r4"
 
-SRC_URI += "file://use-g++-for-linking.patch;patch=1"
+SRC_URI += "file://use-g++-for-linking.patch;patch=1 \
+            file://rematch-gcc-bug.patch;patch=1"
 
 do_configure_append() {
         for i in */Makefile */*.inc */*/Makefile */*/*.inc ; do