tunctl: new recipe, version 1.5
authorRoman I Khimov <khimov@altell.ru>
Fri, 17 Apr 2009 01:30:24 +0000 (01:30 +0000)
committerKoen Kooi <koen@openembedded.org>
Tue, 21 Apr 2009 20:45:50 +0000 (22:45 +0200)
Tool for controlling the TUN/TAP driver in Linux.

Signed-off-by: Koen Kooi <koen@openembedded.org>
conf/checksums.ini
recipes/tunctl/tunctl.inc [new file with mode: 0644]
recipes/tunctl/tunctl_1.5.bb [new file with mode: 0644]

index 512cc9a..30d4798 100644 (file)
@@ -22722,6 +22722,10 @@ sha256=d91b4addcbb241b04b6cf795447163ed890a436b10205d2cd9cc1885ea3d9433
 md5=ee74158c6c55ae16327595c70369ef83
 sha256=ef5e9bf276b65bb831f9c2554cd8784bd5b4ee65353808f82b7e2aef851587ec
 
+[http://downloads.sourceforge.net/tunctl/tunctl-1.5.tar.gz]
+md5=fdbedc263b3e85bb0e087cd567414607
+sha256=aa2a6c4cc6bfacb11e0d9f62334a6638a0d435475c61230116f00b6af8b14fff
+
 [http://alioth.debian.org/frs/download.php/2241/tuxmath_w_fonts-1.6.0.tar.gz]
 md5=3aa0e0e488719611f0bc4441b63a6f56
 sha256=f3aae7e2f67cf12f3da98325388c7b2f6718729aa69c5c804d1866d6a49f8592
diff --git a/recipes/tunctl/tunctl.inc b/recipes/tunctl/tunctl.inc
new file mode 100644 (file)
index 0000000..c9c7e95
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "The tunctl tool for controlling the TUN/TAP driver in Linux."
+SECTION = "net"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tunctl/tunctl-${PV}.tar.gz"
+
+do_compile() {
+       oe_runmake tunctl
+}
+
+do_install() {
+       install -d ${D}/${sbindir}
+       install -m 755 tunctl ${D}/${sbindir}
+}
diff --git a/recipes/tunctl/tunctl_1.5.bb b/recipes/tunctl/tunctl_1.5.bb
new file mode 100644 (file)
index 0000000..8a988a8
--- /dev/null
@@ -0,0 +1 @@
+require tunctl.inc