Merge commit 'dm/opendreambox-1.6' into test_0108
authorschon <schon@dev03-server>
Sat, 8 Jan 2011 07:23:07 +0000 (16:23 +0900)
committerschon <schon@dev03-server>
Sat, 8 Jan 2011 07:23:07 +0000 (16:23 +0900)
Conflicts:
recipes/enigma2/enigma2-plugins.bb
recipes/enigma2/enigma2-skins.bb
recipes/enigma2/enigma2.bb
recipes/gstreamer/gst-plugins-bad_0.10.20.bb
recipes/gstreamer/gst-plugins-ugly_0.10.16.bb

1  2 
recipes/enigma2/enigma2-plugins.bb
recipes/enigma2/enigma2.bb
recipes/gstreamer/gst-plugin-dvbmediasink.bb
recipes/gstreamer/gst-plugins-bad_0.10.20.bb
recipes/gstreamer/gst-plugins-base_0.10.31.bb
recipes/gstreamer/gst-plugins.inc

@@@ -3,40 -3,22 +3,28 @@@ MAINTAINER = "Felix Domke <tmbinc@elite
  
  PACKAGES_DYNAMIC = "enigma2-plugin-*"
  
- SRCDATE = "20101112"
- SRCDATE_vuplus = "20101112"
- # if you want the 2.7.0 release, use
- #TAG = ";tag=enigma2-plugins_rel27"
- #PV = "2.7cvs${SRCDATE}"
  # if you want experimental, use:
- TAG = ""
- PV = "experimental-cvs${SRCDATE}"
- # if vuplus
- #TAG_vuplus = ";tag=enigma2-plugins_rel28"
- #PV_vuplus = "2.8cvs${SRCDATE}"
- # if you want vuplus experimental, use:
- TAG_vuplus = ""
- PV_vuplus = "experimental-cvs${SRCDATE}"
- PR_vuplus = "r1"
+ SRCREV=""
+ SRCDATE="20101217"
+ BRANCH="master"
+ PV = "experimental-git${SRCDATE}"
  
- SRC_URI = "cvs://anonymous@cvs.schwerkraft.elitedvb.net/cvsroot/enigma2-plugins;module=enigma2-plugins;method=pserver${TAG};date=${SRCDATE}"
+ PR = "r0"
+ SRC_URI="git://schwerkraft.elitedvb.net/enigma2-plugins/enigma2-plugins.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
  
- #SRC_URI_append_vuplus = " \
- #        file://enigma2_plugins_mytube_vuplus.patch;patch=1;pnum=1 \
- #        file://enigma2_plugins_mytube_entry_vuplus.patch;patch=1;pnum=1 \
- #           file://dreamboxweb.png \
- #           file://favicon.ico"
+ EXTRA_OECONF = " \
+         BUILD_SYS=${BUILD_SYS} \
+         HOST_SYS=${HOST_SYS} \
+         STAGING_INCDIR=${STAGING_INCDIR} \
+         STAGING_LIBDIR=${STAGING_LIBDIR} \
+ "
  
 +SRC_URI_append_vuplus = " \
 +         file://enigma2_plugins_mytube_tpm.patch;patch=1;pnum=1 \
 +         file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
 +           file://dreamboxweb.png \
 +           file://favicon.ico"
 +
  FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
  FILES_${PN}-meta = "${datadir}/meta"
  PACKAGES += "${PN}-meta"
@@@ -62,8 -61,7 +62,8 @@@ DESCRIPTION_append_enigma2-plugin-syste
  PN = "enigma2"
  PR = "r0"
  
- SRCDATE = "20101124"
- SRCDATE_vuplus = "20101124"
+ SRCDATE = "20101204"
++SRCDATE_vuplus = "20101204"
  #SRCDATE is NOT used by git to checkout a specific revision
  #but we need it to build a ipk package version
  #when you like to checkout a specific revision of e2 you need
@@@ -9,18 -8,14 +9,20 @@@ do_configure_prepend() 
  
  DEPENDS += "gst-plugins-base"
  
- EXTRA_OECONF_opendreambox += "--disable-apexsink --disable-dvdnav --disable-cdaudio --disable-mpeg2enc --disable-mplex"
- EXTRA_OECONF_vuplus += "--disable-apexsink --disable-dvdnav --disable-cdaudio --disable-mpeg2enc --disable-mplex"
+ EXTRA_OECONF_opendreambox += "--disable-apexsink --disable-dvdnav --disable-cdaudio --disable-mpeg2enc --disable-mplex --disable-librfb"
++EXTRA_OECONF_vuplus += "--disable-apexsink --disable-dvdnav --disable-cdaudio --disable-mpeg2enc --disable-mplex --disable-librfb"
  
- SRC_URI_append_opendreambox += " file://mpegpsdemux_speedup.diff;patch=1;pnum=0 \
-                                file://mpegtsdemux_fix_ac3_detection.diff;patch=1;pnum=0 \
+ SRC_URI_append_opendreambox += " file://mpegpsdemux-speedup.diff;patch=1;pnum=0 \
+                                file://mpegtsdemux-fix-bd-streamtype-detection.diff;patch=1;pnum=1 \
                                 file://aacparse-fix-rank.diff;patch=1;pnum=1 \
-                                file://ac3parse-fix-rank.diff;patch=1;pnum=1"
+                                file://ac3parse-fix-rank.diff;patch=1;pnum=1 \
+                                file://ac3parse-just-warn-unknown-ac3-bsid.diff;patch=1;pnum=1 \
+ "
  
 +SRC_URI_append_vuplus += " file://mpegpsdemux_speedup.diff;patch=1;pnum=0 \
 +                               file://mpegtsdemux_fix_ac3_detection.diff;patch=1;pnum=0 \
 +                               file://aacparse-fix-rank.diff;patch=1;pnum=1 \
 +                               file://ac3parse-fix-rank.diff;patch=1;pnum=1"
 +
  RCONFLICTS_gst-plugin-mpegdemux = "gst-plugin-fluendo-mpegdemux"
  RREPLACES_gst-plugin-mpegdemux = "gst-plugin-fluendo-mpegdemux"
index 0000000,6aeb18f..f730871
mode 000000,100644..100644
--- /dev/null
@@@ -1,0 -1,15 +1,18 @@@
+ require gst-plugins.inc
+ SRC_URI_append_opendreambox = " file://samihack.patch;patch=1"
++SRC_URI_append_vuplus = " file://samihack.patch;patch=1"
+ PR = "${INC_PR}.0"
+ PROVIDES += "gst-plugins"
+ # gst-plugins-base only builds the alsa plugin
+ # if alsa has been built and is present.  You will
+ # not get an error if this is not present, just 
+ # a missing alsa plugin
+ DEPENDS += "${@base_contains('DISTRO', 'opendreambox', 'alsa-lib', 'cdparanoia pango libtheora alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv', d)}"
++DEPENDS += "${@base_contains('DISTRO', 'vuplus', 'alsa-lib', 'cdparanoia pango libtheora alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv', d)}"
+ EXTRA_OECONF_opendreambox += "--disable-theora --disable-pango --with-audioresample-format=int"
++EXTRA_OECONF_vuplus += "--disable-theora --disable-pango --with-audioresample-format=int"
index 5df9e48,59333b5..228af90
mode 100755,100644..100755
@@@ -3,9 -3,8 +3,9 @@@ DESCRIPTION = "Plugins for GStreamer
  DEPENDS = "gstreamer libmikmod liboil libogg tremor libvorbis"
  DEPENDS += "${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag', d)}"
  DEPENDS += "${@base_conditional('DISTRO', 'opendreambox', 'libmad libsoup-2.4 flac libmatroska libcdio libid3tag', '', d)}"
 +DEPENDS += "${@base_conditional('DISTRO', 'vuplus', 'libmad libsoup-2.4 flac libmatroska libcdio libid3tag', '', d)}"
  
- INC_PR = "r9"
+ INC_PR = "r1"
  
  PACKAGES_DYNAMIC = "gst-plugin-*"