vsftpd: fix commit c75ca22864fd7afe086c5fda6e0a9d7e9158a010
authorAndreas Oberritter <obi@opendreambox.org>
Tue, 8 Feb 2011 03:52:55 +0000 (04:52 +0100)
committerAndreas Oberritter <obi@opendreambox.org>
Tue, 8 Feb 2011 03:54:58 +0000 (04:54 +0100)
recipes/vsftpd/vsftpd_2.0.5.bb

index 9e31cac..771e662 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Secure ftp daemon"
 SECTION = "console/network"
 LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "ftp://vsftpd.beasts.org/users/cevans/vsftpd-${PV}.tar.gz \
            file://makefile.patch;patch=1 \
@@ -41,9 +41,12 @@ do_install() {
 }
 
 pkg_postinst() {
+        if [ "x$D" != "x" ]; then
+                exit 1
+        fi
         addgroup ftp
         adduser --system --home /var/lib/ftp --no-create-home --ingroup ftp --disabled-password -s /bin/false ftp
-        mkdir -p ${D}${localstatedir}/share/empty
+        mkdir -p ${localstatedir}/share/empty
 }
 
 INITSCRIPT_NAME = "vsftpd"