Update driver and fix auto resolution problem
authorschon <schon@dev03-server>
Mon, 21 Mar 2011 05:12:38 +0000 (14:12 +0900)
committerschon <schon@dev03-server>
Mon, 21 Mar 2011 05:12:38 +0000 (14:12 +0900)
recipes/enigma2/enigma2-plugins.bb
recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_autoresolution_fix.patch [new file with mode: 0644]
recipes/vuplus/vuplus-dvb-modules.bb

index 306450b..5bec9de 100755 (executable)
@@ -23,6 +23,7 @@ SRC_URI_append_vuplus = " \
           file://enigma2_plugins_mytube_tpm.patch;patch=1;pnum=1 \
           file://enigma2_plugins_webinterface_tpm.patch;patch=1;pnum=1 \
           file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
+          file://enigma2_plugins_autoresolution_fix.patch;patch=1;pnum=1 \
            file://dreamboxweb.png \
            file://favicon.ico"
 
diff --git a/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_autoresolution_fix.patch b/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_autoresolution_fix.patch
new file mode 100644 (file)
index 0000000..481d00d
--- /dev/null
@@ -0,0 +1,14 @@
+diff --git a/autoresolution/src/plugin.py b/autoresolution/src/plugin.py
+old mode 100644
+new mode 100755
+index f034c06..0dee6ce
+--- a/autoresolution/src/plugin.py
++++ b/autoresolution/src/plugin.py
+@@ -302,6 +302,7 @@ class AutoResSetupMenu(Screen, ConfigListScreen):
+       def apply(self):
+               for x in self["config"].list:
++                      x[1].onDeselect(self.session)
+                       x[1].save()
+               self.close()
index 68c5e4f..1918d49 100755 (executable)
@@ -16,8 +16,8 @@ PV_bm750 = "${KV}"
 PV_vusolo = "${KV}"
 
 
-SRCDATE_bm750 = "20110317"
-SRCDATE_vusolo = "20110317"
+SRCDATE_bm750 = "20110321"
+SRCDATE_vusolo = "20110321"
 
 
 RDEPENDS = "initscripts-vuplus kernel (${KV}) kernel-module-firmware-class kernel-module-input kernel-module-evdev kernel-module-i2c-core kernel-module-snd kernel-module-snd-pcm"