lyx: after a while of breakage, this software works again.
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Tue, 3 Mar 2009 23:13:44 +0000 (00:13 +0100)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Tue, 3 Mar 2009 23:15:14 +0000 (00:15 +0100)
Updated to the latest version.

conf/checksums.ini
packages/lyx/files/no-session-manager.patch [new file with mode: 0644]
packages/lyx/lyx_1.4.1.bb [deleted file]
packages/lyx/lyx_1.4.4.bb [deleted file]
packages/lyx/lyx_1.5.1.bb [deleted file]
packages/lyx/lyx_1.6.1.bb

index ee2ad24..2be8714 100644 (file)
@@ -14806,6 +14806,10 @@ sha256=daa670b686f959ab15e457425e57c50f0b973ee4d24d6a4171c33f467961ad1d
 md5=0ae3b9ccb2aa74776be4af8c199dbbe9
 sha256=d720ff082ed29d385c52e7ad370499d23275e595e9d7a321b383609f68acf23e
 
+[ftp://ftp.lyx.org/pub/lyx/stable/1.6.x/lyx-1.6.1.tar.bz2]
+md5=fdac2fc40b435857afa1089fc04c1fcb
+sha256=8f45da9653fc9ea927f3b8c7c96390fc8277d7c969b735a7b615c06e4e5c03d7
+
 [http://downloads.sourceforge.net/sevenzip/lzma417.tar.bz2]
 md5=b1ab85e4dc1eb1323d77fef47a2cb71c
 sha256=84124d4501798ecb284fceb28931db023850535e1b1146c884add7b3b0331cbc
diff --git a/packages/lyx/files/no-session-manager.patch b/packages/lyx/files/no-session-manager.patch
new file mode 100644 (file)
index 0000000..edb8f00
--- /dev/null
@@ -0,0 +1,20 @@
+Index: lyx-1.6.1/src/frontends/qt4/GuiApplication.cpp
+===================================================================
+--- lyx-1.6.1.orig/src/frontends/qt4/GuiApplication.cpp
++++ lyx-1.6.1/src/frontends/qt4/GuiApplication.cpp
+@@ -1320,6 +1320,7 @@
+ void GuiApplication::commitData(QSessionManager & sm)
+ {
++#if 0 // no session manager in OE's Qt4
+       /// The implementation is required to avoid an application exit
+       /// when session state save is triggered by session manager.
+       /// The default implementation sends a close event to all
+@@ -1329,6 +1330,7 @@
+       /// FIXME: verify if the default implementation is enough now.
+       if (sm.allowsInteraction() && !closeAllViews())
+               sm.cancel();
++#endif
+ }
diff --git a/packages/lyx/lyx_1.4.1.bb b/packages/lyx/lyx_1.4.1.bb
deleted file mode 100644 (file)
index 1a89a42..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
-SECTION = "x11/office"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.lyx.org"
-DEPENDS = "boost"
-RRECOMMENDS = "tetex"
-PR = "r1"
-
-# we're checking out from svn because the tarball doesn't contain the necessary stuff to run autoreconf
-SRC_URI = "svn://svn.lyx.org/lyx/lyx-devel/tags;module=lyx-1_4_1;rev=13847"
-S = "${WORKDIR}/lyx-1_4_1"
-
-inherit qt3x11 autotools
-
-EXTRA_OECONF = "--with-frontend=qt --with-qt-dir=${QTDIR}"
-PARALLEL_MAKE = ""
-
-do_configure_prepend() {
-       echo "NOTE: touching missing files, please report to upstream"
-       touch lib/configure.ac lib/doc/LaTeXConfig.lyx lib/textclass.lst
-}
-
-export UIC="${OE_QMAKE_UIC}"
-export MOC="${OE_QMAKE_MOC}"
diff --git a/packages/lyx/lyx_1.4.4.bb b/packages/lyx/lyx_1.4.4.bb
deleted file mode 100644 (file)
index 26970a3..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
-SECTION = "x11/office"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.lyx.org"
-DEPENDS = "boost"
-RRECOMMENDS = "tetex"
-PR = "r0"
-
-# we're checking out from svn because the tarball doesn't contain the necessary stuff to run autoreconf
-SRC_URI = "svn://svn.lyx.org/lyx/lyx-devel/tags;module=lyx-1_4_4;rev=17185"
-S = "${WORKDIR}/lyx-1_4_4"
-
-inherit qt3x11 autotools
-
-EXTRA_OECONF = "--with-frontend=qt --with-qt-dir=${QTDIR}"
-PARALLEL_MAKE = ""
-
-do_configure_prepend() {
-       echo "NOTE: touching missing files, please report to upstream"
-       touch lib/configure.ac lib/doc/LaTeXConfig.lyx lib/textclass.lst
-}
-
-export UIC="${OE_QMAKE_UIC}"
-export MOC="${OE_QMAKE_MOC}"
diff --git a/packages/lyx/lyx_1.5.1.bb b/packages/lyx/lyx_1.5.1.bb
deleted file mode 100644 (file)
index 32e3096..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
-SECTION = "x11/office"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.lyx.org"
-DEPENDS = "boost qt4-x11-free"
-RSUGGESTS = "tetex"
-RDEPENDS = "python-shell python-textutils"
-PR = "r0"
-
-SRC_URI = "http://lyx.cybermirror.org/stable/lyx-${PV}.tar.bz2"
-
-inherit qt4x11 autotools
-
-EXTRA_OECONF = " --with-qt4-dir=${QTDIR} -enable-pch"
-EXTRA_QMAKEVARS_POST = "DEFINES+=_LIBC"
-PARALLEL_MAKE = ""
-
-do_configure_prepend() {
-       echo "NOTE: touching missing files, please report to upstream"
-       touch lib/configure.ac lib/doc/LaTeXConfig.lyx lib/textclass.lst
-}
-
-export UIC="${OE_QMAKE_UIC}"
-export MOC="${OE_QMAKE_MOC}"
-export OE_QMAKE_LIBS_X11="-lX11 -lXext"
index 3d5b6c6..d293a08 100644 (file)
@@ -2,24 +2,27 @@ DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
 SECTION = "x11/office"
 LICENSE = "GPL"
 HOMEPAGE = "http://www.lyx.org"
-DEPENDS = "boost qt4-x11-free"
+DEPENDS = "qt4-x11-free"
 RSUGGESTS = "tetex"
 RDEPENDS = "python-shell python-textutils"
 PR = "r0"
 
-SRC_URI = "http://lyx.cybermirror.org/stable/lyx-${PV}.tar.bz2"
+SRC_URI = "\
+  ftp://ftp.lyx.org/pub/lyx/stable/1.6.x/lyx-${PV}.tar.bz2 \
+  file://no-session-manager.patch;patch=1 \
+"
 
 inherit qt4x11 autotools
 
-EXTRA_OECONF = " --with-qt4-dir=${QTDIR} -enable-pch"
+EXTRA_OECONF = "\
+  --with-qt4-dir=${QTDIR} \
+  --enable-threads=posix \
+"
+
 EXTRA_QMAKEVARS_POST = "DEFINES+=_LIBC"
 PARALLEL_MAKE = ""
 
-do_configure_prepend() {
-       echo "NOTE: touching missing files, please report to upstream"
-       touch lib/configure.ac lib/doc/LaTeXConfig.lyx lib/textclass.lst
+do_configure() {
+       gnu-configize
+       oe_runconf
 }
-
-#export UIC="${OE_QMAKE_UIC}"
-#export MOC="${OE_QMAKE_MOC}"
-#export OE_QMAKE_LIBS_X11="-lX11 -lXext"