apr + apr-util: merge from poky
authorKoen Kooi <koen@openembedded.org>
Sat, 7 Feb 2009 21:49:55 +0000 (22:49 +0100)
committerKoen Kooi <koen@openembedded.org>
Sat, 7 Feb 2009 21:49:55 +0000 (22:49 +0100)
packages/apr/apr-util/configfix.patch [new file with mode: 0644]
packages/apr/apr-util/configure_fixes.patch
packages/apr/apr-util/configure_fixes.patch.old [new file with mode: 0644]
packages/apr/apr-util_1.3.4.bb [new file with mode: 0644]
packages/apr/apr/cleanup.patch [new file with mode: 0644]
packages/apr/apr/configfix.patch [new file with mode: 0644]
packages/apr/apr/configure_fixes.patch
packages/apr/apr_1.3.3.bb [new file with mode: 0644]

diff --git a/packages/apr/apr-util/configfix.patch b/packages/apr/apr-util/configfix.patch
new file mode 100644 (file)
index 0000000..a8953e5
--- /dev/null
@@ -0,0 +1,49 @@
+Index: apr-util-1.3.4/apu-config.in
+===================================================================
+--- apr-util-1.3.4.orig/apu-config.in  2009-01-12 17:08:06.000000000 +0000
++++ apr-util-1.3.4/apu-config.in       2009-01-12 17:09:00.000000000 +0000
+@@ -134,14 +134,7 @@
+     exit 0
+     ;;
+     --includes)
+-    if test "$location" = "installed"; then
+         flags="$flags -I$includedir $INCLUDES"
+-    elif test "$location" = "source"; then
+-        flags="$flags -I$APU_SOURCE_DIR/include $INCLUDES"
+-    else
+-        # this is for VPATH builds
+-        flags="$flags -I$APU_BUILD_DIR/include -I$APU_SOURCE_DIR/include $INCLUDES"
+-    fi
+     ;;
+     --ldflags)
+     flags="$flags $LDFLAGS"
+@@ -155,28 +148,10 @@
+     exit 0
+     ;;
+     --link-ld)
+-    if test "$location" = "installed"; then
+-        ### avoid using -L if libdir is a "standard" location like /usr/lib
+         flags="$flags -L$libdir -l$APRUTIL_LIBNAME"
+-    else
+-        flags="$flags -L$APU_BUILD_DIR -l$APRUTIL_LIBNAME"
+-    fi
+     ;;
+     --link-libtool)
+-    # If the LA_FILE exists where we think it should be, use it.  If we're
+-    # installed and the LA_FILE does not exist, assume to use -L/-l
+-    # (the LA_FILE may not have been installed).  If we're building ourselves,
+-    # we'll assume that at some point the .la file be created.
+-    if test -f "$LA_FILE"; then
+-        flags="$flags $LA_FILE"
+-    elif test "$location" = "installed"; then
+-        ### avoid using -L if libdir is a "standard" location like /usr/lib
+-        # Since the user is specifying they are linking with libtool, we
+-        # *know* that -R will be recognized by libtool.
+-        flags="$flags -L$libdir -R$libdir -l$APRUTIL_LIBNAME"
+-    else
+-        flags="$flags $LA_FILE"
+-    fi
++        flags="$flags -l$APRUTIL_LIBNAME"
+     ;;
+     --apu-la-file)
+     if test -f "$LA_FILE"; then
index 7c6fa6a..0b2a090 100644 (file)
@@ -1,6 +1,8 @@
---- /tmp/configure.in  2009-02-06 16:34:14.000000000 +0100
-+++ apr-util-1.2.12/configure.in       2009-02-06 16:34:38.000000000 +0100
-@@ -8,13 +8,13 @@
+Index: apr-util-1.3.4/configure.in
+===================================================================
+--- apr-util-1.3.4.orig/configure.in
++++ apr-util-1.3.4/configure.in
+@@ -8,14 +8,14 @@ AC_INIT(export_vars.sh.in)
  AC_CONFIG_HEADER(include/private/apu_config.h)
  AC_CONFIG_AUX_DIR(build)
  
@@ -11,6 +13,7 @@
 -sinclude(build/find_apr.m4)
 -sinclude(build/dbm.m4)
 -sinclude(build/dbd.m4)
+-sinclude(build/dso.m4)
 +#sinclude(build/apu-conf.m4)
 +#sinclude(build/apu-iconv.m4)
 +#sinclude(build/apu-hints.m4)
 +#sinclude(build/find_apr.m4)
 +#sinclude(build/dbm.m4)
 +#sinclude(build/dbd.m4)
++#sinclude(build/dso.m4)
  
  dnl Generate ./config.nice for reproducing runs of configure
  dnl 
-@@ -45,10 +45,10 @@
- # against installed versions of libapr instead of those just
- # built.
- case $host in
--*-apple-darwin*) LT_NO_INSTALL="" ;;
--*) LT_NO_INSTALL="-no-install" ;;
-+*-apple-darwin*) LV_NO_INSTALL="" ;;
-+*) LV_NO_INSTALL="-no-install" ;;
- esac
--AC_SUBST(LT_NO_INSTALL)
-+AC_SUBST(LV_NO_INSTALL)
- dnl
- dnl compute the top directory of the build
diff --git a/packages/apr/apr-util/configure_fixes.patch.old b/packages/apr/apr-util/configure_fixes.patch.old
new file mode 100644 (file)
index 0000000..16f88b3
--- /dev/null
@@ -0,0 +1,25 @@
+Index: apr-util-1.2.12/configure.in
+===================================================================
+--- apr-util-1.2.12.orig/configure.in  2008-03-08 19:15:00.000000000 +0000
++++ apr-util-1.2.12/configure.in       2008-03-08 19:15:13.000000000 +0000
+@@ -8,13 +8,13 @@
+ AC_CONFIG_HEADER(include/private/apu_config.h)
+ AC_CONFIG_AUX_DIR(build)
+-sinclude(build/apu-conf.m4)
+-sinclude(build/apu-iconv.m4)
+-sinclude(build/apu-hints.m4)
+-sinclude(build/apr_common.m4)
+-sinclude(build/find_apr.m4)
+-sinclude(build/dbm.m4)
+-sinclude(build/dbd.m4)
++#sinclude(build/apu-conf.m4)
++#sinclude(build/apu-iconv.m4)
++#sinclude(build/apu-hints.m4)
++#sinclude(build/apr_common.m4)
++#sinclude(build/find_apr.m4)
++#sinclude(build/dbm.m4)
++#sinclude(build/dbd.m4)
+ dnl Generate ./config.nice for reproducing runs of configure
+ dnl 
diff --git a/packages/apr/apr-util_1.3.4.bb b/packages/apr/apr-util_1.3.4.bb
new file mode 100644 (file)
index 0000000..6b2e9cc
--- /dev/null
@@ -0,0 +1,34 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r5"
+
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
+           file://configfix.patch;patch=1 \
+           file://configure_fixes.patch;patch=1"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ 
+               --with-dbm=gdbm \
+               --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
+               --without-sqlite2 \
+               --without-sqlite3 \
+               --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
+
+
+inherit autotools_stage lib_package binconfig
+
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
+do_configure_prepend() {
+       cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+       echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
+}
+
+do_configure_append() {
+       sed -i -e  s:apr_builders=/usr/share/build-1:apr_builders=${STAGING_DATADIR}/build-1:g ${S}/build/rules.mk
+       sed -i /^LIBTOOL/d ${S}/build/rules.mk
+       echo LIBTOOL="${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool --tag=CC" >> ${S}/build/rules.mk
+}
+
diff --git a/packages/apr/apr/cleanup.patch b/packages/apr/apr/cleanup.patch
new file mode 100644 (file)
index 0000000..fd74826
--- /dev/null
@@ -0,0 +1,42 @@
+Index: apr-1.3.3/build/buildcheck.sh
+===================================================================
+--- apr-1.3.3.orig/build/buildcheck.sh 2009-01-15 13:32:33.000000000 +0000
++++ apr-1.3.3/build/buildcheck.sh      2009-01-15 13:33:06.000000000 +0000
+@@ -32,35 +32,4 @@
+ echo "buildconf: autoconf version $ac_version (ok)"
+ fi
+-# Sample libtool --version outputs:
+-# ltmain.sh (GNU libtool) 1.3.3 (1.385.2.181 1999/07/02 15:49:11)
+-# ltmain.sh (GNU libtool 1.1361 2004/01/02 23:10:52) 1.5a
+-# output is multiline from 1.5 onwards
+-
+-# Require libtool 1.4 or newer
+-libtool=`build/PrintPath glibtool libtool libtool15 libtool14`
+-lt_pversion=`$libtool --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'`
+-if test -z "$lt_pversion"; then
+-echo "buildconf: libtool not found."
+-echo "           You need libtool version 1.4 or newer installed"
+-echo "           to build APR from SVN."
+-exit 1
+-fi
+-lt_version=`echo $lt_pversion|sed -e 's/\([a-z]*\)$/.\1/'`
+-IFS=.; set $lt_version; IFS=' '
+-lt_status="good"
+-if test "$1" = "1"; then
+-   if test "$2" -lt "4"; then
+-      lt_status="bad"
+-   fi
+-fi
+-if test $lt_status = "good"; then
+-   echo "buildconf: libtool version $lt_pversion (ok)"
+-   exit 0
+-fi
+-
+-echo "buildconf: libtool version $lt_pversion found."
+-echo "           You need libtool version 1.4 or newer installed"
+-echo "           to build APR from SVN."
+-
+-exit 1
++exit 0
+\ No newline at end of file
diff --git a/packages/apr/apr/configfix.patch b/packages/apr/apr/configfix.patch
new file mode 100644 (file)
index 0000000..995555e
--- /dev/null
@@ -0,0 +1,51 @@
+Index: apr-1.3.3/apr-config.in
+===================================================================
+--- apr-1.3.3.orig/apr-config.in       2009-01-12 15:16:31.000000000 +0000
++++ apr-1.3.3/apr-config.in    2009-01-12 15:19:25.000000000 +0000
+@@ -152,14 +152,7 @@
+     flags="$flags $LDFLAGS"
+     ;;
+     --includes)
+-    if test "$location" = "installed"; then
+         flags="$flags -I$includedir $EXTRA_INCLUDES"
+-    elif test "$location" = "source"; then
+-        flags="$flags -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
+-    else
+-        # this is for VPATH builds
+-        flags="$flags -I$APR_BUILD_DIR/include -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
+-    fi
+     ;;
+     --srcdir)
+     echo $APR_SOURCE_DIR
+@@ -181,29 +167,14 @@
+     exit 0
+     ;;
+     --link-ld)
+-    if test "$location" = "installed"; then
+-        ### avoid using -L if libdir is a "standard" location like /usr/lib
+-        flags="$flags -L$libdir -l${APR_LIBNAME}"
+-    else
+-        ### this surely can't work since the library is in .libs?
+-        flags="$flags -L$APR_BUILD_DIR -l${APR_LIBNAME}"
+-    fi
++        flags="$flags -l${APR_LIBNAME}"
+     ;;
+     --link-libtool)
+     # If the LA_FILE exists where we think it should be, use it.  If we're
+     # installed and the LA_FILE does not exist, assume to use -L/-l
+     # (the LA_FILE may not have been installed).  If we're building ourselves,
+     # we'll assume that at some point the .la file be created.
+-    if test -f "$LA_FILE"; then
+-        flags="$flags $LA_FILE"
+-    elif test "$location" = "installed"; then
+-        ### avoid using -L if libdir is a "standard" location like /usr/lib
+-        # Since the user is specifying they are linking with libtool, we
+-        # *know* that -R will be recognized by libtool.
+-        flags="$flags -L$libdir -R$libdir -l${APR_LIBNAME}"
+-    else
+-        flags="$flags $LA_FILE"
+-    fi
++        flags="$flags -l${APR_LIBNAME}"
+     ;;
+     --shlib-path-var)
+     echo "$SHLIBPATH_VAR"
index 88e1e21..86ceb8c 100644 (file)
@@ -1,54 +1,66 @@
---- /tmp/configure.in  2009-02-02 17:50:51.000000000 +0100
-+++ apr-1.2.12/configure.in    2009-02-02 17:54:55.000000000 +0100
-@@ -13,12 +13,11 @@
- dnl 
- dnl Include our own M4 macros along with those for libtool
- dnl 
--sinclude(build/apr_common.m4)
--sinclude(build/apr_network.m4)
--sinclude(build/apr_threads.m4)
--sinclude(build/apr_hints.m4)
--sinclude(build/libtool.m4)
--sinclude(build/ltsugar.m4)
-+#sinclude(build/apr_common.m4)
-+#sinclude(build/apr_network.m4)
-+#sinclude(build/apr_threads.m4)
-+#sinclude(build/apr_hints.m4)
-+#sinclude(build/libtool.m4)
+Index: apr-1.3.3/configure.in
+===================================================================
+--- apr-1.3.3.orig/configure.in
++++ apr-1.3.3/configure.in
+@@ -794,39 +794,6 @@ AC_CHECK_FUNCS([mmap munmap shm_open shm
+                 create_area])
  
- dnl Hard-coded inclusion at the tail end of apr_private.h:
- AH_BOTTOM([
-@@ -197,8 +196,8 @@
+ APR_CHECK_DEFINE(MAP_ANON, sys/mman.h)
+-AC_CHECK_FILE(/dev/zero)
+-
+-# Not all systems can mmap /dev/zero (such as HP-UX).  Check for that.
+-if test "$ac_cv_func_mmap" = "yes" &&
+-   test "$ac_cv_file__dev_zero" = "yes"; then
+-    AC_MSG_CHECKING(for mmap that can map /dev/zero)
+-    AC_TRY_RUN([
+-#include <sys/types.h>
+-#include <sys/stat.h>
+-#include <fcntl.h>
+-#ifdef HAVE_SYS_MMAN_H
+-#include <sys/mman.h>
+-#endif
+-    int main()
+-    {
+-        int fd;
+-        void *m;
+-        fd = open("/dev/zero", O_RDWR);
+-        if (fd < 0) {
+-            return 1;
+-        }
+-        m = mmap(0, sizeof(void*), PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0);
+-        if (m == (void *)-1) {  /* aka MAP_FAILED */
+-            return 2;
+-        }
+-        if (munmap(m, sizeof(void*)) < 0) {
+-            return 3;
+-        }
+-        return 0;
+-    }], [], [ac_cv_file__dev_zero=no], [ac_cv_file__dev_zero=no])
+-
+-    AC_MSG_RESULT($ac_cv_file__dev_zero)
+-fi
  
- if test "x$use_libtool" = "xyes"; then
-       lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -o $@ -c $< && touch $@'
--      LT_VERSION="-version-info `$get_version libtool $version_hdr APR`"
--      link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LT_LDFLAGS) \$(COMPILE) ${LT_VERSION} \$(ALL_LDFLAGS) -o \$@"
-+      LV_VERSION="-version-info `$get_version libtool $version_hdr APR`"
-+      link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LV_LDFLAGS) \$(COMPILE) ${LV_VERSION} \$(ALL_LDFLAGS) -o \$@"
-       so_ext='lo'
-       lib_target='-rpath $(libdir) $(OBJECTS)'
-       export_lib_target='-rpath \$(libdir) \$(OBJECTS)'
-@@ -225,7 +224,7 @@
- AC_SUBST(export_lib_target)
- AC_SUBST(shlibpath_var)
- AC_SUBST(LTFLAGS)
--AC_SUBST(LT_LDFLAGS)
-+AC_SUBST(LV_LDFLAGS)
+ # Now we determine which one is our anonymous shmem preference.
+ haveshmgetanon="0"
+@@ -1518,13 +1485,14 @@ else
+     bigendian=0
+ fi
  
- dnl ----------------------------- Checks for compiler flags
- nl='
-@@ -2132,10 +2131,10 @@
- # against installed versions of libapr instead of those just
- # built.
- case $host in
--*-apple-darwin*) LT_NO_INSTALL="" ;;
--*) LT_NO_INSTALL="-no-install" ;;
-+*-apple-darwin*) LV_NO_INSTALL="" ;;
-+*) LV_NO_INSTALL="-no-install" ;;
- esac
--AC_SUBST(LT_NO_INSTALL)
-+AC_SUBST(LV_NO_INSTALL)
+-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>
+-#include <sys/uio.h>],struct iovec,0)
+-if test "$ac_cv_sizeof_struct_iovec" = "0"; then
+-    have_iovec=0
+-else
+-    have_iovec=1
+-fi
++#APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>
++##include <sys/uio.h>],struct iovec,0)
++#if test "$ac_cv_sizeof_struct_iovec" = "0"; then
++#    have_iovec=0
++#else
++#    have_iovec=1
++#fi
++have_iovec=1
  
- #
- # BSD/OS (BSDi) needs to use a different include syntax in the Makefiles
+ AC_SUBST(voidp_size)
+ AC_SUBST(short_value)
diff --git a/packages/apr/apr_1.3.3.bb b/packages/apr/apr_1.3.3.bb
new file mode 100644 (file)
index 0000000..0d0fd66
--- /dev/null
@@ -0,0 +1,32 @@
+DESCRIPTION = "Apache Portable Runtime (APR) library"
+SECTION = "libs"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r4"
+
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
+           file://configure_fixes.patch;patch=1 \
+          file://cleanup.patch;patch=1 \
+           file://configfix.patch;patch=1"
+
+inherit autotools lib_package binconfig
+
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
+do_configure_prepend() {
+       cd ${S}
+       ./buildconf
+}
+
+do_stage() {
+       autotools_stage_all
+       install -d ${STAGING_DATADIR}/apr
+       cp ${S}/build/apr_rules.mk ${STAGING_DATADIR}/apr/
+       sed -i s,apr_builddir=.*,apr_builddir=,g ${STAGING_DATADIR}/apr/apr_rules.mk
+       sed -i s,apr_builders=.*,apr_builders=,g ${STAGING_DATADIR}/apr/apr_rules.mk
+       sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${TARGET_PREFIX}libtool,g ${STAGING_DATADIR}/apr/apr_rules.mk
+       sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g ${STAGING_DATADIR}/apr/apr_rules.mk
+       cp ${S}/build/mkdir.sh ${STAGING_DATADIR}/apr/
+       cp ${S}/build/make_exports.awk ${STAGING_DATADIR}/apr/
+       cp ${S}/build/make_var_export.awk ${STAGING_DATADIR}/apr/
+}