fakechroot: fix duplicated readlink (from Poky)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 28 Aug 2008 07:35:22 +0000 (07:35 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 19 Mar 2009 19:22:35 +0000 (20:22 +0100)
git-svn-id: https://svn.o-hand.com/repos/poky@5115 311d38ba-8fff-0310-9ca6-ca027cbcb966

recipes/fakechroot/fakechroot-native_2.5.bb
recipes/fakechroot/fakechroot_2.5.bb
recipes/fakechroot/files/fix-readlink.patch [new file with mode: 0644]

index efd41c7..8cb88bd 100644 (file)
@@ -1,5 +1,5 @@
 SECTION = "base"
-PR = "r0"
+PR = "r1"
 require fakechroot_${PV}.bb
 inherit native
 
index c791512..dfe9077 100644 (file)
@@ -2,6 +2,7 @@ SECTION = "base"
 DESCRIPTION = "Gives a fake root environment which can support chroot"
 LICENSE = "GPL"
 
-SRC_URI = "${DEBIAN_MIRROR}/main/f/fakechroot/fakechroot_${PV}.orig.tar.gz"
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakechroot/fakechroot_${PV}.orig.tar.gz \
+           file://fix-readlink.patch;patch=1"
 
 inherit autotools
diff --git a/recipes/fakechroot/files/fix-readlink.patch b/recipes/fakechroot/files/fix-readlink.patch
new file mode 100644 (file)
index 0000000..f218956
--- /dev/null
@@ -0,0 +1,32 @@
+---
+ src/libfakechroot.c |    4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- fakechroot-2.5.orig/src/libfakechroot.c
++++ fakechroot-2.5/src/libfakechroot.c
+@@ -596,11 +596,11 @@ void fakechroot_init (void)
+     nextsym(open64, "open64");
+ #if !defined(HAVE___OPENDIR2)
+     nextsym(opendir, "opendir");
+ #endif
+     nextsym(pathconf, "pathconf");
+-    nextsym(readlink, "readlink");
++    nextsym(readlink, "own_readlink");
+     nextsym(realpath, "realpath");
+     nextsym(remove, "remove");
+ #ifdef HAVE_REMOVEXATTR
+     nextsym(removexattr, "removexattr");
+ #endif
+@@ -1864,11 +1864,11 @@ long pathconf (const char *path, int nam
+     return next_pathconf(path, name);
+ }
+ /* #include <unistd.h> */
+-int readlink (const char *path, char *buf, READLINK_TYPE_ARG3)
++int own_readlink (const char *path, char *buf, READLINK_TYPE_ARG3)
+ {
+     int status;
+     char tmp[FAKECHROOT_MAXPATH], *tmpptr;
+     char *fakechroot_path, *fakechroot_ptr, fakechroot_buf[FAKECHROOT_MAXPATH];