thunar: properly install libraries into the staging area
authorOtavio Salvador <otavio@ossystems.com.br>
Fri, 17 Oct 2008 20:27:06 +0000 (17:27 -0300)
committerOtavio Salvador <otavio@ossystems.com.br>
Fri, 17 Oct 2008 20:36:45 +0000 (17:36 -0300)
xfdesktop needs thunar-vfs to be able to show the created icons on the
Desktop area and for it to work thunar needs to properly install the
required headers on staging.

packages/xfce/thunar_0.9.0.bb

index 4aebde8..4c5f025 100644 (file)
@@ -1,9 +1,10 @@
 DESCRIPTION = "File manager for the Xfce Desktop Environment"
 DEPENDS = "libxfcegui4 exo dbus-glib libexif xfce4-panel libice libsm"
 
-inherit xfce
+inherit xfce pkgconfig
 
 SRC_URI = "http://www.us.xfce.org/archive/xfce-4.4.2/src/Thunar-${PV}.tar.bz2"
+FILE_PR = 'r1'
 
 S = "${WORKDIR}/Thunar-${PV}/"
 
@@ -13,3 +14,7 @@ FILES_${PN} += "${libdir}/thunarx-1/*.so \
                 ${datadir}/Thunar \
                 ${datadir}/xfce4"
 FILES_${PN}-dbg += "${libdir}/thunarx-1/.debug/ ${libexecdir}/xfce4/panel-plugins/.debug/"
+
+do_stage () {
+       autotools_stage_all
+}