glibc: 5090_all_stubs-rule-fix.patch allows building from very deep
authorRaymond Danks <raymond@edanks.com>
Tue, 18 Apr 2006 01:30:14 +0000 (01:30 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Tue, 18 Apr 2006 01:30:14 +0000 (01:30 +0000)
directories

packages/glibc/files/5090_all_stubs-rule-fix.patch [new file with mode: 0644]
packages/glibc/files/etc/ld.so.conf
packages/glibc/glibc_2.3.3+cvs20050420.bb
packages/glibc/glibc_2.3.5+cvs20050627.bb

diff --git a/packages/glibc/files/5090_all_stubs-rule-fix.patch b/packages/glibc/files/5090_all_stubs-rule-fix.patch
new file mode 100644 (file)
index 0000000..c445a52
--- /dev/null
@@ -0,0 +1,39 @@
+Index: Makerules
+===================================================================
+RCS file: /cvs/glibc/libc/Makerules,v
+retrieving revision 1.430
+diff -u -r1.430 Makerules
+--- libc/Makerules     5 Mar 2005 19:24:32 -0000       1.430
++++ libc/Makerules     22 Apr 2005 18:31:27 -0000
+@@ -1390,15 +1390,26 @@
+                 $(addprefix $(objpfx),$(extra-objs))
+ $(objpfx)stubs: $(objs-for-stubs)
+ ifneq (,$(strip $(objs-for-stubs)))
+-      $(OBJDUMP) -h $^ | \
+-      $(AWK) '/\.gnu\.glibc-stub\./ { \
+-                sub(/\.gnu\.glibc-stub\./, "", $$2); \
+-                stubs[$$2] = 1; } \
+-              END { for (s in stubs) print "#define __stub_" s }' > $@T
++      $(stub-obj-list)
++      cat $@L | xargs \
++              $(OBJDUMP) -h | \
++              $(AWK) '/\.gnu\.glibc-stub\./ { \
++                        sub(/\.gnu\.glibc-stub\./, "", $$2); \
++                        stubs[$$2] = 1; } \
++                      END { for (s in stubs) print "#define __stub_" s }' \
++              > $@T
++      -rm -f $@L
+       mv -f $@T $@
+ else
+       > $@
+ endif
++
++define stub-obj-list
++-@rm -f $@L
++-@echo "Generating stub obj list..."
++$(foreach file,$^,
++@echo >> $@L '$(file)')
++endef
\f
+ # This information is not used for making distributions any more.
+ # But it's used by MakeTAGS for making TAGS files and the .pot files.
index 3f9b41a..fb1aab5 100644 (file)
@@ -1,3 +1,3 @@
 /usr/local/lib
 /opt/QtPalmtop/lib
-
+/usr/X11R6/lib
index c110619..23b4098 100644 (file)
@@ -33,7 +33,7 @@ SRC_URI = "cvs://anoncvs@sources.redhat.com/cvs/glibc;module=libc;date=${@bb.dat
           file://eabi-patch-1;patch=1 \
           file://eabi-patch-2;patch=1 \
           file://eabi-patch-3;patch=1 \
-          \
+          file://5090_all_stubs-rule-fix.patch;patch=1 \
            file://etc/ld.so.conf \
           file://generate-supported.mk"
 
index d192590..c8f1d56 100644 (file)
@@ -53,6 +53,7 @@ SRC_URI = "http://familiar.handhelds.org/source/v0.8.3/stash_libc_sources.redhat
           file://fhs-linux-paths.patch;patch=1 \
           file://dl-cache-libcmp.patch;patch=1 \
           file://ldsocache-varrun.patch;patch=1 \
+          file://5090_all_stubs-rule-fix.patch;patch=1 \
            file://etc/ld.so.conf \
           file://generate-supported.mk"