add igmp.patch and update PR of dvbapp.
authorkos <kos@dev3>
Thu, 19 Jan 2012 04:46:54 +0000 (13:46 +0900)
committerkos <kos@dev3>
Thu, 19 Jan 2012 04:46:54 +0000 (13:46 +0900)
recipes/enigma2/enigma2.bb
recipes/linux/linux-bm750-3.1.1/igmp.patch [new file with mode: 0644]
recipes/linux/linux-bm750_3.1.1.bb
recipes/linux/linux-vuplus-3.1.1.inc
recipes/linux/linux-vusolo-3.1.1/igmp.patch [new file with mode: 0644]
recipes/linux/linux-vusolo_3.1.1.bb
recipes/linux/linux-vuultimo-3.1.1/igmp.patch [new file with mode: 0644]
recipes/linux/linux-vuultimo_3.1.1.bb
recipes/linux/linux-vuuno-3.1.1/igmp.patch [new file with mode: 0644]
recipes/linux/linux-vuuno_3.1.1.bb

index 66b75b2..8facf62 100644 (file)
@@ -67,7 +67,7 @@ DESCRIPTION_append_enigma2-plugin-systemplugins-crashreport = "automatically sen
 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "twisted-mail twisted-names python-compression python-mime python-email"
 
 PN = "enigma2"
-PR = "r13"
+PR = "r14"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
diff --git a/recipes/linux/linux-bm750-3.1.1/igmp.patch b/recipes/linux/linux-bm750-3.1.1/igmp.patch
new file mode 100644 (file)
index 0000000..e2e648c
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/net/ipv4/igmp.c b/net/ipv4/igmp.c
+index d577199..e0d42db 100644
+--- a/net/ipv4/igmp.c
++++ b/net/ipv4/igmp.c
+@@ -875,6 +875,8 @@ static void igmp_heard_query(struct in_device *in_dev, struct sk_buff *skb,
+                * to be intended in a v3 query.
+                */
+               max_delay = IGMPV3_MRC(ih3->code)*(HZ/IGMP_TIMER_SCALE);
++              if (!max_delay)
++                      max_delay = 1;  /* can't mod w/ 0 */
+       } else { /* v3 */
+               if (!pskb_may_pull(skb, sizeof(struct igmpv3_query)))
+                       return;
index 4c8b7ce..a1c1e49 100644 (file)
@@ -1,6 +1,6 @@
 require linux-vuplus-3.1.1.inc
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI += "\
         file://linux_3.1.1_bm750.patch;patch=1;pnum=1 \
index 4e75ad6..50e8e93 100644 (file)
@@ -9,6 +9,7 @@ MODULE = "linux-3.1.1"
 SRC_URI += "http://archive.vuplus.com/download/kernel/linux-${KV}_${SRCREV}.tar.bz2 \
        file://fix_cpu_proc.patch;patch=1;pnum=1 \
         file://${MACHINE}_defconfig \
+       file://igmp.patch;patch=1;pnum=1 \
         "
 
 S = "${WORKDIR}/linux-${KV}"
diff --git a/recipes/linux/linux-vusolo-3.1.1/igmp.patch b/recipes/linux/linux-vusolo-3.1.1/igmp.patch
new file mode 100644 (file)
index 0000000..e2e648c
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/net/ipv4/igmp.c b/net/ipv4/igmp.c
+index d577199..e0d42db 100644
+--- a/net/ipv4/igmp.c
++++ b/net/ipv4/igmp.c
+@@ -875,6 +875,8 @@ static void igmp_heard_query(struct in_device *in_dev, struct sk_buff *skb,
+                * to be intended in a v3 query.
+                */
+               max_delay = IGMPV3_MRC(ih3->code)*(HZ/IGMP_TIMER_SCALE);
++              if (!max_delay)
++                      max_delay = 1;  /* can't mod w/ 0 */
+       } else { /* v3 */
+               if (!pskb_may_pull(skb, sizeof(struct igmpv3_query)))
+                       return;
index a7d275b..aa05b37 100644 (file)
@@ -1,6 +1,6 @@
 require linux-vuplus-3.1.1.inc
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI += "\
         file://linux_3.1.1_vusolo.patch;patch=1;pnum=1 \
diff --git a/recipes/linux/linux-vuultimo-3.1.1/igmp.patch b/recipes/linux/linux-vuultimo-3.1.1/igmp.patch
new file mode 100644 (file)
index 0000000..e2e648c
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/net/ipv4/igmp.c b/net/ipv4/igmp.c
+index d577199..e0d42db 100644
+--- a/net/ipv4/igmp.c
++++ b/net/ipv4/igmp.c
+@@ -875,6 +875,8 @@ static void igmp_heard_query(struct in_device *in_dev, struct sk_buff *skb,
+                * to be intended in a v3 query.
+                */
+               max_delay = IGMPV3_MRC(ih3->code)*(HZ/IGMP_TIMER_SCALE);
++              if (!max_delay)
++                      max_delay = 1;  /* can't mod w/ 0 */
+       } else { /* v3 */
+               if (!pskb_may_pull(skb, sizeof(struct igmpv3_query)))
+                       return;
index b940aec..b4ae76b 100644 (file)
@@ -1,6 +1,6 @@
 require linux-vuplus-3.1.1.inc
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI += "\
        file://linux-sata_brcm.patch;patch=1;pnum=1 \
diff --git a/recipes/linux/linux-vuuno-3.1.1/igmp.patch b/recipes/linux/linux-vuuno-3.1.1/igmp.patch
new file mode 100644 (file)
index 0000000..e2e648c
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/net/ipv4/igmp.c b/net/ipv4/igmp.c
+index d577199..e0d42db 100644
+--- a/net/ipv4/igmp.c
++++ b/net/ipv4/igmp.c
+@@ -875,6 +875,8 @@ static void igmp_heard_query(struct in_device *in_dev, struct sk_buff *skb,
+                * to be intended in a v3 query.
+                */
+               max_delay = IGMPV3_MRC(ih3->code)*(HZ/IGMP_TIMER_SCALE);
++              if (!max_delay)
++                      max_delay = 1;  /* can't mod w/ 0 */
+       } else { /* v3 */
+               if (!pskb_may_pull(skb, sizeof(struct igmpv3_query)))
+                       return;
index fedaf4d..2c884a0 100644 (file)
@@ -1,6 +1,6 @@
 require linux-vuplus-3.1.1.inc
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI += "\
         file://linux_3.1.1_vuuno.patch;patch=1;pnum=1 \