Add patch to support 1080p.
authorkos <kos@dev3>
Thu, 8 Nov 2012 10:16:33 +0000 (19:16 +0900)
committerkos <kos@dev3>
Thu, 8 Nov 2012 10:22:10 +0000 (19:22 +0900)
recipes/enigma2/enigma2.bb
recipes/enigma2/enigma2/vuplus/enigma2_vuplus_1080p.patch [new file with mode: 0644]

index 4065c16..03165fd 100644 (file)
@@ -77,7 +77,7 @@ RDEPENDS_enigma2-plugin-extensions-hbbtv = "tslib-conf libts-1.0-0 libsysfs2 lib
 RDEPENDS_enigma2-plugin-systemplugins-devicemanager = "util-linux-ng-blkid ntfs-3g dosfstools"
 
 PN = "enigma2"
-PR = "r56"
+PR = "r57"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
@@ -138,7 +138,10 @@ SRC_URI = "git://192.168.102.66/dvbapp_factory.git;protocol=http;branch=vuplus_e
 
 SRC_URI_append_bm750 = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
 SRC_URI_append_vuuno = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
-SRC_URI_append_vusolo2 = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
+SRC_URI_append_vusolo2 = " \
+          file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1 \
+          file://enigma2_vuplus_1080p.patch;patch=1;pnum=1 \
+"
 
 SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
 
diff --git a/recipes/enigma2/enigma2/vuplus/enigma2_vuplus_1080p.patch b/recipes/enigma2/enigma2/vuplus/enigma2_vuplus_1080p.patch
new file mode 100644 (file)
index 0000000..bb8f5f2
--- /dev/null
@@ -0,0 +1,28 @@
+diff --git a/lib/python/Plugins/SystemPlugins/Videomode/VideoHardware.py b/lib/python/Plugins/SystemPlugins/Videomode/VideoHardware.py
+index 6ecbfd4..d801f58 100644
+--- a/lib/python/Plugins/SystemPlugins/Videomode/VideoHardware.py
++++ b/lib/python/Plugins/SystemPlugins/Videomode/VideoHardware.py
+@@ -37,6 +37,10 @@ class VideoHardware:
+                                                               "60Hz":         { 60: "1080i" },
+                                                               "multi":        { 50: "1080i50", 60: "1080i" } }
++      rates["1080p"] =                { "50Hz":               { 50: "1080p50" },
++                                                              "60Hz":         { 60: "1080p" },
++                                                              "multi":        { 50: "1080p50", 60: "1080p" } }
++
+       rates["PC"] = { 
+               "1024x768": { 60: "1024x768" }, # not possible on DM7025
+               "800x600" : { 60: "800x600" },  # also not possible
+@@ -55,10 +59,10 @@ class VideoHardware:
+       modes["Scart"] = ["PAL", "NTSC", "Multi"]
+       modes["YPbPr"] = ["720p", "1080i", "576p", "480p", "576i", "480i"]
+-      modes["DVI"] = ["720p", "1080i", "576p", "480p", "576i", "480i"]
++      modes["DVI"] = ["720p", "1080i", "1080p", "576p", "480p", "576i", "480i"]
+       modes["DVI-PC"] = ["PC"]
+-      widescreen_modes = set(["720p", "1080i"])
++      widescreen_modes = set(["720p", "1080i", "1080p"])
+       def getOutputAspect(self):
+               ret = (16,9)