modify recipes/tuxbox
authorikseong <ikseong@dev03-server.(none)>
Fri, 4 Jun 2010 11:13:12 +0000 (20:13 +0900)
committerikseong <ikseong@dev03-server.(none)>
Fri, 4 Jun 2010 11:13:12 +0000 (20:13 +0900)
modify tuxbox-libtuxtxt.bb with bm750,vusolo on SRC_URI_append.
modify tuxbox-tuxtxt-32bpp.bb with vuplus on SRC_URI_append.
add patch file in tuxbox-tuxtxt-32bpp/vuplus/ : tuxtxt_vuplus.patch.

recipes/tuxbox/tuxbox-libtuxtxt.bb [changed mode: 0644->0755]
recipes/tuxbox/tuxbox-tuxtxt-32bpp.bb [changed mode: 0644->0755]
recipes/tuxbox/tuxbox-tuxtxt-32bpp/vuplus/tuxtxt_vuplus.patch [new file with mode: 0644]

old mode 100644 (file)
new mode 100755 (executable)
index d5db62d..d5bbf96
@@ -35,6 +35,16 @@ SRC_URI_append_dm8000 = " \
        file://resize_framebuffer.diff;patch=1 \
        file://allow_different_demux.diff;patch=1"
 
+SRC_URI_append_bm750 = " \
+       file://32bpp.diff;patch=1 \
+       file://resize_framebuffer.diff;patch=1 \
+       file://allow_different_demux.diff;patch=1"
+
+SRC_URI_append_vusolo = " \
+       file://32bpp.diff;patch=1 \
+       file://resize_framebuffer.diff;patch=1 \
+       file://allow_different_demux.diff;patch=1"
+
 S = "${WORKDIR}/libs"
 EXTRA_OECONF = "--with-target=native"
 
old mode 100644 (file)
new mode 100755 (executable)
index 4c96f11..823a3a1
@@ -15,6 +15,9 @@ SRC_URI = "cvs://anoncvs@cvs.tuxbox.org/cvs/tuxbox;module=apps/tuxbox/plugins/tu
        file://allow_different_demux.diff;patch=1 \
        file://plugin.py"
 
+SRC_URI_append_vuplus = " \
+       file://tuxtxt_vuplus.patch;patch=1;pnum=1"      
+
 FILES_${PN} = "/usr/bin/tuxtxt /usr/share/fonts /usr/lib/enigma2/python/Plugins/Extensions/Tuxtxt /etc/tuxtxt"
 
 S = "${WORKDIR}/tuxtxt"
diff --git a/recipes/tuxbox/tuxbox-tuxtxt-32bpp/vuplus/tuxtxt_vuplus.patch b/recipes/tuxbox/tuxbox-tuxtxt-32bpp/vuplus/tuxtxt_vuplus.patch
new file mode 100644 (file)
index 0000000..4c2a950
--- /dev/null
@@ -0,0 +1,12 @@
+--- tuxtxt_org/tuxtxt.c        2010-04-01 13:18:13.000000000 +0900
++++ tuxtxt/tuxtxt.c    2010-04-01 13:21:57.000000000 +0900
+@@ -2664,7 +2664,8 @@
+       static int init_lcd = 1, old_cached_pages = -1, old_page = -1, old_subpage = -1, old_subpage_max = -1, old_hintmode = -1;
+       int  x, y, subpage_max = 0, update_lcd = 0;
+-      if (lcd == -1) return; // for Dreamboxes without LCD-Display (5xxx)
++//    if (lcd == -1) 
++              return; // for Dreamboxes without LCD-Display (5xxx)
+       /* init or update lcd */
+       if (init_lcd)
+       {