merge of '8c185e14edc5b4a26b15fd54f158e22f3f659282'
authorRobert Schuster <thebohemian@gmx.net>
Tue, 23 Sep 2008 06:32:19 +0000 (06:32 +0000)
committerRobert Schuster <thebohemian@gmx.net>
Tue, 23 Sep 2008 06:32:19 +0000 (06:32 +0000)
     and 'c70fa985cd7a9e0166e70d97ccac1c7dd324fe8b'

21 files changed:
MAINTAINERS
conf/distro/include/preferred-om-2008-versions.inc
packages/classpath/classpath-native.inc
packages/classpath/classpath.inc
packages/cnc/openredalert/gcc43-fix.patch [new file with mode: 0644]
packages/cnc/openredalert_r438.bb
packages/ecj/ecj-bootstrap-native.bb [new file with mode: 0644]
packages/ecj/ecj-bootstrap-native_3.3.2.bb [deleted file]
packages/ecj/ecj-bootstrap-native_3.3.bb [deleted file]
packages/ecj/ecj-bootstrap-native_3.4.bb [deleted file]
packages/ecj/ecj-initial.bb [new file with mode: 0644]
packages/ecj/ecj-initial_3.3.2.bb [deleted file]
packages/ecj/ecj-initial_3.3.bb [deleted file]
packages/ecj/ecj-initial_3.4.bb [deleted file]
packages/ecj/libecj-bootstrap.inc [new file with mode: 0644]
packages/ecj/libecj-bootstrap_3.3.2.bb [new file with mode: 0644]
packages/ecj/libecj-bootstrap_3.3.bb [new file with mode: 0644]
packages/ecj/libecj-bootstrap_3.4.bb [new file with mode: 0644]
packages/obsolete/wesnoth_svn.bb [new file with mode: 0644]
packages/wesnoth/wesnoth_1.4.5.bb [new file with mode: 0644]
packages/wesnoth/wesnoth_svn.bb [deleted file]

index 65f6a10..072bf0a 100644 (file)
@@ -275,8 +275,8 @@ Recipes:    jikes-native, jikes-initial, ecj-initial, ecj-bootstrap-native
 Recipes:    classpath*, cacao*, jamvm*
 Recipes:    miglayout, javasqlite*, sqlitejbdc
 Recipes:    swt-gtk, rxtx, dbus-java, libmatthew, kxml2, xmlpull
-Recipes:    woodstox2
+Recipes:    woodstox2, phoneme-advanced-*
 Recipes:    midpath*, logic-analyze
-Recipes:    kobodeluxe
+Recipes:    kobodeluxe, wesnoth
 Recipes:    hildon-thumbnail, libhildon*, libosso*, mce-dev, libconic
 Recipes:    libgpsbt, libgpsmgr, osso-gnome-vfs2, osso-gwconnect, osso-ic-oss
index a42e555..e8ed77e 100644 (file)
@@ -288,7 +288,7 @@ PREFERRED_VERSION_e2tools-native ?= "0.0.16"
 PREFERRED_VERSION_eb ?= "4.3"
 PREFERRED_VERSION_ebtables ?= "2.0.6"
 PREFERRED_VERSION_eciadsl ?= "0.11"
-PREFERRED_VERSION_ecj-native ?= "3.3"
+PREFERRED_VERSION_libecj-bootstrap ?= "3.3"
 PREFERRED_VERSION_editres ?= "1.0.2"
 PREFERRED_VERSION_eds-feed ?= "0.3.2"
 PREFERRED_VERSION_eel ?= "2.12.2"
index 992a16e..060dd3f 100644 (file)
@@ -18,6 +18,7 @@ do_configure_prepend () {
 }
 
 export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial"
+export JAVACFLAGS="-nowarn"
 
 # Note: the --with-ecj options seems redundant but is
 # for compatibility with older classpath versions.
index 65bc465..e0d6a2a 100644 (file)
@@ -21,6 +21,8 @@ SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
 
 S = "${WORKDIR}/${PBN}-${PV}"
 
+export JAVA = "java"
+
 EXTRA_OECONF = "\
   --with-glibj \
   --with-ecj=javac \
diff --git a/packages/cnc/openredalert/gcc43-fix.patch b/packages/cnc/openredalert/gcc43-fix.patch
new file mode 100644 (file)
index 0000000..aa99d99
--- /dev/null
@@ -0,0 +1,13 @@
+Index: openredalert-0.0+svnr438-r0/src/misc/Compression.h
+===================================================================
+--- openredalert-0.0+svnr438-r0.orig/src/misc/Compression.h    2008-09-21 15:20:33.000000000 +0200
++++ openredalert-0.0+svnr438-r0/src/misc/Compression.h 2008-09-21 15:21:10.000000000 +0200
+@@ -20,6 +20,8 @@
\r
+ #include "SDL/SDL_types.h"\r
\r
++#include <cstring>\r
++\r
+ /** \r
+  * Various decompression routines for format80, format40, and \r
+  * format20 type graphics\r
index 4da2456..098f293 100644 (file)
@@ -4,8 +4,11 @@ LICENSE = "GPLv2"
 DEPENDS = "virtual/libsdl libsdl-mixer" 
 
 SRC_URI = "http://openredalert.googlecode.com/files/openredalert-${PV}-src.tar.gz \
+           file://gcc43-fix.patch;patch=1 \
            file://openredalert-launcher"
 
+PR = "r1"
+
 S = "${WORKDIR}"
 
 CFLAGS_append = " -I. -I${STAGING_INCDIR}"
diff --git a/packages/ecj/ecj-bootstrap-native.bb b/packages/ecj/ecj-bootstrap-native.bb
new file mode 100644 (file)
index 0000000..04f8ba4
--- /dev/null
@@ -0,0 +1,36 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+#
+# This recipe uses the jar created by libecj-bootstrap.
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "EPL"
+
+DEPENDS = "libecj-bootstrap"
+
+PROVIDES = "virtual/javac-native"
+
+SRC_URI = "file://ecj.in"
+
+S = "${WORKDIR}"
+
+JAR = "ecj-bootstrap.jar"
+
+inherit native
+
+do_compile() {
+  # Create the start script
+  echo "#!/bin/sh" > ecj-bootstrap
+  echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
+  echo "RUNTIME=java" >> ecj-bootstrap
+  cat ecj.in >> ecj-bootstrap
+}
+
+do_stage() {
+  install -d ${STAGING_BINDIR}
+  install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
+  install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
+}
diff --git a/packages/ecj/ecj-bootstrap-native_3.3.2.bb b/packages/ecj/ecj-bootstrap-native_3.3.2.bb
deleted file mode 100644 (file)
index bd43474..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
-# and no less features.
-#
-# Since the VM running the compiler has no effect on the produced bytecode this recipe
-# uses the jar created by ecj-initial and creates a start script that runs it with a different
-# VM.
-
-DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
-HOMEPAGE = "http://www.eclipse.org/"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "EPL"
-
-DEPENDS = "ecj-initial virtual/java-native"
-
-PROVIDES = "virtual/javac-native"
-
-SRC_URI = "file://ecj.in"
-
-S = "${WORKDIR}"
-
-JAR = "ecj-bootstrap-${PV}.jar"
-
-inherit native
-
-do_compile() {
-  # Create the start script
-  echo "#!/bin/sh" > ecj-bootstrap
-  echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
-  echo "RUNTIME=java" >> ecj-bootstrap
-  cat ecj.in >> ecj-bootstrap
-}
-
-do_stage() {
-  install -d ${STAGING_BINDIR}
-  install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
-  install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
-}
diff --git a/packages/ecj/ecj-bootstrap-native_3.3.bb b/packages/ecj/ecj-bootstrap-native_3.3.bb
deleted file mode 100644 (file)
index bd43474..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
-# and no less features.
-#
-# Since the VM running the compiler has no effect on the produced bytecode this recipe
-# uses the jar created by ecj-initial and creates a start script that runs it with a different
-# VM.
-
-DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
-HOMEPAGE = "http://www.eclipse.org/"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "EPL"
-
-DEPENDS = "ecj-initial virtual/java-native"
-
-PROVIDES = "virtual/javac-native"
-
-SRC_URI = "file://ecj.in"
-
-S = "${WORKDIR}"
-
-JAR = "ecj-bootstrap-${PV}.jar"
-
-inherit native
-
-do_compile() {
-  # Create the start script
-  echo "#!/bin/sh" > ecj-bootstrap
-  echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
-  echo "RUNTIME=java" >> ecj-bootstrap
-  cat ecj.in >> ecj-bootstrap
-}
-
-do_stage() {
-  install -d ${STAGING_BINDIR}
-  install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
-  install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
-}
diff --git a/packages/ecj/ecj-bootstrap-native_3.4.bb b/packages/ecj/ecj-bootstrap-native_3.4.bb
deleted file mode 100644 (file)
index bd43474..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
-# and no less features.
-#
-# Since the VM running the compiler has no effect on the produced bytecode this recipe
-# uses the jar created by ecj-initial and creates a start script that runs it with a different
-# VM.
-
-DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
-HOMEPAGE = "http://www.eclipse.org/"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "EPL"
-
-DEPENDS = "ecj-initial virtual/java-native"
-
-PROVIDES = "virtual/javac-native"
-
-SRC_URI = "file://ecj.in"
-
-S = "${WORKDIR}"
-
-JAR = "ecj-bootstrap-${PV}.jar"
-
-inherit native
-
-do_compile() {
-  # Create the start script
-  echo "#!/bin/sh" > ecj-bootstrap
-  echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
-  echo "RUNTIME=java" >> ecj-bootstrap
-  cat ecj.in >> ecj-bootstrap
-}
-
-do_stage() {
-  install -d ${STAGING_BINDIR}
-  install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
-  install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
-}
diff --git a/packages/ecj/ecj-initial.bb b/packages/ecj/ecj-initial.bb
new file mode 100644 (file)
index 0000000..1064536
--- /dev/null
@@ -0,0 +1,31 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+
+# This variant runs on the initial (not Java5-compatible runtime).
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+LICENSE = "EPL"
+
+DEPENDS = "libecj-bootstrap"
+
+SRC_URI = "file://ecj.in"
+
+S = "${WORKDIR}"
+
+inherit native
+
+JAR = "ecj-bootstrap.jar"
+
+do_compile() {
+  # Create the start script
+  echo "#!/bin/sh" > ecj-initial
+  echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-initial
+  echo "RUNTIME=java-initial" >> ecj-initial
+  cat ecj.in >> ecj-initial
+}
+
+do_stage() {
+  install -d ${STAGING_BINDIR}
+  install -m 755 ${S}/ecj-initial ${STAGING_BINDIR}
+}
diff --git a/packages/ecj/ecj-initial_3.3.2.bb b/packages/ecj/ecj-initial_3.3.2.bb
deleted file mode 100644 (file)
index 60bbc55..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
-# and no less features.
-
-# This variant runs on the initial (not Java5-compatible runtime).
-
-DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
-HOMEPAGE = "http://www.eclipse.org/"
-LICENSE = "EPL"
-
-DEPENDS = "fastjar-native unzip-native jikes-initial virtual/java-initial"
-
-SRC_URI = "\
-    http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.3.2-200802211800/ecjsrc.zip \
-    file://ecj.in \
-    "
-
-S = "${WORKDIR}"
-
-inherit native
-
-JAR = "ecj-bootstrap-${PV}.jar"
-
-do_unpackpost() {
-  if [ ! -d source ]; then
-    mkdir source
-  fi
-
-  if [ ! -d build ]; then
-    mkdir build
-  fi
-
-  # Remove crap.
-  rm about.html build.xml
-  rm -rf META-INF
-
-  # Move source into separate subdir.
-  mv org source/
-
-  # Remove stuff unneeded for the bootstrap compiler.
-  rm -rf source/org/eclipse/jdt/internal/compiler/apt
-  rm -rf source/org/eclipse/jdt/internal/compiler/tool
-  rm -rf source/org/eclipse/jdt/internal/antadapter
-  rm source/org/eclipse/jdt/core/JDTCompilerAdapter.java
-
-  # Make a copy of the remaining source to get the embedded
-  # resources.
-  cp -r source/org build/
-
-  # Remove source code and other stuff.
-  find build -name '*.java' -exec rm -f {} \;
-  find build -name '*.html' -exec rm -f {} \;
-}
-
-addtask unpackpost after do_unpack before do_patch
-
-do_compile() {
-  find source -name '*.java' > sourcefiles
-  split -l 25 sourcefiles ecj-sources.
-
-  # Compiling in place is done because the sources contain
-  # property files which need to be available at runtime.
-  for list in `find . -name 'ecj-sources.*'`; do
-      echo "building files in $list ...";
-      echo jikes-initial -d build -source 1.4 -sourcepath source `cat $list`;
-      jikes-initial \
-                               -d build -source 1.4 -sourcepath source `cat $list`;
-  done
-
-  fastjar -c -C build . -f ${JAR}
-
-  # Create the start script
-  echo "#!/bin/sh" > ecj-initial
-  echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-initial
-  echo "RUNTIME=java-initial" >> ecj-initial
-  cat ecj.in >> ecj-initial
-}
-
-do_stage() {
-  install -d ${STAGING_DATADIR}/java
-  install -m 755 ${S}/${JAR} ${STAGING_DATADIR}/java
-
-  install -d ${STAGING_BINDIR}
-  install -m 755 ${S}/ecj-initial ${STAGING_BINDIR}
-}
diff --git a/packages/ecj/ecj-initial_3.3.bb b/packages/ecj/ecj-initial_3.3.bb
deleted file mode 100644 (file)
index 884d98f..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
-# and no less features.
-
-# This variant runs on the initial (not Java5-compatible runtime).
-
-DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
-HOMEPAGE = "http://www.eclipse.org/"
-LICENSE = "EPL"
-
-DEPENDS = "fastjar-native unzip-native jikes-initial virtual/java-initial"
-
-SRC_URI = "\
-    http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.3-200706251500/ecjsrc.zip \
-    file://ecj.in \
-    "
-
-S = "${WORKDIR}"
-
-inherit native
-
-JAR = "ecj-bootstrap-${PV}.jar"
-
-do_unpackpost() {
-  if [ ! -d source ]; then
-    mkdir source
-  fi
-
-  if [ ! -d build ]; then
-    mkdir build
-  fi
-
-  # Remove crap.
-  rm about.html build.xml
-  rm -rf META-INF
-
-  # Move source into separate subdir.
-  mv org source/
-
-  # Remove stuff unneeded for the bootstrap compiler.
-  rm -rf source/org/eclipse/jdt/internal/compiler/apt
-  rm -rf source/org/eclipse/jdt/internal/compiler/tool
-  rm -rf source/org/eclipse/jdt/internal/antadapter
-  rm source/org/eclipse/jdt/core/JDTCompilerAdapter.java
-
-  # Make a copy of the remaining source to get the embedded
-  # resources.
-  cp -r source/org build/
-
-  # Remove source code and other stuff.
-  find build -name '*.java' -exec rm -f {} \;
-  find build -name '*.html' -exec rm -f {} \;
-}
-
-addtask unpackpost after do_unpack before do_patch
-
-do_compile() {
-  find source -name '*.java' > sourcefiles
-  split -l 25 sourcefiles ecj-sources.
-
-  # Compiling in place is done because the sources contain
-  # property files which need to be available at runtime.
-  for list in `find . -name 'ecj-sources.*'`; do
-      echo "building files in $list ...";
-      echo jikes-initial -d build -source 1.4 -sourcepath source `cat $list`;
-      jikes-initial \
-                               -d build -source 1.4 -sourcepath source `cat $list`;
-  done
-
-  fastjar -c -C build . -f ${JAR}
-
-  # Create the start script
-  echo "#!/bin/sh" > ecj-initial
-  echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-initial
-  echo "RUNTIME=java-initial" >> ecj-initial
-  cat ecj.in >> ecj-initial
-}
-
-do_stage() {
-  install -d ${STAGING_DATADIR}/java
-  install -m 755 ${S}/${JAR} ${STAGING_DATADIR}/java
-
-  install -d ${STAGING_BINDIR}
-  install -m 755 ${S}/ecj-initial ${STAGING_BINDIR}
-}
diff --git a/packages/ecj/ecj-initial_3.4.bb b/packages/ecj/ecj-initial_3.4.bb
deleted file mode 100644 (file)
index dcc0813..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
-# and no less features.
-
-# This variant runs on the initial (not Java5-compatible runtime).
-
-DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
-HOMEPAGE = "http://www.eclipse.org/"
-LICENSE = "EPL"
-
-DEPENDS = "fastjar-native unzip-native jikes-initial virtual/java-initial"
-
-SRC_URI = "\
-    http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.4-200806172000/ecjsrc.zip \
-    file://ecj.in \
-    "
-
-S = "${WORKDIR}"
-
-inherit native
-
-JAR = "ecj-bootstrap-${PV}.jar"
-
-do_unpackpost() {
-  if [ ! -d source ]; then
-    mkdir source
-  fi
-
-  if [ ! -d build ]; then
-    mkdir build
-  fi
-
-  # Remove crap.
-  rm about.html build.xml
-  rm -rf META-INF
-
-  # Move source into separate subdir.
-  mv org source/
-
-  # Remove stuff unneeded for the bootstrap compiler.
-  rm -rf source/org/eclipse/jdt/internal/compiler/apt
-  rm -rf source/org/eclipse/jdt/internal/compiler/tool
-  rm -rf source/org/eclipse/jdt/internal/antadapter
-  rm source/org/eclipse/jdt/core/JDTCompilerAdapter.java
-
-  # Make a copy of the remaining source to get the embedded
-  # resources.
-  cp -r source/org build/
-
-  # Remove source code and other stuff.
-  find build -name '*.java' -exec rm -f {} \;
-  find build -name '*.html' -exec rm -f {} \;
-}
-
-addtask unpackpost after do_unpack before do_patch
-
-do_compile() {
-  find source -name '*.java' > sourcefiles
-  split -l 25 sourcefiles ecj-sources.
-
-  # Compiling in place is done because the sources contain
-  # property files which need to be available at runtime.
-  for list in `find . -name 'ecj-sources.*'`; do
-      echo "building files in $list ...";
-      echo jikes-initial -d build -source 1.4 -sourcepath source `cat $list`;
-      jikes-initial \
-                               -d build -source 1.4 -sourcepath source `cat $list`;
-  done
-
-  fastjar -c -C build . -f ${JAR}
-
-  # Create the start script
-  echo "#!/bin/sh" > ecj-initial
-  echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-initial
-  echo "RUNTIME=java-initial" >> ecj-initial
-  cat ecj.in >> ecj-initial
-}
-
-do_stage() {
-  install -d ${STAGING_DATADIR}/java
-  install -m 755 ${S}/${JAR} ${STAGING_DATADIR}/java
-
-  install -d ${STAGING_BINDIR}
-  install -m 755 ${S}/ecj-initial ${STAGING_BINDIR}
-}
diff --git a/packages/ecj/libecj-bootstrap.inc b/packages/ecj/libecj-bootstrap.inc
new file mode 100644 (file)
index 0000000..c24c1af
--- /dev/null
@@ -0,0 +1,67 @@
+# This package compiles and stages only the Jar.
+
+DESCRIPTION = "JDT Core Batch Compiler - Jar only"
+HOMEPAGE = "http://www.eclipse.org/"
+LICENSE = "EPL"
+
+DEPENDS = "fastjar-native jikes-initial virtual/java-initial"
+
+inherit native java
+
+S = "${WORKDIR}"
+
+JAR = "ecj-bootstrap-${PV}.jar"
+
+do_unpackpost() {
+  if [ ! -d source ]; then
+    mkdir source
+  fi
+
+  if [ ! -d build ]; then
+    mkdir build
+  fi
+
+  # Remove crap.
+  rm about.html build.xml
+  rm -rf META-INF
+
+  # Move source into separate subdir.
+  mv org source/
+
+  # Remove stuff unneeded for the bootstrap compiler.
+  rm -rf source/org/eclipse/jdt/internal/compiler/apt
+  rm -rf source/org/eclipse/jdt/internal/compiler/tool
+  rm -rf source/org/eclipse/jdt/internal/antadapter
+  rm source/org/eclipse/jdt/core/JDTCompilerAdapter.java
+
+  # Make a copy of the remaining source to get the embedded
+  # resources.
+  cp -r source/org build/
+
+  # Remove source code and other stuff.
+  find build -name '*.java' -exec rm -f {} \;
+  find build -name '*.html' -exec rm -f {} \;
+}
+
+addtask unpackpost after do_unpack before do_patch
+
+do_compile() {
+  find source -name '*.java' > sourcefiles
+  split -l 25 sourcefiles ecj-sources.
+
+  # Compiling in place is done because the sources contain
+  # property files which need to be available at runtime.
+  for list in `find . -name 'ecj-sources.*'`; do
+      echo "building files in $list ...";
+      echo jikes-initial -d build -source 1.4 -sourcepath source `cat $list`;
+      jikes-initial \
+                               -d build -source 1.4 -sourcepath source `cat $list`;
+  done
+
+  fastjar -c -C build . -f ${JAR}
+}
+
+do_stage() {
+  oe_jarinstall -s ${JAR} ecj-bootstrap.jar
+}
+
diff --git a/packages/ecj/libecj-bootstrap_3.3.2.bb b/packages/ecj/libecj-bootstrap_3.3.2.bb
new file mode 100644 (file)
index 0000000..dab6ed7
--- /dev/null
@@ -0,0 +1,6 @@
+require libecj-bootstrap.inc
+
+SRC_URI = "\
+       http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.3.2-200802211800/ecjsrc.zip \
+  "
+
diff --git a/packages/ecj/libecj-bootstrap_3.3.bb b/packages/ecj/libecj-bootstrap_3.3.bb
new file mode 100644 (file)
index 0000000..b65e99c
--- /dev/null
@@ -0,0 +1,6 @@
+require libecj-bootstrap.inc
+
+SRC_URI = "\
+       http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.3-200706251500/ecjsrc.zip \
+  "
+
diff --git a/packages/ecj/libecj-bootstrap_3.4.bb b/packages/ecj/libecj-bootstrap_3.4.bb
new file mode 100644 (file)
index 0000000..c321a8f
--- /dev/null
@@ -0,0 +1,6 @@
+require libecj-bootstrap.inc
+
+SRC_URI = "\
+       http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.4-200806172000/ecjsrc.zip \
+  "
+
diff --git a/packages/obsolete/wesnoth_svn.bb b/packages/obsolete/wesnoth_svn.bb
new file mode 100644 (file)
index 0000000..430abe7
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "fantasy turn-based strategy game"
+PV = "0.01+svnr${SRCREV}"
+PR = "r1"
+SECTION = "games"
+LICENSE = "GPL"
+DEPENDS += "libsdl-image libsdl-mixer libsdl-net"
+SRC_URI = "svn://svn.gna.org/svn/wesnoth;module=trunk;proto=http"
+
+EXTRA_OECONF += " --enable-tinygui --disable-python --enable-lite --enable-lowmem"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+addtask autogen after do_patch before do_configure
+
+do_autogen() {
+        cd ${WORKDIR}/trunk/ && ./autogen.sh --host=armv4t-angstrom-linux-gnueabi
+}
diff --git a/packages/wesnoth/wesnoth_1.4.5.bb b/packages/wesnoth/wesnoth_1.4.5.bb
new file mode 100644 (file)
index 0000000..5b5484d
--- /dev/null
@@ -0,0 +1,139 @@
+DESCRIPTION = "The Battle for Wesnoth is a turn-based strategy game with a fantasy theme."
+HOMEPAGE = "http://www.wesnoth.org/"
+SECTION = "games"
+LICENSE = "GPL"
+
+DEPENDS = "freetype libsdl-image libsdl-mixer libsdl-net libsdl-ttf zlib boost imagemagick-native"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wesnoth/${PN}-${PV}.tar.bz2"
+
+EXTRA_OECONF = "\
+       --enable-tinygui \
+       --enable-editor \
+       --enable-lite \
+       --enable-lowmem \
+       --with-boost=${STAGING_INCDIR} \
+       --with-freetype=${STAGING_INCDIR} \
+       --without-fribidi \
+       --disable-python \
+"
+
+inherit autotools
+
+PACKAGES = "wesnoth-editor wesnoth-doc wesnoth-music \
+       wesnoth-aoi wesnoth-did wesnoth-ei wesnoth-httt wesnoth-l \
+       wesnoth-nr wesnoth-sof wesnoth-sotbe wesnoth-thot wesnoth-trow \
+       wesnoth-tsg wesnoth-tb wesnoth-utbs \
+       wesnoth-data \
+       wesnoth-all \
+       wesnoth wesnoth-dbg \
+       "
+
+do_install_append() {
+       if [ -f ${D}${datadir}/wesnoth/icons ]; then
+               rm -rf ${D}${datadir}/wesnoth/icons
+       fi
+}
+
+RDEPENDS_wesnoth = "wesnoth-data"
+
+RDEPENDS_wesnoth-editor = "wesnoth-data"
+
+RDEPENDS_wesnoth-all = "wesnoth wesnoth-music \
+       wesnoth-aoi wesnoth-did wesnoth-ei wesnoth-httt wesnoth-l \
+       wesnoth-nr wesnoth-sof wesnoth-sotbe wesnoth-thot wesnoth-trow \
+       wesnoth-tsg wesnoth-tb wesnoth-utbs"
+
+# Installing wesnoth-all should pull everything in (like in Debian).
+ALLOW_EMPTY_${PN}-all = "1"
+
+FILES_wesnoth-music = "\
+       ${datadir}/wesnoth/data/core/music \
+"
+
+# Picks up remaining translations and data. Must be packaged after
+# wesnoth-music and all campaigns.
+FILES_wesnoth-data = "\
+  ${datadir}/wesnoth/sounds \
+  ${datadir}/wesnoth/images \
+  ${datadir}/wesnoth/data \
+  ${datadir}/wesnoth/fonts \
+  ${datadir}/wesnoth/translations \
+"
+
+FILES_${PN} = "\
+  ${bindir}/wesnoth \
+       ${datadir}/icons \
+       ${datadir}/applications \
+"
+
+FILES_wesnoth-editor = "\
+       ${bindir}/wesnoth_editor \
+"
+
+FILES_wesnoth-aoi = "\
+       ${datadir}/wesnoth/data/campaigns/An_Orcish_Incursion \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-aoi.mo \
+"
+
+FILES_wesnoth-did = "\
+       ${datadir}/wesnoth/data/campaigns/Descent_Into_Darkness \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-did.mo \
+"
+
+FILES_wesnoth-ei = "\
+       ${datadir}/wesnoth/data/campaigns/Eastern_Invasion \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-ei.mo \
+"
+
+FILES_wesnoth-httt = "\
+       ${datadir}/wesnoth/data/campaigns/Heir_To_The_Throne \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-httt.mo \
+"
+
+FILES_wesnoth-l = "\
+       ${datadir}/wesnoth/data/campaigns/Liberty \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-l.mo \
+"
+
+FILES_wesnoth-nr = "\
+       ${datadir}/wesnoth/data/campaigns/Northern_Rebirth \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-nr.mo \
+"
+
+FILES_wesnoth-sof = "\
+       ${datadir}/wesnoth/data/campaigns/Sceptre_Of_Fire \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-sof.mo \
+"
+
+FILES_wesnoth-sotbe = "\
+       ${datadir}/wesnoth/data/campaigns/Son_Of_The_Black_Eye \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-sotbe.mo \
+"
+
+FILES_wesnoth-thot = "\
+       ${datadir}/wesnoth/data/campaigns/The_Hammer_Of_Thursagan \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-thot.mo \
+"
+
+FILES_wesnoth-trow = "\
+       ${datadir}/wesnoth/data/campaigns/The_Rise_Of_Wesnoth \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-trow.mo \
+"
+
+FILES_wesnoth-tsg = "\
+       ${datadir}/wesnoth/data/campaigns/The_South_Guard \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-tsg.mo \
+"
+
+FILES_wesnoth-tb = "\
+       ${datadir}/wesnoth/data/campaigns/Two_Brothers \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-tb.mo \
+"
+
+FILES_wesnoth-utbs = "\
+       ${datadir}/wesnoth/data/campaigns/Under_the_Burning_Suns \
+       ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-utbs.mo \
+"
diff --git a/packages/wesnoth/wesnoth_svn.bb b/packages/wesnoth/wesnoth_svn.bb
deleted file mode 100644 (file)
index 430abe7..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "fantasy turn-based strategy game"
-PV = "0.01+svnr${SRCREV}"
-PR = "r1"
-SECTION = "games"
-LICENSE = "GPL"
-DEPENDS += "libsdl-image libsdl-mixer libsdl-net"
-SRC_URI = "svn://svn.gna.org/svn/wesnoth;module=trunk;proto=http"
-
-EXTRA_OECONF += " --enable-tinygui --disable-python --enable-lite --enable-lowmem"
-
-S = "${WORKDIR}/trunk"
-
-inherit autotools
-
-addtask autogen after do_patch before do_configure
-
-do_autogen() {
-        cd ${WORKDIR}/trunk/ && ./autogen.sh --host=armv4t-angstrom-linux-gnueabi
-}