xserver-common_1.22.bb : update with two xorg patches, one generic to
authorGraeme Gregory <dp@xora.org.uk>
Wed, 12 Nov 2008 09:23:52 +0000 (09:23 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Wed, 12 Nov 2008 15:23:07 +0000 (15:23 +0000)
stop -mouse argument being passed.
The other om-gta* specific to stop -screen argument being passed for
these machines.

packages/xserver-common/files/gta-xorg-fixes.patch [new file with mode: 0644]
packages/xserver-common/files/xorg-fixes.patch [new file with mode: 0644]
packages/xserver-common/xserver-common_1.22.bb

diff --git a/packages/xserver-common/files/gta-xorg-fixes.patch b/packages/xserver-common/files/gta-xorg-fixes.patch
new file mode 100644 (file)
index 0000000..adf6798
--- /dev/null
@@ -0,0 +1,29 @@
+Index: xserver-common-1.22/X11/Xserver
+===================================================================
+--- xserver-common-1.22.orig/X11/Xserver       2008-11-12 09:16:50.000000000 +0000
++++ xserver-common-1.22/X11/Xserver    2008-11-12 09:18:53.000000000 +0000
+@@ -109,7 +109,11 @@
+       "Nokia RX-44")
+               ARGS="$ARGS -dpi 225 -screen ${SCREEN_SIZE} -mouse tslib" ;;
+       "GTA01" )
+-              ARGS="$ARGS -dpi 285 -screen 480x640" ;;
++              ARGS="$ARGS -dpi 285"
++              if [ "$XSERVER" != "Xorg" ] ; then
++                      ARGS="$ARGS -screen 480x640"
++              fi
++              ;;
+       "Motorola Ezx Platform")
+               ARGS="$ARGS -dpi 170 -screen 240x320" ;;
+       "ARM-IntegratorCP" | "ARM-Versatile PB")
+@@ -118,7 +122,10 @@
+               modprobe mbxfb
+               ARGS="$ARGS -fb /dev/fb1" ;;
+       "GTA02")
+-              ARGS="$ARGS -dpi 285 -screen ${SCREEN_SIZE}" 
++              ARGS="$ARGS -dpi 285"
++              if [ "$XSERVER" != "Xorg" ] ; then
++                      ARGS="$ARGS -screen ${SCREEN_SIZE}"
++              fi
+               ;;
+       "Boundary Devices Neon board")
+               ARGS="$ARGS -dpi 100 -screen ${SCREEN_SIZE} -mouse tslib"
diff --git a/packages/xserver-common/files/xorg-fixes.patch b/packages/xserver-common/files/xorg-fixes.patch
new file mode 100644 (file)
index 0000000..b2fd544
--- /dev/null
@@ -0,0 +1,25 @@
+Index: xserver-common-1.22/X11/Xserver
+===================================================================
+--- xserver-common-1.22.orig/X11/Xserver       2008-11-12 09:14:55.000000000 +0000
++++ xserver-common-1.22/X11/Xserver    2008-11-12 09:16:22.000000000 +0000
+@@ -48,6 +48,7 @@
+ ARGS="-br -pn $INPUT_EXTRA_ARGS"
++if [ "$XSERVER" != "Xorg" ] ; then
+ # use ucb 1x00 touchscreen if present
+ if [ -z "$TSLIB_TSDEVICE" ] && [ -e /dev/touchscreen/ucb1x00 ]; then
+   ARGS="$ARGS -mouse /dev/touchscreen/ucb1x00"
+@@ -58,10 +59,11 @@
+ if [ -e "$TSLIB_TSDEVICE" ] ; then
+   ARGS="$ARGS -mouse tslib"
+ else
+-  if  [ -e /dev/input/mice ] && [ "$XSERVER" != "Xorg" ] ; then
++  if  [ -e /dev/input/mice ] ; then
+     ARGS="$ARGS -mouse mouse"
+   fi
+ fi
++fi
+ # start off server in conventional location.
+ case `module_id` in
index 6dcbc68..05b15ae 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts and support files"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
-PR = "r7"
+PR = "r8"
 
 PACKAGE_ARCH = "all"
 
@@ -11,6 +11,8 @@ inherit gpe
 
 SRC_URI_append = " file://setDPI.sh "
 SRC_URI_append_angstrom = " file://kdrive-1.4-fixes.patch;patch=1 \
+                            file://xorg-fixes.patch;patch=1 \
+                           file://gta-xorg-fixes.patch;patch=1 \
                             file://default.xmodmap "
 
 do_install_append() {