apr-util: fix most libtool problems
authorKoen Kooi <koen@openembedded.org>
Fri, 6 Feb 2009 18:35:13 +0000 (19:35 +0100)
committerKoen Kooi <koen@openembedded.org>
Fri, 6 Feb 2009 18:35:13 +0000 (19:35 +0100)
packages/apr/apr-util/configure_fixes.patch
packages/apr/apr-util_1.2.12.bb

index 16f88b3..7c6fa6a 100644 (file)
@@ -1,7 +1,5 @@
-Index: apr-util-1.2.12/configure.in
-===================================================================
---- apr-util-1.2.12.orig/configure.in  2008-03-08 19:15:00.000000000 +0000
-+++ apr-util-1.2.12/configure.in       2008-03-08 19:15:13.000000000 +0000
+--- /tmp/configure.in  2009-02-06 16:34:14.000000000 +0100
++++ apr-util-1.2.12/configure.in       2009-02-06 16:34:38.000000000 +0100
 @@ -8,13 +8,13 @@
  AC_CONFIG_HEADER(include/private/apu_config.h)
  AC_CONFIG_AUX_DIR(build)
@@ -23,3 +21,17 @@ Index: apr-util-1.2.12/configure.in
  
  dnl Generate ./config.nice for reproducing runs of configure
  dnl 
+@@ -45,10 +45,10 @@
+ # against installed versions of libapr instead of those just
+ # built.
+ case $host in
+-*-apple-darwin*) LT_NO_INSTALL="" ;;
+-*) LT_NO_INSTALL="-no-install" ;;
++*-apple-darwin*) LV_NO_INSTALL="" ;;
++*) LV_NO_INSTALL="-no-install" ;;
+ esac
+-AC_SUBST(LT_NO_INSTALL)
++AC_SUBST(LV_NO_INSTALL)
+ dnl
+ dnl compute the top directory of the build
index 64f6bcb..6613ab9 100644 (file)
@@ -3,7 +3,9 @@ SECTION = "libs"
 DEPENDS = "apr expat gdbm"
 LICENSE = "Apache License, Version 2.0"
 
-PR = "r2"
+PR = "r3"
+
+inherit autotools lib_package binconfig
 
 # apache mirrors?
 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
@@ -16,12 +18,16 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
                --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
 
 
-inherit autotools lib_package binconfig
-
 OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+EXTRA_OEMAKE = " LIBTOOL=\"${S}/${TARGET_PREFIX}libtool\" "
+
+export LIBTOOL="${S}/${TARGET_PREFIX}libtool"
 
 do_configure_prepend() {
+       cp ${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool ${S}/
        cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+       echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
+       libtoolize --force
 }
 
 do_stage() {