krb5: Force cp to work due to an permissions issue
authorTim 'timtim' Ellis <tim.ellis@foonas.org>
Sun, 17 May 2009 20:50:09 +0000 (21:50 +0100)
committerTim 'timtim' Ellis <tim.ellis@foonas.org>
Sun, 17 May 2009 20:50:09 +0000 (21:50 +0100)
recipes/krb/files/copyperms.patch [new file with mode: 0644]
recipes/krb/krb5_1.6.3.bb

diff --git a/recipes/krb/files/copyperms.patch b/recipes/krb/files/copyperms.patch
new file mode 100644 (file)
index 0000000..b0abb72
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN src.old/config/pre.in src/config/pre.in
+--- src.old/config/pre.in      2006-10-15 19:19:28.000000000 +0100
++++ src/config/pre.in  2009-05-17 21:28:54.000000000 +0100
+@@ -258,7 +258,7 @@
+ transform = @program_transform_name@
+ RM = rm -f
+-CP  = cp
++CP  = cp -f
+ MV = mv -f
+ CHMOD=chmod
+ RANLIB = @RANLIB@
index 5fc75b4..a1694b2 100644 (file)
@@ -1,14 +1,15 @@
 DESCRIPTION = "A network authentication protocol"
 HOMEPAGE = "http://web.mit.edu/Kerberos/"
 SECTION = "console/network"
-PR = "r5"
+PR = "r6"
 LICENSE = "MIT"
 DEPENDS = "perl-native ncurses e2fsprogs-libs"
 
 inherit autotools binconfig
 
 SRC_URI = "http://web.mit.edu/kerberos/dist/krb5/1.6/krb5-1.6.3-signed.tar \
-           file://fix-uclibc-ruserpass-collision.patch"
+           file://fix-uclibc-ruserpass-collision.patch \
+           file://copyperms.patch"
 S = "${WORKDIR}/${PN}-${PV}/src/"
 
 # Will clean this up...
@@ -23,6 +24,7 @@ FILES_${PN}-doc += /usr/share/examples
 krb5_do_unpack() {
        tar xzf ${WORKDIR}/krb5-1.6.3.tar.gz -C ${WORKDIR}/
        patch -d ${S} -p1 < ${WORKDIR}/fix-uclibc-ruserpass-collision.patch
+       patch -d ${S} -p1 < ${WORKDIR}/copyperms.patch
 }
 
 python do_unpack() {