fix e2 bb and make fuse as modules
authorschon <schon@dev03-server>
Fri, 31 Aug 2012 10:07:16 +0000 (19:07 +0900)
committerschon <schon@dev03-server>
Fri, 31 Aug 2012 10:07:16 +0000 (19:07 +0900)
recipes/enigma2/enigma2.bb
recipes/linux/linux-vuduo2-3.1.1/vuduo2_defconfig
recipes/tasks/task-vuplus-enigma2.bb

index bdd93d2..df21681 100644 (file)
@@ -3,8 +3,6 @@ MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
        dreambox-dvbincludes freetype libdvbsi++ python swig-native \
        libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
-       gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi \
-       directfb mpfr gmp tslib opera-hbbtv"
        gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data \
        hostap-daemon bridge-utils djmount minidlna mpfr gmp tslib opera-hbbtv util-linux-ng ntfs-3g dosfstools "
 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
@@ -129,7 +127,6 @@ SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};t
           file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
-          file://enigma2-hbbtv_20120610.patch;patch=1;pnum=1 \
            file://MyriadPro-Regular.otf \
            file://MyriadPro-Semibold.otf \
            file://MyriadPro-SemiboldIt.otf \
index a3c024e..6b76af3 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Automatically generated make config: don't edit
 # Linux/mips 2.6.37-2.8 Kernel Configuration
-# Thu Jun  7 19:50:36 2012
+# Fri Aug 31 17:36:37 2012
 #
 CONFIG_MIPS=y
 
@@ -95,14 +95,12 @@ CONFIG_BCMGENET=y
 # BCMGENET options
 #
 # CONFIG_BCMGENET_0_GPHY is not set
-# CONFIG_BCMGENET_1_GPHY is not set
 # CONFIG_BCMGENET_RX_DESC_THROTTLE is not set
 CONFIG_BCMGENET_NAPI=y
 # CONFIG_BCMGENET_RX_CSUM is not set
 # CONFIG_BCMGENET_TX_CSUM is not set
 # CONFIG_BCMGENET_DUMP_DATA is not set
 # CONFIG_BCMGENET_DUMP_TRACE is not set
-# CONFIG_BRCM_MOCA is not set
 CONFIG_BRCM_USB=y
 # CONFIG_BRCM_OVERRIDE_USB is not set
 CONFIG_BRCM_SDIO=y
@@ -131,11 +129,7 @@ CONFIG_BRCM_GENET_V3=y
 CONFIG_BRCM_GENET_VERSION=3
 CONFIG_BRCM_HAS_GENET=y
 CONFIG_BRCM_HAS_GENET_0=y
-# CONFIG_BRCM_HAS_GENET_1=y
-# CONFIG_BRCM_HAS_MOCA=y
-# CONFIG_BRCM_HAS_MOCA_20=y
-# CONFIG_BRCM_MOCA_VERS=0x2000
-# CONFIG_BRCM_MOCA_ON_GENET_1=y
+CONFIG_BRCM_MOCA_ON_GENET_1=y
 CONFIG_BRCM_HAS_SATA=y
 CONFIG_BRCM_HAS_SATA3=y
 # CONFIG_BRCM_SATA_75MHZ_PLL is not set
@@ -1908,7 +1902,7 @@ CONFIG_INOTIFY_USER=y
 # CONFIG_QUOTA is not set
 # CONFIG_QUOTACTL is not set
 # CONFIG_AUTOFS4_FS is not set
-CONFIG_FUSE_FS=y
+CONFIG_FUSE_FS=m
 # CONFIG_CUSE is not set
 
 #
index 734d6bf..ee41dfd 100644 (file)
@@ -69,12 +69,14 @@ RDEPENDS_task-vuplus-enigma2_append_vuduo2 = "\
   enigma2-plugin-systemplugins-remotecontrolcode \
   enigma2-plugin-systemplugins-hdmicec \
   enigma2-plugin-extensions-openwebif \
+  enigma2-plugin-extensions-hbbtv \
 "
 
 RDEPENDS_task-vuplus-enigma2_append_vusolo2 = "\
   enigma2-plugin-extensions-openwebif \
   enigma2-plugin-systemplugins-remotecontrolcode \
   enigma2-plugin-systemplugins-hdmicec \
+  enigma2-plugin-extensions-hbbtv \
 "
 
 RDEPENDS_task-vuplus-enigma2_append_vuuno = "\