Merge bk://openembedded@openembedded.bkbits.net/packages
authorHolger Freyther <zecke@selfish.org>
Wed, 13 Oct 2004 20:47:38 +0000 (20:47 +0000)
committerHolger Freyther <zecke@selfish.org>
Wed, 13 Oct 2004 20:47:38 +0000 (20:47 +0000)
into handhelds.org:/home/ich/programming/oe/oe-packages-exported

2004/10/13 22:47:21+02:00 handhelds.org!zecke
Kernel OE-Class:
-Remove the ARCH="mips" assignment in favor of a proper test with the substituted varible

BKrev: 416d946aOAPNaIYqioII7ummJJMNSw

classes/kernel.oeclass

index b8e199f..53482f3 100644 (file)
@@ -69,7 +69,7 @@ kernel_do_stage() {
        [ -e Rules.make ] && install -m 0644 Rules.make ${STAGING_KERNEL_DIR}/
        [ -e Makefile ] && install -m 0644 Makefile ${STAGING_KERNEL_DIR}/
        # Makefile includes arch/mips/Makefile on mips
-       if [ ARCH="mips" ]; then
+       if [ "${ARCH}" = "mips" ]; then
                install -d ${STAGING_KERNEL_DIR}/arch/mips
                install -m 0644 arch/mips/Makefile ${STAGING_KERNEL_DIR}/arch/mips
        fi