ixp4xx-kernel, slugos: moved some modules into the kernel (those that are the lowest...
authorRod Whitby <rod@whitby.id.au>
Thu, 30 Nov 2006 03:23:09 +0000 (03:23 +0000)
committerRod Whitby <rod@whitby.id.au>
Thu, 30 Nov 2006 03:23:09 +0000 (03:23 +0000)
conf/distro/debianslug.conf
conf/distro/openslug.conf
packages/images/slugos-image.bb
packages/linux/ixp4xx-kernel_2.6.19.bb
packages/slugos-init/files/modulefunctions
packages/slugos-init/slugos-init_0.10.bb

index 0b333e2..0bcdac1 100644 (file)
@@ -86,26 +86,15 @@ kernel-module-nls-cp437 \
 kernel-module-nls-utf8 \
 "
 
-# Add module to create i2c chardev
+# Add daemon required for HW RNG support
 DEBIANSLUG_STANDARD_RDEPENDS += "\
-kernel-module-i2c-dev \
-"
-
-# Add module & daemon required for HW RNG support
-DEBIANSLUG_STANDARD_RDEPENDS += "\
-kernel-module-ixp4xx-rng \
 rng-tools \
 "
 
 # Add modules required for usb support
 DEBIANSLUG_STANDARD_RDEPENDS += "\
-kernel-module-usbcore \
 kernel-module-ohci-hcd \
-kernel-module-ehci-hcd \
 kernel-module-uhci-hcd \
-kernel-module-scsi-mod \
-kernel-module-sd-mod \
-kernel-module-usb-storage \
 "
 
 # Add modules required for IDE support
index 55a6942..dec16d8 100644 (file)
@@ -86,26 +86,15 @@ kernel-module-nls-cp437 \
 kernel-module-nls-utf8 \
 "
 
-# Add module to create i2c chardev
+# Add daemon required for HW RNG support
 OPENSLUG_STANDARD_RDEPENDS += "\
-kernel-module-i2c-dev \
-"
-
-# Add module & daemon required for HW RNG support
-OPENSLUG_STANDARD_RDEPENDS += "\
-kernel-module-ixp4xx-rng \
 rng-tools \
 "
 
 # Add modules required for usb support
 OPENSLUG_STANDARD_RDEPENDS += "\
-kernel-module-usbcore \
 kernel-module-ohci-hcd \
-kernel-module-ehci-hcd \
 kernel-module-uhci-hcd \
-kernel-module-scsi-mod \
-kernel-module-sd-mod \
-kernel-module-usb-storage \
 "
 
 # Add modules required for IDE support
index 388a975..714945f 100644 (file)
@@ -69,11 +69,10 @@ EXTRA_IMAGEDEPENDS += "${IMAGE_TOOLS}"
 # known to be sufficient for boot.)
 SLUGOS_SUPPORT ?= "diffutils cpio findutils udev"
 
-# kernel-module-af-packet must be in the image for DHCP to work
 # kernel-module-netconsole is here because it is small and is
 # highly useful on minimal systems (which really don't have anywhere
 # other than the network to output error messages!)
-SLUGOS_KERNEL ?= "kernel-module-af-packet kernel-module-netconsole"
+SLUGOS_KERNEL ?= "kernel-module-netconsole"
 
 RDEPENDS = "kernel ixp4xx-npe \
        base-files base-passwd netbase \
index d7dbf10..999e09f 100644 (file)
@@ -6,7 +6,7 @@
 # http://trac.nslu2-linux.org/kernel/
 #
 # The revision that is pulled from SVN is specified below
-IXP4XX_KERNEL_SVN_REV = "595"
+IXP4XX_KERNEL_SVN_REV = "596"
 #
 # The directory containing the patches to be applied is
 # specified below
index 1073dae..8ab5e01 100644 (file)
@@ -4,35 +4,25 @@
 . /etc/default/functions
 
 loaddiskmods(){
-       modprobe scsi_mod
-       modprobe sd_mod 
-       modprobe usbcore 
        case "$(machine)" in
            nslu2)                     
-               modprobe ehci-hcd
                modprobe ohci-hcd
                ;;
             nas100d)
                 modprobe pata-artop
-                modprobe ehci-hcd
                 modprobe uhci-hcd
                 ;;
             dsmg600)
                 modprobe pata-artop
-                modprobe ehci-hcd
                 modprobe uhci-hcd
                 ;;
 
        esac
-       modprobe usb-storage
 }
 
 loadnetmods(){
-       modprobe af_packet
 }
 
 loadmiscmods(){
-       modprobe ixp4xx_rng
-       modprobe i2c_dev
 }
 
index 54c1993..d69b32c 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "required"
 LICENSE = "GPL"
 DEPENDS = "base-files devio"
 RDEPENDS = "busybox devio"
-PR = "r74"
+PR = "r75"
 
 SRC_URI = "file://boot/flash \
           file://boot/disk \