fixed fancontrol2 dependency(webinterface -> openwebif).
authorkos <kos@dev3>
Wed, 13 Feb 2013 09:06:07 +0000 (18:06 +0900)
committerkos <kos@dev3>
Wed, 13 Feb 2013 09:59:30 +0000 (18:59 +0900)
recipes/enigma2/enigma2-plugins.bb
recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_fancontrol2.patch [new file with mode: 0644]

index 0c0fbb7..e537295 100755 (executable)
@@ -10,7 +10,7 @@ SRCDATE="20110215"
 BRANCH="master"
 PV = "experimental-git${SRCDATE}"
 
-PR = "r7"
+PR = "r8"
 SRC_URI="git://code.vuplus.com/git/dvbapp-plugin.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
 
 EXTRA_OECONF = " \
@@ -26,7 +26,7 @@ SRC_URI_append_vuplus = " \
           file://enigma2_plugins_webinterface_tpm.patch;patch=1;pnum=1 \
           file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
           file://enigma2_plugins_autoresolution_fix.patch;patch=1;pnum=1 \
-          file://enigma2_plugins_dependency.patch;patch=1;pnum=1 \
+          file://enigma2_plugins_fancontrol2.patch;patch=1;pnum=1 \
            file://dreamboxweb.png \
            file://dreamboxwebtv.png \
            file://favicon.ico"
diff --git a/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_fancontrol2.patch b/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_fancontrol2.patch
new file mode 100644 (file)
index 0000000..f5daea0
--- /dev/null
@@ -0,0 +1,26 @@
+diff --git a/fancontrol2/CONTROL/control b/fancontrol2/CONTROL/control
+index a2cee72..d8dec7f 100644
+--- a/fancontrol2/CONTROL/control
++++ b/fancontrol2/CONTROL/control
+@@ -3,4 +3,4 @@ Version: 2.5
+ Description: Temperature dependent fan control
+ Maintainer: IHAD joergm6 <joergm6@www.i-have-a-dreambox.com>
+ Homepage: http://www.i-have-a-dreambox.com
+-Depends: enigma2 (>> 2.6)
++Depends: enigma2 (>> 2.6), enigma2-plugin-extensions-openwebif
+diff --git a/fancontrol2/src/plugin.py b/fancontrol2/src/plugin.py
+index 847cd6c..671bfa3 100644
+--- a/fancontrol2/src/plugin.py
++++ b/fancontrol2/src/plugin.py
+@@ -1045,9 +1045,8 @@ def Plugins(**kwargs):
+       list = [
+       PluginDescriptor(name="Fan Control", 
+       description="Fan Control 2", 
+-      where = [PluginDescriptor.WHERE_SESSIONSTART, 
+-      PluginDescriptor.WHERE_AUTOSTART], 
+-      fnc = autostart),
++      where = PluginDescriptor.WHERE_NETWORKCONFIG_READ,
++      fnc = autostart, weight=10),
+       PluginDescriptor(name="Fan Control", 
+       description="Fan Control 2", 
+       where = PluginDescriptor.WHERE_PLUGINMENU,