util-linux-ng: Fixed dangling symlinks.
authorLeon Woestenberg <leon@sidebranch.com>
Tue, 14 Apr 2009 20:32:14 +0000 (22:32 +0200)
committerLeon Woestenberg <leon@sidebranch.com>
Tue, 14 Apr 2009 21:01:21 +0000 (23:01 +0200)
recipes/util-linux-ng/util-linux-ng.inc
recipes/util-linux-ng/util-linux-ng_2.13.1.bb
recipes/util-linux-ng/util-linux-ng_2.14.bb

index 443adf2..dda9792 100644 (file)
@@ -5,14 +5,11 @@ DEPENDS = "udev zlib ncurses e2fsprogs-libs"
 
 inherit autotools
 
-# I'm finishing this recipe during the 2.13.1 candidate release cycle
-# @todo Remove $RC later. See if patches are needed. Move files from /usr/*.
-# --  Leon 'likewise' Woestenberg
-
-#RC="-rc2"
-RC=""
 DEFAULT_PREFERENCE = "-1"
 
+# allows for a release candidate
+RC ?= ""
+
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/util-linux-ng/v${PV}/util-linux-ng-${PV}${RC}.tar.bz2"
 
 PACKAGES =+ "util-linux-ng-fdisk util-linux-ng-cfdisk util-linux-ng-sfdisk util-linux-ng-swaponoff util-linux-ng-losetup util-linux-ng-umount util-linux-ng-mount util-linux-ng-readprofile "
@@ -114,11 +111,11 @@ do_install () {
        install -d ${D}${sysconfdir}/default/
        echo 'MOUNTALL="-t nonfs,nosmbfs,noncpfs"' > ${D}${sysconfdir}/default/mountall
 
-       ln -sf ${base_sbindir}/swapon ${D}${base_sbindir}/swapoff.${PN}
-       ln -sf ${base_sbindir}/shutdown ${D}${base_sbindir}/reboot.${PN}
-       ln -sf ${base_sbindir}/shutdown ${D}${base_sbindir}/halt.${PN}
-       ln -sf ${base_sbindir}/shutdown ${D}${base_sbindir}/fastboot
-       ln -sf ${base_sbindir}/shutdown ${D}${base_sbindir}/fasthalt
+       ln -sf ${sbindir}/swapon ${D}${sbindir}/swapoff.${PN}
+       ln -sf ${sbindir}/shutdown ${D}${sbindir}/reboot.${PN}
+       ln -sf ${sbindir}/shutdown ${D}${sbindir}/halt.${PN}
+       ln -sf ${sbindir}/shutdown ${D}${sbindir}/fastboot
+       ln -sf ${sbindir}/shutdown ${D}${sbindir}/fasthalt
 }
 
 pkg_postinst_${PN} () {
index c10792e..946147d 100644 (file)
@@ -4,4 +4,4 @@ require util-linux-ng.inc
 #SRC_URI += "file://glibc-fix.patch;patch=1"
 #SRC_URI += "file://glibc-umount2.patch;patch=1"
 
-PR = "r0"
+PR = "r1"
index 587eb97..fdd911a 100644 (file)
@@ -1,6 +1,6 @@
 require util-linux-ng.inc
 
-PR = "r4"
+PR = "r5"
 FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/util-linux-ng-2.14', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
 
 SRC_URI += "file://util-linux-ng-uclibc-versionsort.patch;patch=1 \