bluez4: fix HUGE bug
authorKoen Kooi <koen@openembedded.org>
Sun, 12 Apr 2009 09:06:28 +0000 (11:06 +0200)
committerKoen Kooi <koen@openembedded.org>
Sun, 12 Apr 2009 09:06:28 +0000 (11:06 +0200)
* the recipe installed the .pc file, but not headers and libs, so application checking for bluez4 would actually build against bluez3 headers and libs
* for angstrom, replace bluez-libs3 with bluez4 at buildtime

conf/distro/angstrom-2008.1.conf
recipes/bluez/bluez4_4.35.bb

index e3e36d5..37cb8f0 100644 (file)
@@ -163,6 +163,7 @@ PREFERRED_PROVIDER_ntp                  ?= "ntp"
 PREFERRED_PROVIDER_hotplug               = "udev"
 PREFERRED_PROVIDER_libxss                = "libxss"
 PREFERRED_PROVIDER_bluez-utils-dbus      = "bluez-utils"
+PREFERRED_PROVIDER_bluez-libs            = "bluez4"
 
 # we don't ship gtk-directfb by default
 PREFERRED_PROVIDER_gtk+                   ?= "gtk+"
index 8c86a1a..fec1411 100644 (file)
@@ -5,6 +5,11 @@ DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
 HOMEPAGE = "http://www.bluez.org"
 LICENSE = "GPL"
 
+# For angstrom we want this to replace at least bluez-libs
+PROVIDES_append_angstrom = " bluez-libs"
+
+PR = "r1"
+
 SRC_URI = "\
   http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
   file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
@@ -13,10 +18,8 @@ SRC_URI = "\
 "
 S = "${WORKDIR}/bluez-${PV}"
 
-inherit autotools pkgconfig
-
-OE_LT_RPATH_ALLOW = "any"
-OE_LT_RPATH_ALLOW[export] = "1"
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
 
 EXTRA_OECONF = "\
   --enable-gstreamer \
@@ -56,6 +59,7 @@ FILES_${PN}-dev += "\
   ${libdir}/alsa-lib/*.la \
   ${libdir}/gstreamer-0.10/*.la \
 "
+
 FILES_${PN}-dbg += "\
   ${libdir}/bluetooth/plugins/.debug \
   ${libdir}/*/.debug \