grub: fix SECTION, sanitize, separate out -doc package. Closes 1838.
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>
Sun, 18 Feb 2007 03:22:54 +0000 (03:22 +0000)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Sun, 18 Feb 2007 03:22:54 +0000 (03:22 +0000)
packages/grub/grub_0.93.bb
packages/grub/grub_0.97.bb

index 8341184..9fc0084 100644 (file)
@@ -1,14 +1,15 @@
 DESCRIPTION = "GRUB is the GRand Unified Bootloader"
-SECTION = "base"
 HOMEPAGE = "http://www.gnu.org/software/grub"
+SECTION = "bootloaders"
+PRIORITY = "optional"
 
 SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz; \
           file://autohell.patch;patch=1 \
           file://memcpy.patch;patch=1 \
           file://reiserfs.patch;patch=1"
 
-S = "${WORKDIR}/grub-${PV}"
-
 inherit autotools
 
 COMPATIBLE_HOST = 'i.86.*-linux'
+
+FILES_${PN}-doc = "${datadir}"
index 051296a..044ecba 100644 (file)
@@ -1,10 +1,11 @@
-SECTION = "base"
-DESCRIPTION = "grand unified bootloader"
+DESCRIPTION = "GRUB is the GRand Unified Bootloader"
+HOMEPAGE = "http://www.gnu.org/software/grub"
+SECTION = "bootloaders"
+PRIORITY = "optional"
+PR = "r1"
 
 SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz"
 
-S = "${WORKDIR}/grub-${PV}"
-
 inherit autotools
 
 python __anonymous () {
@@ -19,4 +20,5 @@ do_install_append_vmware() {
        ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub
 }
 
+FILES_${PN}-doc = "${datadir}"
 FILES_${PN} = "/boot /usr"