pciutils: filter out flags that break gcc3
authorMartin Dietze <di@fh-wedel.de>
Wed, 20 May 2009 07:41:34 +0000 (09:41 +0200)
committerKoen Kooi <koen@openembedded.org>
Wed, 20 May 2009 08:12:39 +0000 (10:12 +0200)
* this is done with a nylon override since we lack gcc3 overrides

recipes/pciutils/pciutils-3.1.2/gcc-3-compatibility.patch [new file with mode: 0644]
recipes/pciutils/pciutils_3.1.2.bb

diff --git a/recipes/pciutils/pciutils-3.1.2/gcc-3-compatibility.patch b/recipes/pciutils/pciutils-3.1.2/gcc-3-compatibility.patch
new file mode 100644 (file)
index 0000000..3a10209
--- /dev/null
@@ -0,0 +1,11 @@
+--- pciutils-3.1.2/lib/Makefile-orig   2009-02-27 11:31:24.000000000 +0100
++++ pciutils-3.1.2/lib/Makefile        2009-02-27 11:31:32.000000000 +0100
+@@ -50,7 +50,7 @@
+       $(AR) rcs $@ $^
+       $(RANLIB) $@
+ else
+-CFLAGS += -fPIC -fvisibility=hidden
++CFLAGS += -fPIC 
+ $(PCILIB): $(addsuffix .o,$(OBJS))
+       $(CC) -shared $(LDFLAGS) $(SONAME) -Wl,--version-script=libpci.ver -o $@ $^ $(LIB_LDLIBS)
+ endif
index 25782a5..d7458a1 100644 (file)
@@ -8,6 +8,7 @@ DEPENDS = "zlib"
 
 SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
           file://pciutils.patch;patch=1 "
+SRC_URI_append_nylon = "file://gcc-3-compatibility.patch;patch=1 "
 
 PARALLEL_MAKE = ""