libbedic: fix build
authorJunqian Gordon Xu <xjqian@gmail.com>
Wed, 17 Sep 2008 20:49:12 +0000 (20:49 +0000)
committerJunqian Gordon Xu <xjqian@gmail.com>
Wed, 17 Sep 2008 20:49:12 +0000 (20:49 +0000)
* add DEPENDS = sqlite3
* add -DVERSION, introduced in 1.1, used as a string to set a db
property
in dynamic_library.cpp
* we don't want mkbedic and xerox on embedded devices
* add install, fix staging. (set DESTDIR to STAGING is wrong)

packages/zbedic/libbedic_1.1.bb

index 4ffb13c..c9e2ebf 100644 (file)
@@ -2,9 +2,10 @@ DESCRIPTION = "A dictionary application for Qt/E based Palmtop Environments"
 SECTION = "opie/applications"
 PRIORITY = "optional"
 LICENSE = "GPL"
+DEPENDS = "sqlite3"
 APPTYPE = "binary"
 APPDESKTOP = "${WORKDIR}/zbedic/misc"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/libbedic_${PV}-0.tgz"
 
@@ -12,18 +13,30 @@ S = "${WORKDIR}"
 
 inherit palmtop
 # need to override this, because bedic contains exception handling
-export OE_QMAKE_CXXFLAGS="-fexceptions -fno-rtti ${CXXFLAGS}"
+# pass VERSION as a string \\"${PV}.0\\"
+export OE_QMAKE_CXXFLAGS="-fexceptions -fno-rtti ${CXXFLAGS} -DVERSION=\\"${PV}.0\\""
 
+# no sharedlib, only as staticlib
 do_configure() {
-       qmake -project && qmake -makefile -t lib -spec ${QMAKESPEC} CONFIG=console CONFIG+=staticlib -after \
-        INCLUDEPATH+=../include TARGET=bedic DESTDIR=${STAGING_LIBDIR} \
-       HEADERS+=src/file.h SOURCES+=src/file.cpp SOURCES-=tools/xerox.cpp \
-       SOURCES-=src/test_dynamic_dictionary.cpp \
-       SOURCES-=src/test_dynamic_database.cpp \
-       CXXFLAGS+=-fexceptions
+        qmake -project && qmake -makefile -t lib -spec ${QMAKESPEC} CONFIG=console CONFIG+=staticlib CONFIG+=sharedlib -after \
+        TARGET=bedic \
+        SOURCES-=src/xerox.cpp OBJECTS-=xerox.o \
+        SOURCES-=src/mkbedic.cpp OBJECTS-=mkbedic.o \
+        SOURCES-=src/test_dynamic_dictionary.cpp \
+}
+
+do_install() {
+    install -d ${D}${includedir}
+    install -m 0644 ${S}/include/*.h ${D}${includedir}
+    install -d ${D}${libdir}
+    oe_libinstall -a libbedic ${D}${libdir}
 }
 
 do_stage() {
     install -d ${STAGING_INCDIR}/libbedic/
     install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/libbedic/
+    oe_libinstall -a libbedic ${STAGING_LIBDIR}
 }
+
+FILES_${PN} = "${libdir}"
+FILES_${PN}-dev = "${includedir}"